summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimao Gomes Viana2020-04-14 12:46:01 +0200
committerSimao Gomes Viana2020-04-15 21:05:40 +0200
commitff39328ef1747c540c9cbfee325e9c1a5c3b31c8 (patch)
treea20512bfce8ba2dced1333c6ba3a452b62e1b10f
parentdd450268325a7ad30b025e731741bff2d2b22aec (diff)
downloadaur-ff39328ef1747c540c9cbfee325e9c1a5c3b31c8.tar.gz
clean up and use correct naming
update preset checksum and update .SRCINFO update srcname
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--linux-nitrous-git.preset (renamed from linux-nitrous.preset)6
-rw-r--r--linux-nitrous.install37
4 files changed, 10 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8218c46c90e0..c70484057c88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,9 +15,9 @@ pkgbase = linux-nitrous-git
makedepends = coreutils
options = !strip
source = git+https://gitlab.com/xdevs23/linux-nitrous.git#branch=v5.6+
- source = linux-nitrous.preset
+ source = linux-nitrous-git.preset
sha256sums = SKIP
- sha256sums = 03a08e1df74541e9848685da38134d701684694c43e3428197c6db41e968f246
+ sha256sums = ecfa409b29641e070ef45baa9f866659e9f64ccbad8bedbb52f946c186d360ac
pkgname = linux-nitrous-git
pkgdesc = Modified Linux kernel optimized for Haswell (and newer) compiled using clang
@@ -29,7 +29,7 @@ pkgname = linux-nitrous-git
optdepends = crda: to set the correct wireless channels of your country
optdepends = linux-nitrous-git-headers: to build DKMS modules against this kernel
provides = linux
- backup = etc/mkinitcpio.d/linux-nitrous.preset
+ backup = etc/mkinitcpio.d/linux-nitrous-git.preset
pkgname = linux-nitrous-git-headers
pkgdesc = Header files and scripts for building modules for Linux kernel (git version)
diff --git a/PKGBUILD b/PKGBUILD
index ced3c494c896..452da6b475ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
# Contributor: Doug Johnson <dougvj at dougvj.net>
pkgbase=linux-nitrous-git
-_srcname=linux-nitrous
+_srcname=linux-nitrous-git
pkgver=5.6+
pkgrel=1
arch=('x86_64')
@@ -23,7 +23,7 @@ source=('git+https://gitlab.com/xdevs23/linux-nitrous.git#branch=v'"$pkgver"
# standard config files for mkinitcpio ramdisk
"${_srcname}.preset")
sha256sums=('SKIP'
- '03a08e1df74541e9848685da38134d701684694c43e3428197c6db41e968f246')
+ 'ecfa409b29641e070ef45baa9f866659e9f64ccbad8bedbb52f946c186d360ac')
_kernelname=${pkgbase#linux}
@@ -73,8 +73,8 @@ _package() {
'linux-nitrous-git-headers: to build DKMS modules against this kernel'
)
provides=('linux')
- __kernelname=linux-nitrous
- backup=("etc/mkinitcpio.d/linux-nitrous.preset")
+ __kernelname=linux-nitrous-git
+ backup=("etc/mkinitcpio.d/linux-nitrous-git.preset")
install=${pkgbase}.install
cd "${_srcname}"
diff --git a/linux-nitrous.preset b/linux-nitrous-git.preset
index e39a5658b31a..ee917ea42743 100644
--- a/linux-nitrous.preset
+++ b/linux-nitrous-git.preset
@@ -1,4 +1,4 @@
-# mkinitcpio preset file for the 'linux-git' package
+# mkinitcpio preset file for the 'linux-nitrous-git' package
ALL_config="/etc/mkinitcpio.conf"
ALL_kver="/boot/vmlinuz-linux-nitrous-git"
@@ -6,9 +6,9 @@ ALL_kver="/boot/vmlinuz-linux-nitrous-git"
PRESETS=('default' 'fallback')
#default_config="/etc/mkinitcpio.conf"
-default_image="/boot/initramfs-linux-nitrous.img"
+default_image="/boot/initramfs-linux-nitrous-git.img"
#default_options=""
#fallback_config="/etc/mkinitcpio.conf"
-fallback_image="/boot/initramfs-linux-nitrous-fallback.img"
+fallback_image="/boot/initramfs-linux-nitrous-git-fallback.img"
fallback_options="-S autodetect"
diff --git a/linux-nitrous.install b/linux-nitrous.install
deleted file mode 100644
index 6d43bb26375f..000000000000
--- a/linux-nitrous.install
+++ /dev/null
@@ -1,37 +0,0 @@
-# arg 1: the new package version
-# arg 2: the old package version
-
-KERNEL_NAME=
-KERNEL_VERSION=
-
-post_install () {
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p ${KERNEL_NAME}
-}
-
-post_upgrade() {
- if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
- echo "WARNING: /boot appears to be a separate partition but is not mounted."
- fi
-
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p ${KERNEL_NAME}
-
- if [ $(vercmp $2 3.13) -lt 0 ]; then
- echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
- echo ">>> In order to use your keyboard during early init, you MUST"
- echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
- fi
-}
-
-post_remove() {
- # also remove the compat symlinks
- rm -f boot/initramfs-linux${KERNEL_NAME}.img
- rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
-}