summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimao Gomes Viana2020-07-17 09:03:04 +0200
committerSimao Gomes Viana2020-07-17 09:03:04 +0200
commit66af3c6fbed186bd407c5302066a56a646b9fda4 (patch)
tree17ae67dab745f9e029fa3e7c6ca28f2e39aa0627
parent752670bd37660ed92c9e4d42c312b4c79c118cac (diff)
downloadaur-66af3c6fbed186bd407c5302066a56a646b9fda4.tar.gz
Fix build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62ca66af172d..c31f5bf04acc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-nitrous-git
pkgver = 5.7+
- pkgrel = 12
+ pkgrel = 13
url = https://gitlab.com/xdevs23/linux-nitrous
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 68d73f07f254..e7840b0f1e2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=linux-nitrous-git
_srcname=linux-nitrous-git
pkgver=5.7+
-pkgrel=12
+pkgrel=13
arch=('x86_64')
url="https://gitlab.com/xdevs23/linux-nitrous"
license=('GPL2')
@@ -32,7 +32,7 @@ pkgver() {
}
prepare() {
- cd "${_srcname}"
+ cd "linux-nitrous"
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
@@ -58,7 +58,7 @@ prepare() {
}
build() {
- cd "${_srcname}"
+ cd "linux-nitrous"
make HOSTCC=clang CC=clang nitrous_defconfig
makeflags="${MAKEFLAGS}"
@@ -80,7 +80,7 @@ _package() {
backup=("etc/mkinitcpio.d/linux-nitrous-git.preset")
install=${pkgbase}.install
- cd "${_srcname}"
+ cd "linux-nitrous"
KARCH=x86
@@ -142,7 +142,7 @@ _package-headers() {
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
- cd "${_srcname}"
+ cd "linux-nitrous"
# Fix for DKMS because clang doesn't like this
for f in Makefile kernel/Makefile; do
@@ -264,7 +264,7 @@ _package-docs() {
pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel (git version)"
provides=('linux-docs')
- cd "${_srcname}"
+ cd "linux-nitrous"
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build"
cp -al Documentation "${pkgdir}/usr/lib/modules/${_kernver}/build"