summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimao Gomes Viana2019-11-05 18:45:32 +0100
committerSimao Gomes Viana2019-11-05 18:45:32 +0100
commitd8e7f0027682e2594aa68be7faec4b15980b5985 (patch)
tree4abe5ab8f37dd475c83480773e7d8f62f15a8b12
parent7ee643a26b410cba707ce9cdb437f7a7a3360219 (diff)
downloadaur-d8e7f0027682e2594aa68be7faec4b15980b5985.tar.gz
Make naming more consistent
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b82e8026151..9e7d542e5eaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=linux-nitrous-git
_srcname=linux-nitrous
pkgver=5.3.8
-pkgrel=11
+pkgrel=12
arch=('x86_64')
url="https://gitlab.com/xdevs23/linux-nitrous"
license=('GPL2')
@@ -72,6 +72,7 @@ _package() {
provides=('linux')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
install=${pkgbase}.install
+ _kernelname=linux-nitrous
cd "${_srcname}"
@@ -84,7 +85,7 @@ _package() {
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot}
make CC=clang INSTALL_MOD_PATH="${pkgdir}" modules_install
- cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
+ cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${_kernelname}"
# set correct depmod command for install
cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
@@ -98,9 +99,9 @@ _package() {
install -D -m644 "${srcdir}/${pkgbase}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
sed \
-e "1s|'linux.*'|'${pkgbase}'|" \
- -e "s|ALL_kver=.*|ALL_kver=\"/boot/vmlinuz-${pkgbase}\"|" \
- -e "s|default_image=.*|default_image=\"/boot/initramfs-${pkgbase}.img\"|" \
- -e "s|fallback_image=.*|fallback_image=\"/boot/initramfs-${pkgbase}-fallback.img\"|" \
+ -e "s|ALL_kver=.*|ALL_kver=\"/boot/vmlinuz-${_kernelname}\"|" \
+ -e "s|default_image=.*|default_image=\"/boot/initramfs-${_kernelname}.img\"|" \
+ -e "s|fallback_image=.*|fallback_image=\"/boot/initramfs-${_kernelname}-fallback.img\"|" \
-i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
# remove build and source links