summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordamige2016-11-24 20:43:22 +0100
committerdamige2016-11-24 20:43:22 +0100
commite493ae6a2e3dc747a488371025aeffdfe7c58507 (patch)
treebbb1aabee1f0af3bd9b0f0635ab4c7178af8d16d
parent926a0997e0eb08e3a571d4e8706755307bd5b10c (diff)
downloadaur-e493ae6a2e3dc747a488371025aeffdfe7c58507.tar.gz
added localmodconfig
-rw-r--r--PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5382284afd8..b8fea8301810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -103,6 +103,18 @@ prepare() {
# get kernel version
make prepare
+ ### Optionally load needed modules for the make localmodconfig
+ # See https://aur.archlinux.org/packages/modprobed-db
+ if [ -n "$_localmodcfg" ]; then
+ msg "If you have modprobed-db installed, running it in recall mode now"
+ if [ -e /usr/bin/modprobed-db ]; then
+ [[ ! -x /usr/bin/sudo ]] && echo "Cannot call modprobe with sudo. Install$
+ sudo /usr/bin/modprobed-db recall
+ fi
+ msg "Running Steven Rostedt's make localmodconfig now"
+ make localmodconfig
+ fi
+
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
#make menuconfig # CLI menu for configuration