summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-04-24 22:30:14 +0200
committerjose17112016-04-24 22:30:14 +0200
commitdd19f19d75f1291dac46771d1d1f7bff86c48b27 (patch)
tree81a377745f0322e93c7ff0cf7d647929a861c661
parent573801a67cdd15da031f38404450eb865c035753 (diff)
downloadaur-dd19f19d75f1291dac46771d1d1f7bff86c48b27.tar.gz
updated upstream to 4.5.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d81a50e79b65..3647a7781d29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Sun Apr 17 20:06:06 UTC 2016
+# Sun Apr 24 20:27:06 UTC 2016
pkgbase = linux-pae
- pkgver = 4.5
+ pkgver = 4.5.1
pkgrel = 1
url = http://www.kernel.org/
arch = i686
@@ -14,11 +14,15 @@ pkgbase = linux-pae
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.5.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.5.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.5.1.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.5.1.sign
source = config
source = linux.preset
source = change-default-console-loglevel.patch
sha256sums = a40defb401e01b37d6b8c8ad5c1bbab665be6ac6310cdeed59950c96b31a519c
sha256sums = SKIP
+ sha256sums = 060ad091ebfa2b63d62e86beaf68c3a5d4638c506c3ac941c1825ba756e830b1
+ sha256sums = SKIP
sha256sums = 6c9f10c6c62854d5a8170381336d4e7fbbad83366dca956435d52fab404fc4ce
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
diff --git a/PKGBUILD b/PKGBUILD
index fba4a1d83888..b1c143b614fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Jose Riha
-# $Id: PKGBUILD 264859 2016-04-14 05:06:34Z tpowa $
+# $Id: PKGBUILD 265148 2016-04-19 06:55:26Z tpowa $
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-pae
#pkgbase=linux-pae
_srcname=linux-4.5
-pkgver=4.5
+pkgver=4.5.1
pkgrel=1
arch=(i686)
url="http://www.kernel.org/"
@@ -15,8 +15,8 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
# the main kernel config files
'config'
# standard config files for mkinitcpio ramdisk
@@ -25,6 +25,8 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
sha256sums=('a40defb401e01b37d6b8c8ad5c1bbab665be6ac6310cdeed59950c96b31a519c'
'SKIP'
+ '060ad091ebfa2b63d62e86beaf68c3a5d4638c506c3ac941c1825ba756e830b1'
+ 'SKIP'
'6c9f10c6c62854d5a8170381336d4e7fbbad83366dca956435d52fab404fc4ce'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
@@ -39,7 +41,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- # patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -49,7 +51,11 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- cat "${srcdir}/config" > ./.config
+ if [ "${CARCH}" = "x86_64" ]; then
+ cat "${srcdir}/config.x86_64" > ./.config
+ else
+ cat "${srcdir}/config" > ./.config
+ fi
if [ "${_kernelname}" != "" ]; then
sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config