aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhenning mueller2015-11-25 21:42:05 +0100
committerhenning mueller2015-11-25 21:42:05 +0100
commit8efffe4b08a2f513baf539533bbdf6b4098481cb (patch)
treed97942b126f7a1f771bb9ce255fa12dcb59e5a2b
parent86777e94b6bc95bcf7e962172dad84e21d42e979 (diff)
downloadaur-8efffe4b08a2f513baf539533bbdf6b4098481cb.tar.gz
2.0.18-1: prepend -> pretend
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xlinux-pax-flags.rb18
3 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ba93da94805..2dec83e27ef5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-pax-flags
pkgdesc = Deactivates PaX flags for several binaries to work with PaX enabled kernels.
- pkgver = 2.0.17
+ pkgver = 2.0.18
pkgrel = 1
url = https://github.com/nning/linux-pax-flags
arch = any
@@ -27,7 +27,7 @@ pkgbase = linux-pax-flags
source = valgrind.conf
source = wine.conf
sha256sums = 8581506830903ffcbb0876e4380d660ff044d9805d68f1432753c5bb99dc0db9
- sha256sums = 4eaab9347a35c39f13e23866da943b21e4e26bc882b066ef504e4374d9a79311
+ sha256sums = bb55348c4925aa208ca7fd3007a1aee669e3759c7772d0d012b8469082f4c527
sha256sums = 2020957abcd75d71b7f7dcca49eb3ff5f655eb69a306159eaf2e7d3a60c1ad5c
sha256sums = 29d27cf02b1683ed1017775c24476ec7cfcec3d69d2b2d4fd0263252ef01ce46
sha256sums = 5f81411fd2e7c15ceed6d04eb1a38bdcf6117b401e180c64b463e6d63e55827b
diff --git a/PKGBUILD b/PKGBUILD
index 0a2bf7df187f..51ce4405b448 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=linux-pax-flags
pkgdesc='Deactivates PaX flags for several binaries to work with PaX enabled kernels.'
-pkgver=2.0.17
+pkgver=2.0.18
pkgrel=1
arch=(any)
url='https://github.com/nning/linux-pax-flags'
@@ -38,7 +38,7 @@ package() {
}
sha256sums=('8581506830903ffcbb0876e4380d660ff044d9805d68f1432753c5bb99dc0db9'
- '4eaab9347a35c39f13e23866da943b21e4e26bc882b066ef504e4374d9a79311'
+ 'bb55348c4925aa208ca7fd3007a1aee669e3759c7772d0d012b8469082f4c527'
'2020957abcd75d71b7f7dcca49eb3ff5f655eb69a306159eaf2e7d3a60c1ad5c'
'29d27cf02b1683ed1017775c24476ec7cfcec3d69d2b2d4fd0263252ef01ce46'
'5f81411fd2e7c15ceed6d04eb1a38bdcf6117b401e180c64b463e6d63e55827b'
diff --git a/linux-pax-flags.rb b/linux-pax-flags.rb
index d5c00c9483a0..4fb35eb5c395 100755
--- a/linux-pax-flags.rb
+++ b/linux-pax-flags.rb
@@ -63,7 +63,7 @@ def usage
argument. Can contain globs (escape them in some shells
(zsh for example)).
-h, --help This help.
- -p, --prepend Do not change anything.
+ -p, --pretend Do not change anything.
-y, --yes Non-interactive mode. Assume yes on questions.
-x, --xattr Sets the PaX flags through setfattr, underlying
filesystems need xattr support.
@@ -122,14 +122,14 @@ trap(:INT) { exit 1 }
options = GetoptLong.new(
['--config', '-c', GetoptLong::REQUIRED_ARGUMENT],
['--help', '-h', GetoptLong::NO_ARGUMENT],
- ['--prepend', '-p', GetoptLong::NO_ARGUMENT],
+ ['--pretend', '-p', GetoptLong::NO_ARGUMENT],
['--xattr', '-x', GetoptLong::NO_ARGUMENT],
['--yes', '-y', GetoptLong::NO_ARGUMENT],
)
# Initialize option variables.
new_configs = []
-prepend = false
+pretend = false
yes = false
xattr = false
@@ -141,8 +141,8 @@ begin
new_configs = Dir.glob argument
when '--help'
usage
- when '--prepend'
- prepend = true
+ when '--pretend'
+ pretend = true
when '--xattr'
xattr = true
when '--yes'
@@ -246,7 +246,7 @@ each_entry config, filters do |flags, entry, pattern, path|
# If the entry is complex, stop it if it is running.
if entry.is_a? Hash
if status and system(status + '> /dev/null')
- system stop unless prepend
+ system stop unless pretend
start_again = true if start
end
end
@@ -262,8 +262,10 @@ each_entry config, filters do |flags, entry, pattern, path|
end
# Set the flags and notify the user.
- unless prepend
+ unless pretend
if xattr
+ # if system "paxctl -v '#{path}' &> /dev/null"
+ # end
`setfattr -n user.pax.flags -v #{xflags} "#{path}"`
else
header = 'c'
@@ -273,6 +275,6 @@ each_entry config, filters do |flags, entry, pattern, path|
end
# Start the complex entries service again, if it is neccessary.
- system start unless prepend if start_again
+ system start unless pretend if start_again
end
end