summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Devir2020-01-26 19:59:20 +1000
committerKyle Devir2020-01-26 19:59:20 +1000
commit0db5336c1f626e45c4711469270154f32bd31f73 (patch)
tree656be8194798c4c75c4554c1fe680cb68729f5d3
parent3239d807a9b1d8f9b0964615444af109523ae5d3 (diff)
downloadaur-0db5336c1f626e45c4711469270154f32bd31f73.tar.gz
Change echo back to msg2
-rw-r--r--PKGBUILD56
1 files changed, 28 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7a96cd3e6e0..3873fd120808 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -113,25 +113,25 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
prepare() {
cd $_reponame
- echo "Setting version..."
+ msg2 "Setting version..."
scripts/setlocalversion --save-scmversion
- echo "-$pkgrel" > localversion.10-pkgrel
- echo "${pkgbase#linux}" > localversion.20-pkgname
+ msg2 "-$pkgrel" > localversion.10-pkgrel
+ msg2 "${pkgbase#linux}" > localversion.20-pkgname
# https://github.com/graysky2/kernel_gcc_patch
- echo "Patching with Graysky's additional gcc CPU optimizatons..."
+ msg2 "Patching with Graysky's additional gcc CPU optimizatons..."
patch -Np1 -i "$srcdir/$_reponame_gcc_patch/$_gcc_patch_name"
# From https://github.com/Tk-Glitch/PKGBUILDS/tree/master/linux53-tkg/linux53-tkg-patches
- echo "Patching with Undead PDS 0.99o patches, rebased to 5.4 by TkG"
+ msg2 "Patching with Undead PDS 0.99o patches, rebased to 5.4 by TkG"
for MyPatch in 0005-v5.4_undead-pds099o.patch \
0005-glitched-pds.patch
do
- echo "Patching with $MyPatch..."
+ msg2 "Patching with $MyPatch..."
patch -Np1 -i "$srcdir/$MyPatch"
done
- echo "Setting config..."
+ msg2 "Setting config..."
cp ../config .config
if [ -n "$_subarch" ]; then
@@ -144,10 +144,10 @@ prepare() {
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
if [ -f $HOME/.config/modprobed.db ]; then
- echo "Running Steven Rostedt's make localmodconfig now"
+ msg2 "Running Steven Rostedt's make localmodconfig now"
make LSMOD=$HOME/.config/modprobed.db localmodconfig
else
- echo "No modprobed.db data found"
+ msg2 "No modprobed.db data found"
exit
fi
fi
@@ -158,7 +158,7 @@ prepare() {
yes "" | make config >/dev/null
make -s kernelrelease > version
- echo "Prepared %s version %s" "$pkgbase" "$(<version)"
+ msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
[[ -z "$_makenconfig" ]] || make nconfig
@@ -189,21 +189,21 @@ _package() {
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- echo "Installing boot image..."
+ msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
- echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+ msg2 "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
- echo "Installing modules..."
+ msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
- echo "Fixing permissions..."
+ msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -218,7 +218,7 @@ _package-headers() {
cd $_reponame
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- echo "Installing build files..."
+ msg2 "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
@@ -231,7 +231,7 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
- echo "Installing headers..."
+ msg2 "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
@@ -247,27 +247,27 @@ _package-headers() {
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
- echo "Installing KConfig files..."
+ msg2 "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
- echo "Removing unneeded architectures..."
+ msg2 "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
- echo "Removing $(basename "$arch")"
+ msg2 "Removing $(basename "$arch")"
rm -r "$arch"
done
- echo "Removing documentation..."
+ msg2 "Removing documentation..."
rm -r "$builddir/Documentation"
- echo "Removing broken symlinks..."
+ msg2 "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
- echo "Removing loose objects..."
+ msg2 "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
- echo "Stripping build tools..."
+ msg2 "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -bi "$file")" in
@@ -282,11 +282,11 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- echo "Adding symlink..."
+ msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
- echo "Fixing permissions..."
+ msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -296,7 +296,7 @@ _package-docs() {
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- echo "Installing documentation..."
+ msg2 "Installing documentation..."
local src dst
while read -rd '' src; do
dst="${src#Documentation/}"
@@ -304,11 +304,11 @@ _package-docs() {
install -Dm644 "$src" "$dst"
done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
- echo "Adding symlink..."
+ msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
- echo "Fixing permissions..."
+ msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}