summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2018-08-02 00:10:29 +0200
committerBjörn Bidar2018-08-02 02:19:17 +0200
commit8281e0ed7fcc3a863997a2f5f4e9af18a79089e5 (patch)
treeaa987c5207da1a5dc41cd3d19158f5145f1fcc5b
parent8b80d8c2156e8875a63360dcfc11a27ee3a34c5a (diff)
downloadaur-8281e0ed7fcc3a863997a2f5f4e9af18a79089e5.tar.gz
finally fix the package_linux-pf not defined bug.
The issue was the $CPU defined even on non optimized builds and messed up the evaluation of _package() to package_linux-pf()
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf2c782bd02e..f7900469c3f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -157,9 +157,9 @@ build() {
# enable $_BATCH_MODE if batch_opts is found in $srcdir
if [[ -e $srcdir/batch_opts ]] ; then
source "$srcdir/batch_opts"
- CPU=${CPU^^}
# enable cpu optimisations acording to $CPU and enable pkgopt
if [[ "$CPU" ]] ; then
+ CPU=${CPU^^}
sed -e "s|# CONFIG_M$CPU is not set|CONFIG_M$CPU=y|" \
-e '/CONFIG_GENERIC_CPU=y/d' \
-i "$srcdir/linux-${_basekernel}/.config"
@@ -284,7 +284,12 @@ build() {
fi
fi # batch check ends here
- export CPU
+
+ # only export non-generic
+ if [[ $CPU != GENERIC ]] ; then
+ export CPU
+ fi
+
#----------------------------------------
# Strip config of uneeded localversion
@@ -650,12 +655,15 @@ done
if in_array ${source[*]} batch_opts ; then #FIXME bugs updpkgsums
source batch_opts
- package[0]=linux-pf${CPU+-}$CPU
+ package[0]=linux-pf${CPU+-}${CPU,,}
fi
-eval "package_linux-pf${CPU+-}$CPU() {
- $(declare -f _package)
+
+eval "package_linux-pf${CPU+-$CPU,,}() {
+ $(declare -f "_package")
_package
}"
+
+
sha256sums=('9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13'
'102d518779dc312af35faf7e07ff01df3c04521d40d8757fc4e8eba9c595c395'
'622c9966585723a3a88ccabf83ecb7b64851c6acf9b0dd9862df5885b0d02907'