summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2018-11-25 10:05:09 +0100
committerBjörn Bidar2018-11-27 01:35:23 +0100
commitab4c731e0597ed9b7c0c70922f9cd5388034eab9 (patch)
tree28b78a7e4dee6322ab1bd2fd76f0dc65957dac8e
parentef6eab20c5880e99e1be0b9db9c114d49f5dc559 (diff)
downloadaur-ab4c731e0597ed9b7c0c70922f9cd5388034eab9.tar.gz
urel
- depend on linux-pf-preset - add symlink for systemd (see https://github.com/systemd/systemd/pull/9719)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9064b6841eac..e692f6a11df8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Nov 22 10:53:30 UTC 2018
+# Sun Nov 25 09:04:19 UTC 2018
pkgbase = linux-pf
pkgdesc = Linux kernel and modules with the pf-kernel patch (uksm, PDS).
pkgver = 4.19.5
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/post-factum/pf-kernel/wikis/README
arch = i686
arch = x86_64
@@ -40,6 +40,7 @@ pkgname = linux-pf
depends = linux-firmware
depends = kmod>=9-2
depends = mkinitcpio>=0.7
+ depends = linux-pf-preset
optdepends = linux-docs: Kernel hackers manual - HTML documentation that comes with the Linux kernel.
optdepends = crda: to set the correct wireless channels of your country
optdepends = pm-utils: utilities and scripts for suspend and hibernate power management
diff --git a/PKGBUILD b/PKGBUILD
index 29dba2dd217f..3bff6c201697 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -74,7 +74,7 @@ pkgname=('linux-pf')
pkgdesc="Linux kernel and modules with the pf-kernel patch (uksm, PDS)."
pkgname=('linux-pf' 'linux-pf-headers' 'linux-pf-preset-default')
pkgver=${_basekernel}.${_pfrel}
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="https://gitlab.com/post-factum/pf-kernel/wikis/README"
license=('GPL2')
@@ -315,7 +315,7 @@ _package() {
_pkgdesc="Linux kernel and modules with the pf-kernel patch (uksm, PDS)."
pkgdesc=${_pkgdesc}
groups=('base')
- depends=('coreutils' 'linux-firmware' 'kmod>=9-2' 'mkinitcpio>=0.7')
+ depends=('coreutils' 'linux-firmware' 'kmod>=9-2' 'mkinitcpio>=0.7' 'linux-pf-preset')
optdepends=('linux-docs: Kernel hackers manual - HTML documentation that comes with the Linux kernel.'
'crda: to set the correct wireless channels of your country'
'pm-utils: utilities and scripts for suspend and hibernate power management'
@@ -432,6 +432,8 @@ _package() {
### package_linux-pf
+ ### c/p from linux-ARCH
+
cd "${srcdir}/linux-${_basekernel}"
KARCH=x86
@@ -442,10 +444,15 @@ _package() {
mkdir -p "${pkgdir}"/usr/lib/modules
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
+
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-${pkgbase}"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
+
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "${pkgdir}/usr/lib/modules/vmlinuz"
- ### c/p from linux-ARCH
# make room for external modules
local _extramodules="extramodules-${_basekernel}${_kernelname:--ARCH}"