summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2018-03-05 23:53:40 +0100
committerBjörn Bidar2018-03-05 23:53:40 +0100
commitb820965d28bae883fe6b9afd1dc21b4964138884 (patch)
tree8d4cd11f8db2d678c6c2b591af869929eef5c751
parent842226a14b8d093fd71cd87454a5f099d4698c43 (diff)
downloadaur-b820965d28bae883fe6b9afd1dc21b4964138884.tar.gz
removed unused files
-rw-r--r--build_pkgs26
-rw-r--r--linux-pf.install65
-rw-r--r--linux-pf.preset14
-rw-r--r--makepkg.conf141
4 files changed, 0 insertions, 246 deletions
diff --git a/build_pkgs b/build_pkgs
deleted file mode 100644
index 4cc27232287b..000000000000
--- a/build_pkgs
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/bash
-# default config
-# default build arches
-CPU_ARCHES=( SANDYBRIDGE IVYBRIDGE HASWELL GENERIC)
-
-# init build dir
-mkdir -p build/src
-# copy all sources to build dir
-for src in PKGBUILD linux.install linux.preset config config.x86_64 *.patch ; do
- ln -s ../$src build/$src
-done
-# load local build script if found to apply gpg settings or alike, if existing
-if [ -e build_pkgs.local ] ; then
- source build_pkgs.local
-fi
-
-cd build
-# start building
-
-for cpu in ${CPU_ARCHES[*]} ; do
- mkdir src
- echo "CPU=$cpu" > src/batch_opts
- # use our config file for makepkg
- makepkg --config makepkg.conf -f
- rm -rf {src,pkg}
-done
diff --git a/linux-pf.install b/linux-pf.install
deleted file mode 100644
index 5d8536ffb891..000000000000
--- a/linux-pf.install
+++ /dev/null
@@ -1,65 +0,0 @@
-# arg 1: the new package version
-# arg 2: the old package version
-
-KERNEL_NAME=-pf
-KERNEL_VERSION=3.8.1-pf
-
-# set a sane PATH to ensure that critical utils like depmod will be found
-export PATH='/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'
-
-post_install () {
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
-
- # compat symlinks for the official kernels only
- if [ -z "${KERNEL_NAME}" -o "${KERNEL_NAME}" = "-lts" ]; then
- loaders="$(find /boot -name syslinux.cfg -or -name extlinux.conf -or -name grub.cfg -or -name menu.lst)"
- [ -f /etc/lilo.conf ] && loaders="$loaders /etc/lilo.conf"
- if [ -n "${loaders}" ] && grep -q -e vmlinuz26 -e kernel26.img -e kernel26-fallback.img $loaders; then
- # add compat symlinks for the initramfs images
- ln -sf initramfs-linux${KERNEL_NAME}.img boot/kernel26${KERNEL_NAME}.img
- ln -sf initramfs-linux${KERNEL_NAME}-fallback.img \
- boot/kernel26${KERNEL_NAME}-fallback.img
- ln -sf vmlinuz-linux${KERNEL_NAME} /boot/vmlinuz26${KERNEL_NAME}
- fi
- fi
-}
-
-post_upgrade() {
- pacman -Q grub &>/dev/null
- hasgrub=$?
- pacman -Q grub-common &>/dev/null
- hasgrub2=$?
- pacman -Q lilo &>/dev/null
- haslilo=$?
- # reminder notices
- if [ $haslilo -eq 0 ]; then
- echo ">>>"
- if [ $hasgrub -eq 0 -o $hasgrub2 -eq 0 ]; then
- echo ">>> If you use the LILO bootloader, you should run 'lilo' before rebooting."
- else
- echo ">>> You appear to be using the LILO bootloader. You should run"
- echo ">>> 'lilo' before rebooting."
- fi
- echo ">>>"
- fi
-
- if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
- echo "WARNING: /boot appears to be a separate partition but is not mounted."
- fi
-
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
-}
-
-post_remove() {
- # also remove the compat symlinks
- rm -f boot/{initramfs-linux,kernel26}${KERNEL_NAME}.img
- rm -f boot/{initramfs-linux,kernel26}${KERNEL_NAME}-fallback.img
-}
diff --git a/linux-pf.preset b/linux-pf.preset
deleted file mode 100644
index caaaee08d5e2..000000000000
--- a/linux-pf.preset
+++ /dev/null
@@ -1,14 +0,0 @@
-# mkinitcpio preset file for linux-pf
-
-ALL_config="/etc/mkinitcpio.conf"
-ALL_kver="/boot/vmlinuz-linux-pf"
-
-PRESETS=('default' 'fallback')
-
-#default_config="/etc/mkinitcpio.conf"
-default_image="/boot/initramfs-linux-pf.img"
-#default_options=""
-
-#fallback_config="/etc/mkinitcpio.conf"
-fallback_image="/boot/initramfs-linux-pf-fallback.img"
-fallback_options="-S autodetect"
diff --git a/makepkg.conf b/makepkg.conf
deleted file mode 100644
index 447fbef76eef..000000000000
--- a/makepkg.conf
+++ /dev/null
@@ -1,141 +0,0 @@
-#
-# /etc/makepkg.conf
-#
-
-#########################################################################
-# SOURCE ACQUISITION
-#########################################################################
-#
-#-- The download utilities that makepkg should use to acquire sources
-# Format: 'protocol::agent'
-DLAGENTS=('ftp::/usr/bin/wget -c --passive-ftp -t 3 --waitretry=3 -O %o %u'
- 'http::/usr/bin/wget -c -t 3 --waitretry=3 -O %o %u'
- 'https::/usr/bin/wget -c -t 3 --waitretry=3 --no-check-certificate -O %o %u'
- 'rsync::/usr/bin/rsync -z %u %o'
- 'scp::/usr/bin/scp -C %u %o' )
-
-# Other common tools:
-# /usr/bin/snarf
-# /usr/bin/lftpget -c
-# /usr/bin/curl
-
-#-- The package required by makepkg to download VCS sources
-# Format: 'protocol::package'
-VCSCLIENTS=('bzr::bzr'
- 'git::git'
- 'hg::mercurial'
- 'svn::subversion')
-
-#########################################################################
-# ARCHITECTURE, COMPILE FLAGS
-#########################################################################
-#
-CARCH="i686"
-CHOST="i686-arch-linux-gnu"
-
-#-- Exclusive: will only run on x86_64
-# -march (or -mcpu) builds exclusively for an architecture
-# -mtune optimizes for an architecture, but builds for whole processor family
-CFLAGS="-march=native -mtune=native -O2 -pipe"
-CXXFLAGS="-march=native -O2 -mtune=native -pipe"
-LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu"
-#-- Make Flags: change this for DistCC/SMP systems
-MAKEFLAGS="-j10"
-
-#########################################################################
-# BUILD ENVIRONMENT
-#########################################################################
-#
-# Defaults: BUILDENV=(fakeroot !distcc color !ccache check)
-# A negated environment option will do the opposite of the comments below.
-#
-#-- distcc: Use the Distributed C/C++/ObjC compiler
-#-- color: Colorize output messages
-#-- ccache: Use ccache to cache compilation
-#-- check: Run the check() function if present in the PKGBUILD
-#-- sign: Generate PGP signature file
-#
-
-BUILDENV=(fakeroot !distcc color !ccache check sign)
-#
-#-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
-#-- specify a space-delimited list of hosts running in the DistCC cluster.
-#DISTCC_HOSTS=""
-#-- Specify a directory for package building.
-#BUILDDIR=/tmp/makepkg
-
-#########################################################################
-# GLOBAL PACKAGE OPTIONS
-# These are default values for the options=() settings
-#########################################################################
-#
-# Default: OPTIONS=(strip docs libtool emptydirs zipman purge)
-# A negated option will do the opposite of the comments below.
-#
-#-- strip: Strip symbols from binaries/libraries
-#-- docs: Save doc directories specified by DOC_DIRS
-#-- libtool: Leave libtool (.la) files in packages
-#-- emptydirs: Leave empty directories in packages
-#-- zipman: Compress manual (man and info) pages in MAN_DIRS with gzip
-#-- purge: Remove files specified by PURGE_TARGETS
-#-- upx: Compress binary executable files using UPX
-#-- debug: Add debugging flags as specified in DEBUG_* variables
-#
-OPTIONS=(strip docs libtool emptydirs zipman purge)
-
-#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
-INTEGRITY_CHECK=(md5)
-#-- Options to be used when stripping binaries. See `man strip' for details.
-STRIP_BINARIES="--strip-all"
-#-- Options to be used when stripping shared libraries. See `man strip' for details.
-STRIP_SHARED="--strip-unneeded"
-#-- Options to be used when stripping static libraries. See `man strip' for details.
-STRIP_STATIC="--strip-debug"
-#-- Manual (man and info) directories to compress (if zipman is specified)
-MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
-#-- Doc directories to remove (if !docs is specified)
-DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
-#-- Files to be removed from all packages (if purge is specified)
-PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
-
-#########################################################################
-# PACKAGE OUTPUT
-#########################################################################
-#
-# Default: put built package and cached source in build directory
-#
-#-- Destination: specify a fixed directory where all packages will be placed
-PKGDEST=/home/share/public/aur_cache
-#-- Source cache: specify a fixed dixedrectory where source files will be cached
-SRCDEST=/home/share/Downloads/makepkg
-#-- Source packages: specify a fixed directory where all src packages will be placed
-#SRCPKGDEST=/home/srcpackages
-#-- Packager: name/email of the person or organization building packages
-PACKAGER="Björn Bidar <theodorstormgrade@gmail.com>"
-#-- Specify a key to use for package signing
-#GPGKEY=""
-
-#########################################################################
-# COMPRESSION DEFAULTS
-#########################################################################
-#
-COMPRESSGZ=(gzip -c -f -n)
-COMPRESSBZ2=(bzip2 -c -f)
-COMPRESSXZ=(xz -c -z -)
-COMPRESSLRZ=(lrzip -q)
-COMPRESSLZO=(lzop -q)
-COMPRESSZ=(compress -c -f)
-
-#########################################################################
-# EXTENSION DEFAULTS
-#########################################################################
-#
-# WARNING: Do NOT modify these variables unless you know what you are
-# doing.
-#
-PKGEXT='.pkg.tar.xz'
-SRCEXT='.src.tar.gz'
-
-# vim: set ft=sh ts=2 sw=2 et:
-#PKGDEST="/pkgdest"
-#SRCDEST="/srcdest"