summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2018-08-03 22:26:51 +0200
committerBjörn Bidar2018-08-03 22:26:51 +0200
commitdd413d658f586a165cbf7767fbc137bfa343e126 (patch)
tree888034b937eebacbee09e28a75d690ef54f23754
parentbdac75d2720777792453cb8b403a3e87b44aafa9 (diff)
downloadaur-dd413d658f586a165cbf7767fbc137bfa343e126.tar.gz
remove aur3 workaround and cleanup
aur3 workarounds no longer make sense and headers pkg is no longer changed depending on the optimisation.
-rw-r--r--PKGBUILD25
1 files changed, 1 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 824ce27d122f..a41ea38e8238 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -321,16 +321,10 @@ _package() {
'nvidia-beta-all: NVIDIA drivers for all installed kernels'
'modprobed-db: Keeps track of EVERY kernel module that has ever been probed. Useful for make localmodconfig.')
provides=('linux-tomoyo')
-
replaces=('kernel26-pf')
cd "${srcdir}/linux-${_basekernel}"
- # work around the AUR parser
- # This allows building cpu-optimized packages with according package names.
- # Useful for repo maintainers.
- headers="headers"
- pkgnameopt="${pkgbase}" # this MUST be outside the following 'if'
if [[ "$_PKGOPT" = "y" ]]; then # package naming according to optimization
case $CPU in
CORE2)
@@ -417,11 +411,6 @@ _package() {
pkgname="${pkgbase}-skylake"
pkgdesc="${_pkgdesc} 6th Gen Core processors including Skylake."
;;
- default)
- # Note to me: DO NOT EVER REMOVE THIS. It's for the AUR PKGBUILD parser.
- pkgname="${pkgbase}"
- pkgdesc="Linux kernel and modules with the pf-kernel patch (uksm, PDS)"
- ;;
esac
@@ -434,12 +423,7 @@ _package() {
echo
echo " ========================================"
- msg "The packages will be named ${pkgnameopt} and"
- if [[ "$cpuopt" ]]; then
- msg "and ${pkgbase}-${headers}-${cpuopt}"
- else
- msg "and ${pkgbase}-${headers}"
- fi
+ msg "The packages will be named ${pkgname}"
msg "${pkgdesc}"
echo " ========================================"
echo
@@ -624,13 +608,6 @@ _package-preset-default()
-i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
}
-# Work around the AUR parser
-pkgdesc="Linux kernel and modules with the pf-kernel patch (uksm, PDS)."
-
-# makepkg -g >>PKGBUILD
-
-
-
for _p in linux-pf-headers linux-pf-preset-default ; do
eval "package_${_p}() {
$(declare -f "_package${_p#${pkgbase}}")