summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2020-09-22 22:02:25 +0300
committerYurii Kolesnykov2020-09-22 22:02:25 +0300
commitc3a8ab48fa97ac0beabe0029a434655d98f215cf (patch)
treeb777303ef5efc9229ea09e87760c67c7c4784571
parent45ac25d93ff31201b029f9868ed7fe954f8ccaf4 (diff)
downloadaur-c3a8ab48fa97ac0beabe0029a434655d98f215cf.tar.gz
5.8
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--linux.install27
3 files changed, 16 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a682383d64d9..8cb2654395ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-pf-git
pkgdesc = Linux pf-kernel (git version)
- pkgver = 5.7.7.r190.g62a6be503ef8
+ pkgver = 5.8.5.r0.g6d112431d09f
pkgrel = 1
url = https://gitlab.com/post-factum/pf-kernel/-/wikis/README
arch = x86_64
@@ -16,14 +16,14 @@ pkgbase = linux-pf-git
makedepends = imagemagick
makedepends = git
options = !strip
- source = linux-pf-git::git+https://gitlab.com/post-factum/pf-kernel.git#branch=pf-5.7
+ source = linux-pf-git::git+https://gitlab.com/post-factum/pf-kernel.git#branch=pf-5.8
source = config
source = sphinx-workaround.patch
source = pf_defconfig
sha256sums = SKIP
- sha256sums = 6313ccad7f8e4d8ce09dd5bdb51b8dfa124d0034d7097ba47008380a14a84f09
+ sha256sums = 181330a9cf4517abbbe29b93165bc859ad8ca14a43582f4e1d69aae2b5ecc2c9
sha256sums = 8cb21e0b3411327b627a9dd15b8eb773295a0d2782b1a41b2a8839d1b2f5778c
- sha256sums = 02bd388f03fcdda5ed12e84f4f58f7239a05574755573026f8f1bfc6ce52a46e
+ sha256sums = 598d8639cd9a78695b025342b21e9e1de55b3d5093d037987e70024c8767b3ef
pkgname = linux-pf-git
pkgdesc = The Linux pf-kernel (git version) kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index 7aebb41992a3..67a12457920f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-pf-git
pkgdesc="Linux pf-kernel (git version)"
-pkgver=5.7.7.r190.g62a6be503ef8
+pkgver=5.8.5.r0.g6d112431d09f
_kernel_rel=5.8
_branch=pf-${_kernel_rel}
_product="${pkgbase%-git}"
@@ -73,7 +73,7 @@ build() {
make htmldocs
}
-_package-git() {
+_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
@@ -100,7 +100,7 @@ _package-git() {
rm -f "$modulesdir"/{source,build}
}
-_package-headers-git() {
+_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
cd $_srcname
@@ -178,7 +178,7 @@ _package-headers-git() {
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
-_package-docs-git() {
+_package-docs() {
pkgdesc="Documentation for the $pkgdesc kernel"
cd $_srcname
@@ -197,10 +197,12 @@ _package-docs-git() {
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
}
-pkgname=("$pkgbase" "$_product-headers-git" "$_product-docs-git")
-for _p in "${pkgname[@]}"; do
- eval "package_$_p() {
- $(declare -f "_package${_p#$_product}")
- _package${_p#$_product}
- }"
+pkgname=("${_product}-git" "${_product}-headers-git" "${_product}-docs-git")
+for _package in "${pkgname[@]}"; do
+ local _package_no_git="${_package%-git}"
+ local _package_stripped="${_package_no_git#$_product}"
+ eval "package_${_package}() {
+ $(declare -f "_package${_package_stripped}")
+ _package${_package_stripped}
+}"
done
diff --git a/linux.install b/linux.install
deleted file mode 100644
index 046277584140..000000000000
--- a/linux.install
+++ /dev/null
@@ -1,27 +0,0 @@
-post_install () {
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod %KERNVER%
-}
-
-post_upgrade() {
- if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
- echo "WARNING: /boot appears to be a separate partition but is not mounted."
- fi
-
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod %KERNVER%
-
- if [ $(vercmp $2 3.13) -lt 0 ]; then
- echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
- echo ">>> In order to use your keyboard during early init, you MUST"
- echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
- fi
-}
-
-post_remove() {
- # also remove the compat symlinks
- rm -f boot/initramfs-%PKGBASE%.img
- rm -f boot/initramfs-%PKGBASE%-fallback.img
-}