summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2020-07-31 22:58:16 +0300
committerYurii Kolesnykov2020-07-31 22:58:16 +0300
commitd06559f42b85bd6c0c44d261d3b4f5e44294a6b2 (patch)
tree8d0516f6047aa5002ed5b8b21231c0574594fa2d
parent0ef63caa6d26d436e78925c5998b315024ca9b82 (diff)
downloadaur-d06559f42b85bd6c0c44d261d3b4f5e44294a6b2.tar.gz
fix build
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--config9
3 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b309eeb649e..a682383d64d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = linux-pf-git
pkgdesc = Linux pf-kernel (git version)
- pkgver = 5.7.1.r19.ge0d757a395d1
+ pkgver = 5.7.7.r190.g62a6be503ef8
pkgrel = 1
- url = https://gitlab.com/post-factum/pf-kernel/wikis/README
+ url = https://gitlab.com/post-factum/pf-kernel/-/wikis/README
arch = x86_64
license = GPL2
makedepends = bc
@@ -18,12 +18,12 @@ pkgbase = linux-pf-git
options = !strip
source = linux-pf-git::git+https://gitlab.com/post-factum/pf-kernel.git#branch=pf-5.7
source = config
- source = pf_defconfig
source = sphinx-workaround.patch
+ source = pf_defconfig
sha256sums = SKIP
- sha256sums = 623601ed9d7879dd9dba1cd50fc8051f9db508b49b4fc0c47c5a9eb9165fc04e
- sha256sums = 02bd388f03fcdda5ed12e84f4f58f7239a05574755573026f8f1bfc6ce52a46e
+ sha256sums = 6313ccad7f8e4d8ce09dd5bdb51b8dfa124d0034d7097ba47008380a14a84f09
sha256sums = 8cb21e0b3411327b627a9dd15b8eb773295a0d2782b1a41b2a8839d1b2f5778c
+ sha256sums = 02bd388f03fcdda5ed12e84f4f58f7239a05574755573026f8f1bfc6ce52a46e
pkgname = linux-pf-git
pkgdesc = The Linux pf-kernel (git version) kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index a2e5419676aa..7894e73e9553 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgbase=linux-pf-git
pkgdesc="Linux pf-kernel (git version)"
-pkgver=5.7.1.r19.ge0d757a395d1
+pkgver=5.7.7.r190.g62a6be503ef8
_kernel_rel=5.7
_branch=pf-${_kernel_rel}
_product="${pkgbase%-git}"
pkgrel=1
arch=(x86_64)
-url="https://gitlab.com/post-factum/pf-kernel/wikis/README"
+url="https://gitlab.com/post-factum/pf-kernel/-/wikis/README"
license=(GPL2)
makedepends=(
bc kmod libelf pahole
@@ -21,12 +21,13 @@ _srcname="${pkgbase}"
source=(
"${_srcname}::git+https://gitlab.com/post-factum/pf-kernel.git#branch=${_branch}"
config
+ sphinx-workaround.patch
pf_defconfig
- sphinx-workaround.patch)
+)
sha256sums=('SKIP'
- '623601ed9d7879dd9dba1cd50fc8051f9db508b49b4fc0c47c5a9eb9165fc04e'
- '02bd388f03fcdda5ed12e84f4f58f7239a05574755573026f8f1bfc6ce52a46e'
- '8cb21e0b3411327b627a9dd15b8eb773295a0d2782b1a41b2a8839d1b2f5778c')
+ '6313ccad7f8e4d8ce09dd5bdb51b8dfa124d0034d7097ba47008380a14a84f09'
+ '8cb21e0b3411327b627a9dd15b8eb773295a0d2782b1a41b2a8839d1b2f5778c'
+ '02bd388f03fcdda5ed12e84f4f58f7239a05574755573026f8f1bfc6ce52a46e')
pkgver() {
cd "${_srcname}"
@@ -45,7 +46,6 @@ prepare() {
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
- # _pfrel=`git describe --abbrev=0 --tags| cut -d'-' -f2|sed 's/pf//g'`
local src
for src in "${source[@]}"; do
@@ -97,7 +97,7 @@ _package-git() {
make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
- rm "$modulesdir"/{source,build}
+ rm -f "$modulesdir"/{source,build}
}
_package-headers-git() {
diff --git a/config b/config
index 6c53679be371..1014972b9475 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.7.1-arch1 Kernel Configuration
+# Linux/x86 5.7.11-arch1 Kernel Configuration
#
#
@@ -1621,7 +1621,10 @@ CONFIG_VLAN_8021Q_MVRP=y
# CONFIG_DECNET is not set
CONFIG_LLC=m
CONFIG_LLC2=m
-# CONFIG_ATALK is not set
+CONFIG_ATALK=m
+CONFIG_DEV_APPLETALK=m
+CONFIG_IPDDP=m
+CONFIG_IPDDP_ENCAP=y
# CONFIG_X25 is not set
# CONFIG_LAPB is not set
CONFIG_PHONET=m
@@ -8778,6 +8781,8 @@ CONFIG_HWSPINLOCK=y
#
# Clock Source drivers
#
+CONFIG_TIMER_OF=y
+CONFIG_TIMER_PROBE=y
CONFIG_CLKEVT_I8253=y
CONFIG_I8253_LOCK=y
CONFIG_CLKBLD_I8253=y