summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerry2018-10-06 21:10:30 +0800
committerJerry2018-10-06 21:10:30 +0800
commit2286bef9d434e5c4c26d22250756d0900b8593e3 (patch)
tree8cea2a6035f10b28faa622c75879dca02d7890ff
parent60f42a45239061a0aa316409e36001c21cda0804 (diff)
downloadaur-2286bef9d434e5c4c26d22250756d0900b8593e3.tar.gz
led patch
-rw-r--r--PKGBUILD7
-rw-r--r--config2
-rw-r--r--pwm-led.patch37
3 files changed, 44 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aaec33bd7265..12decb6655ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,10 +18,12 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' '
options=('!strip')
source=("git+https://github.com/150balbes/Amlogic_s905-kernel.git"
'config'
+ 'pwm-led.patch'
'linux.preset'
'99-linux.hook')
md5sums=('SKIP'
- '68748ca1c69eedc93eb5109cadd7c5d4'
+ '44c200b0196238eb258d5fa3822200f8'
+ 'ff7f23f1bc3482651a4b7f4a33deb5fd'
'f6ee374f560e1b9df6a7de2399027d1b'
'd1c40c7367a7081f3b4c03264780f9d4')
@@ -33,6 +35,9 @@ prepare() {
# reset to a certain version
git reset --hard 0774525e710209a9e99136e5373b955f6c7defba
+ # led patch
+ patch -p1 < ../pwm-led.patch
+
cat "${srcdir}/config" > ./.config
# add pkgrel to extraversion
diff --git a/config b/config
index afb3ea3fb8b6..8ebed3661da0 100644
--- a/config
+++ b/config
@@ -3776,7 +3776,7 @@ CONFIG_LEDS_GPIO=y
# CONFIG_LEDS_PCA955X is not set
# CONFIG_LEDS_PCA963X is not set
# CONFIG_LEDS_DAC124S085 is not set
-# CONFIG_LEDS_PWM is not set
+CONFIG_LEDS_PWM=y
# CONFIG_LEDS_REGULATOR is not set
# CONFIG_LEDS_BD2802 is not set
# CONFIG_LEDS_LT3593 is not set
diff --git a/pwm-led.patch b/pwm-led.patch
new file mode 100644
index 000000000000..4cc2ad72e2b7
--- /dev/null
+++ b/pwm-led.patch
@@ -0,0 +1,37 @@
+diff --git a/arch/arm64/boot/dts/amlogic/meson-gxl-s905d-p230.dts b/arch/arm64/boot/dts/amlogic/meson-gxl-s905d-p230.dts
+index 15014faa2ab2..53b91e600842 100644
+--- a/arch/arm64/boot/dts/amlogic/meson-gxl-s905d-p230.dts
++++ b/arch/arm64/boot/dts/amlogic/meson-gxl-s905d-p230.dts
+@@ -41,6 +41,17 @@
+ };
+ };
+
++ pwmleds {
++ compatible = "pwm-leds";
++
++ power {
++ label = "phicomm:white:carlogo";
++ pwms = <&pwm_AO_ab 1 7812500 0>;
++ max-brightness = <255>;
++ linux,default-trigger = "mmc1";
++ };
++ };
++
+ hdmi-connector {
+ compatible = "hdmi-connector";
+ type = "a";
+@@ -60,6 +71,14 @@
+ hdmi-phandle = <&hdmi_tx>;
+ };
+
++&pwm_AO_ab {
++ status = "okay";
++ pinctrl-0 = <&pwm_ao_a_3_pins>, <&pwm_ao_b_pins>;
++ pinctrl-names = "default";
++ clocks = <&xtal> , <&xtal>;
++ clock-names = "clkin0", "clkin1" ;
++};
++
+ /* P230 has exclusive choice between internal or external PHY */
+ &ethmac {
+ pinctrl-0 = <&eth_pins>;