summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Chen2020-11-19 00:28:36 +0800
committerJack Chen2020-11-19 00:55:47 +0800
commit9af2328eedb0a85f1889db9ae5e9df60b9f1f56b (patch)
tree545f4577519eb2465fb87393045efadb72a443a5
parent561586b3e9d98e3e300e0e9f8157506d86553267 (diff)
downloadaur-9af2328eedb0a85f1889db9ae5e9df60b9f1f56b.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--59-linux-rockchip-remove.hook5
-rw-r--r--91-linux-rockchip-install.hook3
-rw-r--r--PKGBUILD22
4 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eedc5fe3d58f..8c2a8c6fe464 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,8 +24,8 @@ pkgbase = linux-rockchip
source = https://apt.armbian.com/pool/main/l/linux-5.8.16-rockchip/linux-image-current-rockchip_20.08.14_armhf.deb
source = https://apt.armbian.com/pool/main/l/linux-5.8.16-rockchip/linux-headers-current-rockchip_20.08.14_armhf.deb
sha512sums = c7a00e379d723d90c28c70069043a29800be40f120e36527b3aefe5b7acfbcd5680417c2cbf5ff2979c765456d4d5022ac10f01cfc65ab2e7cfb3a104bb670ce
- sha512sums = eb861063fa1fa8565651ee8e317a9d19f110380fe5a9e338c7975967d292dda973ef68350db40ddff93f8c2b0a5e719704a83bee3f9d8e806787f469c850ffa2
- sha512sums = 61120b67b38adfe0588d948cbc0b765795a5201daa47145d7f1088626dad82e6dbb207f9279397d4935175689dbf075da6f01d0d89aafaccc4d3ca68bf1d3b7f
+ sha512sums = 7f82e903345633a5f529a5e8472ba0a892de407e7fc0fa489e9652acc24301d4fa6fe5392ca271ec7f051aba2cfee8aa1d0e5134978453143ed998244b6c1459
+ sha512sums = 6f3ebed8b3c570e04de85dee76ef39f542e79e14994808a7a367128cd820441d506663af75bca0267288677aaf9e6566b0f338aa2ef7111398ee5766e2098eee
sha512sums = 723c3acdc7e3f56b7bb071b0d0ac8f284ba1bc2cb13aa318f30d431c49e635171492cd6648d601272259ed4e61f1ab3ac2555e182da9259d53fc148d0b3436ea
sha512sums = 59cea050cb3ca50d6e4c59fd7b2686eaf2762dd8da4bfaae360fb4410f615a5e2107d7c0789e75944620603707a6a6e817619d713c901633277c1fba9e5611d5
sha512sums = 961b8f97ad773d8c5da6d7ab3c5cb1268eea1aaff9ebaf2dc692a31aadb451a9a3ac6300078d2dd704e31e5cedb32aa43c023e991f5b592fd4ae7f01056407da
diff --git a/59-linux-rockchip-remove.hook b/59-linux-rockchip-remove.hook
index 5d511de76501..d93a07e6afd7 100644
--- a/59-linux-rockchip-remove.hook
+++ b/59-linux-rockchip-remove.hook
@@ -1,12 +1,13 @@
[Trigger]
Type = Path
Operation = Remove
-Target = boot/zImage
+Target = usr/lib/modules/*/vmlinuz
[Trigger]
Type = Package
Operation = Remove
-Target = linux-rockchip
+Target = mkinitcpio
+Target = mkinitcpio-git
[Action]
Description = Removing u-boot ramdisk image...
diff --git a/91-linux-rockchip-install.hook b/91-linux-rockchip-install.hook
index cf5a6ebc65ee..2e5520d0c94e 100644
--- a/91-linux-rockchip-install.hook
+++ b/91-linux-rockchip-install.hook
@@ -2,7 +2,8 @@
Type = Path
Operation = Install
Operation = Upgrade
-Target = boot/zImage
+Target = usr/lib/modules/*/vmlinuz
+Target = usr/lib/initcpio/*
[Action]
Description = Updating u-boot ramdisk image...
diff --git a/PKGBUILD b/PKGBUILD
index 3c94c6368fde..e41bf73c8161 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,17 +15,17 @@ _pkgfile=$(curl -s -L https://apt.armbian.com/dists/focal/main/binary-armhf/Pack
_kernver=$(cat Packages | grep 'linux-dtb-current-rockchip.*deb' | head -n 1 | sed -r 's#.*l/linux-(.*)/l.*#\1#')
source=(
- "linux-rockchip.preset"
- "59-linux-rockchip-remove.hook"
- "91-linux-rockchip-install.hook"
+ "$pkgname.preset"
+ "59-$pkgname-remove.hook"
+ "91-$pkgname-install.hook"
"$(cat Packages | grep 'linux-dtb-current-rockchip.*deb' | head -n 1 | sed -r 's#Filename: #https://apt.armbian.com/#')"
"$(cat Packages | grep 'linux-image-current-rockchip.*deb' | head -n 1 | sed -r 's#Filename: #https://apt.armbian.com/#')"
"$(cat Packages | grep 'linux-headers-current-rockchip.*deb' | head -n 1 | sed -r 's#Filename: #https://apt.armbian.com/#')"
)
sha512sums=(
'c7a00e379d723d90c28c70069043a29800be40f120e36527b3aefe5b7acfbcd5680417c2cbf5ff2979c765456d4d5022ac10f01cfc65ab2e7cfb3a104bb670ce'
- 'eb861063fa1fa8565651ee8e317a9d19f110380fe5a9e338c7975967d292dda973ef68350db40ddff93f8c2b0a5e719704a83bee3f9d8e806787f469c850ffa2'
- '61120b67b38adfe0588d948cbc0b765795a5201daa47145d7f1088626dad82e6dbb207f9279397d4935175689dbf075da6f01d0d89aafaccc4d3ca68bf1d3b7f'
+ '7f82e903345633a5f529a5e8472ba0a892de407e7fc0fa489e9652acc24301d4fa6fe5392ca271ec7f051aba2cfee8aa1d0e5134978453143ed998244b6c1459'
+ '6f3ebed8b3c570e04de85dee76ef39f542e79e14994808a7a367128cd820441d506663af75bca0267288677aaf9e6566b0f338aa2ef7111398ee5766e2098eee'
"$(cat Packages | grep 'linux-dtb-current-rockchip.*deb' -A 5 | grep SHA512 | head -n 1 | sed -r 's#SHA512: ##')"
"$(cat Packages | grep 'linux-image-current-rockchip.*deb' -A 5 | grep SHA512 | head -n 1 | sed -r 's#SHA512: ##')"
"$(cat Packages | grep 'linux-headers-current-rockchip.*deb' -A 5 | grep SHA512 | head -n 1 | sed -r 's#SHA512: ##')"
@@ -60,15 +60,15 @@ package_linux-rockchip() {
mkdir -p "$pkgdir/boot"
mv "boot/dtb-$_kernver" "$pkgdir/boot/dtb"
- install -Dm644 "boot/vmlinuz-$_kernver" "$pkgdir/boot/zImage"
+ ln -s "vmlinuz-$pkgname" "$pkgdir/boot/zImage"
+
+ install -Dm644 "boot/vmlinuz-$_kernver" "$pkgdir/usr/lib/modules/$_kernver/vmlinuz"
install -Dm644 "boot/config-$_kernver" "$pkgdir/usr/lib/modules/$_kernver/build/config"
install -Dm644 "boot/System.map-$_kernver" "$pkgdir/usr/lib/modules/$_kernver/build/System.map"
- install -Dm644 linux-rockchip.preset "$pkgdir/etc/mkinitcpio.d/linux-rockchip.preset"
- install -Dm644 59-linux-rockchip-remove.hook "$pkgdir/usr/share/libalpm/hooks/59-linux-rockchip-remove.hook"
- install -Dm644 91-linux-rockchip-install.hook "$pkgdir/usr/share/libalpm/hooks/91-linux-rockchip-install.hook"
-
- install -Dm644 /dev/null "$pkgdir/usr/lib/initcpio/hooks/$pkgname"
+ install -Dm644 "$pkgname.preset" "$pkgdir/etc/mkinitcpio.d/$pkgname.preset"
+ install -Dm644 "59-$pkgname-remove.hook" "$pkgdir/usr/share/libalpm/hooks/59-$pkgname-remove.hook"
+ install -Dm644 "91-$pkgname-install.hook" "$pkgdir/usr/share/libalpm/hooks/91-$pkgname-install.hook"
}
package_linux-rockchip-headers() {