summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Chen2020-11-27 13:55:04 +0800
committerJack Chen2020-11-27 13:55:04 +0800
commitbc1d677681a1659afc77ca3946c543ff5be30ebc (patch)
treecf9517935013f89d4a91ae348fc68e7a34228d29
parent18acd453d2b3eb22e2e649a69ca82e54f401c090 (diff)
downloadaur-bc1d677681a1659afc77ca3946c543ff5be30ebc.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b256656b37e..0be5a2567692 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,9 +15,9 @@ pkgbase = linux-rockchip
source = linux.preset
source = 60-linux.hook
source = 90-linux.hook
- source = linux-dtb-21.02.0-1.deb::https://beta.armbian.com/pool/main/l/linux-5.9.11-rockchip/linux-dtb-current-rockchip_21.02.0-trunk.1_armhf.deb
- source = linux-image-21.02.0-1.deb::https://beta.armbian.com/pool/main/l/linux-5.9.11-rockchip/linux-image-current-rockchip_21.02.0-trunk.1_armhf.deb
- source = linux-headers-21.02.0-1.deb::https://beta.armbian.com/pool/main/l/linux-5.9.11-rockchip/linux-headers-current-rockchip_21.02.0-trunk.1_armhf.deb
+ source = https://beta.armbian.com/pool/main/l/linux-5.9.11-rockchip/linux-dtb-current-rockchip_21.02.0-trunk.1_armhf.deb
+ source = https://beta.armbian.com/pool/main/l/linux-5.9.11-rockchip/linux-image-current-rockchip_21.02.0-trunk.1_armhf.deb
+ source = https://beta.armbian.com/pool/main/l/linux-5.9.11-rockchip/linux-headers-current-rockchip_21.02.0-trunk.1_armhf.deb
sha512sums = a492aae17ee4a316ce03faf9f1b284b2529c485f4b092cc4a1f865a6c68d482fd356fd30efa296c116975a3bdf3922f5bf03912a8d0e76f4ab24aa6ab9f8c276
sha512sums = 7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a
sha512sums = a8fc668de860cf7b44269e35f879d130ccbc7db84d159ffcac6a92c02324f09c08fb57cccad18332f423bf2153c928633fa681ee96482c778dc76bffe80dd4f5
@@ -42,3 +42,4 @@ pkgname = linux-rockchip-headers
pkgdesc = Header files and scripts for building modules for linux kernel - ARMv7 multi-platform Rockchip
provides = linux-headers=5.9.11
conflicts = linux-headers
+
diff --git a/PKGBUILD b/PKGBUILD
index f7b8cfab4db5..397d6a2b077c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,9 +17,9 @@ source=(
"linux.preset"
"60-linux.hook"
"90-linux.hook"
- "linux-dtb-$_armbver-$_armbrel.deb::https://beta.armbian.com/pool/main/l/linux-$_kernver/linux-dtb-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
- "linux-image-$_armbver-$_armbrel.deb::https://beta.armbian.com/pool/main/l/linux-$_kernver/linux-image-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
- "linux-headers-$_armbver-$_armbrel.deb::https://beta.armbian.com/pool/main/l/linux-$_kernver/linux-headers-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
+ "https://beta.armbian.com/pool/main/l/linux-$_kernver/linux-dtb-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
+ "https://beta.armbian.com/pool/main/l/linux-$_kernver/linux-image-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
+ "https://beta.armbian.com/pool/main/l/linux-$_kernver/linux-headers-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
)
sha512sums=(
'a492aae17ee4a316ce03faf9f1b284b2529c485f4b092cc4a1f865a6c68d482fd356fd30efa296c116975a3bdf3922f5bf03912a8d0e76f4ab24aa6ab9f8c276'
@@ -48,9 +48,9 @@ package_linux-rockchip() {
cd "$srcdir"
- ar x "linux-dtb-$_armbver-$_armbrel.deb"
+ ar x "linux-dtb-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
tar -xf data.tar.xz
- ar x "linux-image-$_armbver-$_armbrel.deb"
+ ar x "linux-image-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
tar -xf data.tar.xz
install -Dm644 "boot/vmlinuz-$_kernver" "$pkgdir/boot/zImage"
@@ -92,9 +92,9 @@ package_linux-rockchip-headers() {
cd "$srcdir"
- ar x "linux-image-$_armbver-$_armbrel.deb"
+ ar x "linux-image-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
tar -xf data.tar.xz
- ar x "linux-headers-$_armbver-$_armbrel.deb"
+ ar x "linux-headers-current-rockchip_$_armbver-trunk.${_armbrel}_armhf.deb"
tar -xf data.tar.xz
install -dm755 "$pkgdir/usr/lib/modules/$_kernver"