summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Chen2020-11-25 17:22:35 +0800
committerJack Chen2020-11-25 17:22:35 +0800
commitc9af4708e05b571ba9f25f7dc347153e1bddc163 (patch)
treeca5e8e1e621cb125018cb8a253e3008989e0db22
parenta159caf9eaecd0735d19d209809c4d224b169059 (diff)
downloadaur-c9af4708e05b571ba9f25f7dc347153e1bddc163.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63767349d649..a0bdabc5fbda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,9 +15,9 @@ pkgbase = linux-rockchip
source = linux.preset
source = 60-linux.hook
source = 90-linux.hook
- source = linux-dtb_20.11.0-5.8.18.deb::https://github.com/redchenjs/armbian-ci/releases/download/v5.8.18-rockchip/linux-dtb-current-rockchip_20.11.0-trunk_armhf.deb
- source = linux-image_20.11.0-5.8.18.deb::https://github.com/redchenjs/armbian-ci/releases/download/v5.8.18-rockchip/linux-image-current-rockchip_20.11.0-trunk_armhf.deb
- source = linux-headers_20.11.0-5.8.18.deb::https://github.com/redchenjs/armbian-ci/releases/download/v5.8.18-rockchip/linux-headers-current-rockchip_20.11.0-trunk_armhf.deb
+ source = linux-dtb-20.11.0-5.8.18.deb::https://github.com/redchenjs/armbian-ci/releases/download/v5.8.18-rockchip/linux-dtb-current-rockchip_20.11.0-trunk_armhf.deb
+ source = linux-image-20.11.0-5.8.18.deb::https://github.com/redchenjs/armbian-ci/releases/download/v5.8.18-rockchip/linux-image-current-rockchip_20.11.0-trunk_armhf.deb
+ source = linux-headers-20.11.0-5.8.18.deb::https://github.com/redchenjs/armbian-ci/releases/download/v5.8.18-rockchip/linux-headers-current-rockchip_20.11.0-trunk_armhf.deb
sha512sums = a492aae17ee4a316ce03faf9f1b284b2529c485f4b092cc4a1f865a6c68d482fd356fd30efa296c116975a3bdf3922f5bf03912a8d0e76f4ab24aa6ab9f8c276
sha512sums = 7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a
sha512sums = a8fc668de860cf7b44269e35f879d130ccbc7db84d159ffcac6a92c02324f09c08fb57cccad18332f423bf2153c928633fa681ee96482c778dc76bffe80dd4f5
diff --git a/PKGBUILD b/PKGBUILD
index c8fbae0b1c9c..598e362350d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,9 +16,9 @@ source=(
"linux.preset"
"60-linux.hook"
"90-linux.hook"
- "linux-dtb_$_armbian-$pkgver.deb::https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-dtb-current-rockchip_$_armbian-trunk_armhf.deb"
- "linux-image_$_armbian-$pkgver.deb::https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-image-current-rockchip_$_armbian-trunk_armhf.deb"
- "linux-headers_$_armbian-$pkgver.deb::https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-headers-current-rockchip_$_armbian-trunk_armhf.deb"
+ "linux-dtb-$_armbian-$pkgver.deb::https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-dtb-current-rockchip_$_armbian-trunk_armhf.deb"
+ "linux-image-$_armbian-$pkgver.deb::https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-image-current-rockchip_$_armbian-trunk_armhf.deb"
+ "linux-headers-$_armbian-$pkgver.deb::https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-headers-current-rockchip_$_armbian-trunk_armhf.deb"
)
sha512sums=(
"a492aae17ee4a316ce03faf9f1b284b2529c485f4b092cc4a1f865a6c68d482fd356fd30efa296c116975a3bdf3922f5bf03912a8d0e76f4ab24aa6ab9f8c276"
@@ -47,9 +47,9 @@ package_linux-rockchip() {
cd "$srcdir"
- ar x "linux-dtb_$_armbian-$pkgver.deb"
+ ar x "linux-dtb-$_armbian-$pkgver.deb"
tar -xf data.tar.xz
- ar x "linux-image_$_armbian-$pkgver.deb"
+ ar x "linux-image-$_armbian-$pkgver.deb"
tar -xf data.tar.xz
install -dm755 "$pkgdir/usr"
@@ -91,9 +91,9 @@ package_linux-rockchip-headers() {
cd "$srcdir"
- ar x "linux-image_$_armbian-$pkgver.deb"
+ ar x "linux-image-$_armbian-$pkgver.deb"
tar -xf data.tar.xz
- ar x "linux-headers_$_armbian-$pkgver.deb"
+ ar x "linux-headers-$_armbian-$pkgver.deb"
tar -xf data.tar.xz
install -dm755 "$pkgdir/usr/lib/modules/$_kernver"