summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Chen2020-11-23 13:46:28 +0800
committerJack Chen2020-11-23 13:46:28 +0800
commiteac9ddc20f73067043dd7f70a7e42bfd5cac67b4 (patch)
treec25d0d291d45dd7fac7b8aca3448e284cabb4f0b
parent40b58921d0fa0af8cd4629594c4e5c6f9cff1807 (diff)
downloadaur-eac9ddc20f73067043dd7f70a7e42bfd5cac67b4.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD39
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 808a4fdc446f..b39adb19e683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,9 +16,9 @@ pkgbase = linux-rockchip
source = https://github.com/redchenjs/armbian-ci/releases/download/v5.8.18-rockchip/linux-image-current-rockchip_20.11.0-trunk_armhf.deb
source = https://github.com/redchenjs/armbian-ci/releases/download/v5.8.18-rockchip/linux-headers-current-rockchip_20.11.0-trunk_armhf.deb
sha512sums = 4e479e5c010c5cd6105b104419bbf1886a60174535d17a34ae457f2744598d0f1c4e2b24dc989c038fa2c51b3d076e0acd3210e1492a87db68b1d43840e11e8a
- sha512sums = 7c6bb0e693ae97a5d1d7255c7656ec7558a23bac2258d004524c9e2320d92406ad739d974f1ab74c066285cd707f48e0a30935a3f1f16dd0d44ee6f08b8be031
- sha512sums = 7b37d88234484bad01a065fe5bf35d894b27c9bacc736cbf8d421708d7a0a958e43cb73b44adc9348c284d53828495f0d3c053c8bec06fbcd161e12472d0ae16
- sha512sums = f6614c1f51177e1113b471f69deee389a4e5a989c21759fb0aed0f493878c508114847567a5a866c22e8d8beaf2b84523f7ad5adc998fc324c51cf3a83556cb9
+ sha512sums = Not Found
+ sha512sums = Not Found
+ sha512sums = Not Found
pkgname = linux-rockchip
pkgdesc = Rockchip Linux kernel and modules from Armbian
@@ -33,3 +33,4 @@ pkgname = linux-rockchip-headers
pkgdesc = Headers and scripts for building modules for the linux-rockchip kernel
provides = linux-headers
provides = linux-headers-rockchip
+
diff --git a/PKGBUILD b/PKGBUILD
index 6c55032674ba..9fe8d5d6260e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,19 +9,18 @@ url="https://github.com/redchenjs/armbian-ci"
license=('GPL2')
makedepends=('findutils' 'curl')
options=('!strip')
-_kernver=$pkgver-rockchip
-_armbian=20.11.0-trunk
+_armbian=20.11.0
source=(
"mkinitcpio.preset"
- "https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-dtb-current-rockchip_${_armbian}_armhf.deb"
- "https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-image-current-rockchip_${_armbian}_armhf.deb"
- "https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-headers-current-rockchip_${_armbian}_armhf.deb"
+ "https://github.com/redchenjs/armbian-ci/releases/download/v$pkgver-rockchip/linux-dtb-current-rockchip_$_armbian-trunk_armhf.deb"
+ "https://github.com/redchenjs/armbian-ci/releases/download/v$pkgver-rockchip/linux-image-current-rockchip_$_armbian-trunk_armhf.deb"
+ "https://github.com/redchenjs/armbian-ci/releases/download/v$pkgver-rockchip/linux-headers-current-rockchip_$_armbian-trunk_armhf.deb"
)
sha512sums=(
'4e479e5c010c5cd6105b104419bbf1886a60174535d17a34ae457f2744598d0f1c4e2b24dc989c038fa2c51b3d076e0acd3210e1492a87db68b1d43840e11e8a'
- "$(curl -s -L https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-dtb-current-rockchip_${_armbian}_armhf.deb.sha512sum)"
- "$(curl -s -L https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-image-current-rockchip_${_armbian}_armhf.deb.sha512sum)"
- "$(curl -s -L https://github.com/redchenjs/armbian-ci/releases/download/v$_kernver/linux-headers-current-rockchip_${_armbian}_armhf.deb.sha512sum)"
+ "$(curl -s -L https://github.com/redchenjs/armbian-ci/releases/download/v$pkgver-rockchip/linux-dtb-current-rockchip_$_armbian-trunk_armhf.deb.sha512sum)"
+ "$(curl -s -L https://github.com/redchenjs/armbian-ci/releases/download/v$pkgver-rockchip/linux-image-current-rockchip_$_armbian-trunk_armhf.deb.sha512sum)"
+ "$(curl -s -L https://github.com/redchenjs/armbian-ci/releases/download/v$pkgver-rockchip/linux-headers-current-rockchip_$_armbian-trunk_armhf.deb.sha512sum)"
)
noextract=("${source[@]##*/}")
@@ -38,19 +37,19 @@ package_linux-rockchip() {
cd "$srcdir"
- ar x linux-dtb-current-rockchip_${_armbian}_armhf.deb
+ ar x linux-dtb-current-rockchip_$_armbian-trunk_armhf.deb
tar -xf data.tar.xz
- ar x linux-image-current-rockchip_${_armbian}_armhf.deb
+ ar x linux-image-current-rockchip_$_armbian-trunk_armhf.deb
tar -xf data.tar.xz
mkdir -p "$pkgdir/usr"
mv lib "$pkgdir/usr/lib"
mkdir -p "$pkgdir/boot"
- mv "boot/dtb-$_kernver" "$pkgdir/boot/dtb"
+ mv "boot/dtb-$pkgver-rockchip" "$pkgdir/boot/dtb"
- echo "$pkgbase" > "$pkgdir/usr/lib/modules/$_kernver/pkgbase"
- install -Dm644 "boot/vmlinuz-$_kernver" "$pkgdir/usr/lib/modules/$_kernver/vmlinuz"
+ echo "$pkgbase" > "$pkgdir/usr/lib/modules/$pkgver-rockchip/pkgbase"
+ install -Dm644 "boot/vmlinuz-$pkgver-rockchip" "$pkgdir/usr/lib/modules/$pkgver-rockchip/vmlinuz"
install -Dm644 "mkinitcpio.preset" "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
sed -r -i "s#\\\$pkgbase#$pkgbase#g" "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
@@ -62,17 +61,17 @@ package_linux-rockchip-headers() {
cd "$srcdir"
- ar x linux-image-current-rockchip_${_armbian}_armhf.deb
+ ar x linux-image-current-rockchip_$_armbian-trunk_armhf.deb
tar -xf data.tar.xz
- ar x linux-headers-current-rockchip_${_armbian}_armhf.deb
+ ar x linux-headers-current-rockchip_$_armbian-trunk_armhf.deb
tar -xf data.tar.xz
- mkdir -p "$pkgdir/usr/lib/modules/$_kernver"
- mv "usr/src/linux-headers-$_kernver" "$pkgdir/usr/lib/modules/$_kernver/build"
+ mkdir -p "$pkgdir/usr/lib/modules/$pkgver-rockchip"
+ mv "usr/src/linux-headers-$pkgver-rockchip" "$pkgdir/usr/lib/modules/$pkgver-rockchip/build"
- install -Dm644 "boot/config-$_kernver" "$pkgdir/usr/lib/modules/$_kernver/build/.config"
- install -Dm644 "boot/System.map-$_kernver" "$pkgdir/usr/lib/modules/$_kernver/build/System.map"
+ install -Dm644 "boot/config-$pkgver-rockchip" "$pkgdir/usr/lib/modules/$pkgver-rockchip/build/.config"
+ install -Dm644 "boot/System.map-$pkgver-rockchip" "$pkgdir/usr/lib/modules/$pkgver-rockchip/build/System.map"
mkdir -p "$pkgdir/usr/src"
- ln -s "../lib/modules/$_kernver/build" "$pkgdir/usr/src/$pkgbase"
+ ln -s "../lib/modules/$pkgver-rockchip/build" "$pkgdir/usr/src/$pkgbase"
}