summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Claude Graf2024-01-10 14:32:58 +0100
committerJean-Claude Graf2024-01-10 14:32:58 +0100
commitf46b23ddbadbb0b27689a303e2ab46eadffad41f (patch)
treecb6cdeb2cbb2a2515c35abe834fc4c0c5e3c0031
parent101bcd111fcce94ca6ebe5b3c0e3af595a72f3b5 (diff)
downloadaur-f46b23ddbadbb0b27689a303e2ab46eadffad41f.tar.gz
Update to 0.7.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 231b4a6945e3..01985870050d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-router
pkgdesc = Set Linux as router in one command
- pkgver = 0.6.7
+ pkgver = 0.7.1
pkgrel = 1
url = https://github.com/garywill/linux-router
arch = any
@@ -12,13 +12,12 @@ pkgbase = linux-router
depends = iptables
optdepends = hostapd: WiFi hotspot capability,
optdepends = iw: WiFi hotspot capability,
- optdepends = iwconfig: if iw can not recognize your adapter,
+ optdepends = iwconfig: if "iw" can not recognize your adapter,
optdepends = haveged: improve random entropy,
optdepends = qrencode: QR code support
provides = lnxrouter
provides = linuxrouter
- source = https://github.com/garywill/linux-router/archive/refs/tags/0.6.7.tar.gz
- md5sums = 486e4a6d5c202085f0f9367c5207d3e8
- sha256sums = 94d26e9e3bbe9b2bfe5b1b09fcb6237cf4623ad22f8b7698af2193e2ab78c338
+ source = linux-router-0.7.1.tar.gz::https://github.com/garywill/linux-router/archive/refs/tags/0.7.1.tar.gz
+ sha256sums = 5d919e8fc44b7b7114b6d9762e5282535bcbade19370e032c924496e1cec1696
pkgname = linux-router
diff --git a/PKGBUILD b/PKGBUILD
index 594f8519cce7..c4e92f085883 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
-# Maintainer: Jean-Claude Graf <jeanggi90[at]gmail[dot]com>
-
+# Maintainer: Jean-Claude Graf <mail@jeanclaudegraf.ch>
pkgname=linux-router
-pkgver=0.6.7
+pkgver=0.7.1
pkgrel=1
pkgdesc='Set Linux as router in one command'
url='https://github.com/garywill/linux-router'
-arch=('any')
-license=('LGPL')
-depends=('bash' 'procps-ng' 'iproute2' 'dnsmasq' 'iptables')
+arch=(any)
+license=(LGPL)
+depends=(bash procps-ng iproute2 dnsmasq iptables)
optdepends=(
'hostapd: WiFi hotspot capability',
'iw: WiFi hotspot capability',
- 'iwconfig: if 'iw' can not recognize your adapter',
+ 'iwconfig: if "iw" can not recognize your adapter',
'haveged: improve random entropy',
'qrencode: QR code support')
-provides=('lnxrouter' 'linuxrouter')
-source=("${url}/archive/refs/tags/${pkgver}.tar.gz")
-md5sums=('486e4a6d5c202085f0f9367c5207d3e8')
-sha256sums=('94d26e9e3bbe9b2bfe5b1b09fcb6237cf4623ad22f8b7698af2193e2ab78c338')
-
+provides=(lnxrouter linuxrouter)
+source=("$pkgname-$pkgver.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('5d919e8fc44b7b7114b6d9762e5282535bcbade19370e032c924496e1cec1696')
package() {
cd "$pkgname-$pkgver"
@@ -27,5 +24,4 @@ package() {
install -Dm644 README.md -t "$pkgdir/usr/share/doc/lnxrouter"
}
-
# vim: ts=2 sw=2 et: