summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Hernberg2016-12-07 14:39:25 +0100
committerJoakim Hernberg2016-12-07 14:39:25 +0100
commit5049b53dd61c9e94c5f0ec859dc9e7189ef3578c (patch)
tree740f9f38134c4429836f30210132e85a1b634553
parenta693cb5ffa806c813d48e19e49fa3ea7547f6e73 (diff)
downloadaur-5049b53dd61c9e94c5f0ec859dc9e7189ef3578c.tar.gz
bump to 4.8.11-rt7-2, add fix for CVE-2016-8655
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--fix_race_condition_in_packet_set_ring.diff84
3 files changed, 96 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cef2ef2959ab..8c3a2be49fa4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 5.0.1
-# Fri Dec 2 23:14:26 UTC 2016
+# Wed Dec 7 13:38:05 UTC 2016
pkgbase = linux-rt
pkgver = 4.8.11_rt7
- pkgrel = 1
- url = http://www.kernel.org/
+ pkgrel = 2
+ url = https://www.kernel.org/
arch = i686
arch = x86_64
license = GPL2
@@ -23,6 +23,7 @@ pkgbase = linux-rt
source = config
source = config.x86_64
source = linux-rt.preset
+ source = fix_race_condition_in_packet_set_ring.diff
source = change-default-console-loglevel.patch
source = fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT-160319.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
@@ -39,6 +40,7 @@ pkgbase = linux-rt
sha256sums = 109cec8e65336ac29b51f37ff8a581f1dfde7d42e4fb024b444fa51a635266bc
sha256sums = db2720d989a930022a27ca02e213f6cd3e006bfc59eb29d5e09bb925e682d9e0
sha256sums = 2abb6e506e4a687723d6a6dc21703f5d2b42a8956fbc3313e3da2b03c718c80d
+ sha256sums = ad1ee95f906f88d31fcdb9273cd08e02e8eda177449f0c98dc1bff8cbf1483c2
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
sha256sums = 85f7612edfa129210343d6a4fe4ba2a4ac3542d98b7e28c8896738e7e6541c06
diff --git a/PKGBUILD b/PKGBUILD
index 38be89368287..7a1af47703b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,9 @@ _srcname=linux-4.8
_pkgver=4.8.11
_rtpatchver=rt7
pkgver=${_pkgver}_${_rtpatchver}
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
-url="http://www.kernel.org/"
+url="https://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
@@ -27,6 +27,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
+ 'fix_race_condition_in_packet_set_ring.diff'
'change-default-console-loglevel.patch'
'fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT-160319.patch')
@@ -39,6 +40,7 @@ sha256sums=('3e9150065f193d3d94bcf46a1fe9f033c7ef7122ab71d75a7fb5a2f0c9a7e11a'
'109cec8e65336ac29b51f37ff8a581f1dfde7d42e4fb024b444fa51a635266bc'
'db2720d989a930022a27ca02e213f6cd3e006bfc59eb29d5e09bb925e682d9e0'
'2abb6e506e4a687723d6a6dc21703f5d2b42a8956fbc3313e3da2b03c718c80d'
+ 'ad1ee95f906f88d31fcdb9273cd08e02e8eda177449f0c98dc1bff8cbf1483c2'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'85f7612edfa129210343d6a4fe4ba2a4ac3542d98b7e28c8896738e7e6541c06')
@@ -63,6 +65,9 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+
+ msg "fix_race_condition_in_packet_set_ring.diff"
+ patch -p1 -i "${srcdir}/fix_race_condition_in_packet_set_ring.diff"
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
diff --git a/fix_race_condition_in_packet_set_ring.diff b/fix_race_condition_in_packet_set_ring.diff
new file mode 100644
index 000000000000..12048f611d1a
--- /dev/null
+++ b/fix_race_condition_in_packet_set_ring.diff
@@ -0,0 +1,84 @@
+From: Philip Pettersson <philip.pettersson@gmail.com>
+
+When packet_set_ring creates a ring buffer it will initialize a
+struct timer_list if the packet version is TPACKET_V3. This value
+can then be raced by a different thread calling setsockopt to
+set the version to TPACKET_V1 before packet_set_ring has finished.
+
+This leads to a use-after-free on a function pointer in the
+struct timer_list when the socket is closed as the previously
+initialized timer will not be deleted.
+
+The bug is fixed by taking lock_sock(sk) in packet_setsockopt when
+changing the packet version while also taking the lock at the start
+of packet_set_ring.
+
+Fixes: f6fb8f100b80 ("af-packet: TPACKET_V3 flexible buffer implementation.")
+Signed-off-by: Philip Pettersson <philip.pettersson@gmail.com>
+Signed-off-by: Eric Dumazet <edumazet@google.com>
+---
+ net/packet/af_packet.c | 18 ++++++++++++------
+ 1 file changed, 12 insertions(+), 6 deletions(-)
+
+diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
+index d2238b204691b8e4f2e3acb9bc167b553ba32d50..dd2332390c45bbff7c3fc5d259453f2e1ca352bf 100644
+--- a/net/packet/af_packet.c
++++ b/net/packet/af_packet.c
+@@ -3648,19 +3648,25 @@ packet_setsockopt(struct socket *sock, int level, int optname, char __user *optv
+
+ if (optlen != sizeof(val))
+ return -EINVAL;
+- if (po->rx_ring.pg_vec || po->tx_ring.pg_vec)
+- return -EBUSY;
+ if (copy_from_user(&val, optval, sizeof(val)))
+ return -EFAULT;
+ switch (val) {
+ case TPACKET_V1:
+ case TPACKET_V2:
+ case TPACKET_V3:
+- po->tp_version = val;
+- return 0;
++ break;
+ default:
+ return -EINVAL;
+ }
++ lock_sock(sk);
++ if (po->rx_ring.pg_vec || po->tx_ring.pg_vec) {
++ ret = -EBUSY;
++ } else {
++ po->tp_version = val;
++ ret = 0;
++ }
++ release_sock(sk);
++ return ret;
+ }
+ case PACKET_RESERVE:
+ {
+@@ -4164,6 +4170,7 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
+ /* Added to avoid minimal code churn */
+ struct tpacket_req *req = &req_u->req;
+
++ lock_sock(sk);
+ /* Opening a Tx-ring is NOT supported in TPACKET_V3 */
+ if (!closing && tx_ring && (po->tp_version > TPACKET_V2)) {
+ net_warn_ratelimited("Tx-ring is not supported.\n");
+@@ -4245,7 +4252,6 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
+ goto out;
+ }
+
+- lock_sock(sk);
+
+ /* Detach socket from network */
+ spin_lock(&po->bind_lock);
+@@ -4294,11 +4300,11 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
+ if (!tx_ring)
+ prb_shutdown_retire_blk_timer(po, rb_queue);
+ }
+- release_sock(sk);
+
+ if (pg_vec)
+ free_pg_vec(pg_vec, order, req->tp_block_nr);
+ out:
++ release_sock(sk);
+ return err;
+ }