summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2019-10-04 13:41:10 +0200
committerPiotr Gorski2019-10-04 13:41:10 +0200
commit59de190dae80789d5afcbd223ddac8dd60e4329c (patch)
treec8eae81c848345e15c58613dfaa5b9e2a7cd6e01
parente843b08b7798df495c1197960d050c46b3debe84 (diff)
downloadaur-59de190dae80789d5afcbd223ddac8dd60e4329c.tar.gz
Sync with Arch
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1de5ff9e8faf..58fcd9b1c238 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-rt-bfq
pkgver = 5.2.17.rt9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sirlucjan/bfq-mq-lucjan
arch = x86_64
license = GPL2
@@ -49,10 +49,10 @@ pkgname = linux-rt-bfq
pkgdesc = The Linux-rt-bfq kernel and modules with the RT patch.
install = linux.install
depends = coreutils
- depends = linux-firmware
- depends = mkinitcpio>=0.7
+ depends = kmod
+ depends = initramfs
optdepends = crda: to set the correct wireless channels of your country
- optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
+ optdepends = linux-firmware: firmware images needed for some devices
backup = etc/mkinitcpio.d/linux-rt-bfq.preset
pkgname = linux-rt-bfq-headers
diff --git a/PKGBUILD b/PKGBUILD
index e7523a08be08..efbf5057c300 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,7 @@ _rtpatchver=rt${_rtver}
pkgver=${_major}.${_minor}.${_rtpatchver}
_pkgver=${_major}.${_minor}
_srcname=linux-${_pkgver}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/sirlucjan/bfq-mq-lucjan"
license=('GPL2')
@@ -206,8 +206,9 @@ build() {
_package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the RT patch."
- depends=('coreutils' 'linux-firmware' 'mkinitcpio>=0.7')
- optdepends=('crda: to set the correct wireless channels of your country' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
+ depends=('coreutils' 'kmod' 'initramfs')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
install=linux.install
@@ -222,6 +223,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install