summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2019-10-12 14:29:33 +0200
committerPiotr Gorski2019-10-12 14:29:33 +0200
commit6f3607837f0918e5438a175d370ae2b72bdcd950 (patch)
tree9da323405eeb46dbb1b1a3e9c8ac1afdacaf9361
parent08ff65ecc84230dfb862fd723f6d8ade5cf0a309 (diff)
downloadaur-6f3607837f0918e5438a175d370ae2b72bdcd950.tar.gz
Removal of extramodules
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--60-linux.hook1
-rw-r--r--PKGBUILD42
3 files changed, 17 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee4d12974f97..5e6099324cb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-rt-bfq
pkgver = 5.2.19.rt11
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/sirlucjan/bfq-mq-lucjan
arch = x86_64
license = GPL2
@@ -42,7 +42,7 @@ pkgbase = linux-rt-bfq
sha512sums = f161775e50b28e9978393196a5bae0f7681312e62121f8dadbd8bcadea158f64f61af747b3a246ec3bea714133d77692ef5b69f8c3151110847ea259e95f5e36
sha512sums = 47fff20828fdef97241eb55fb91c05dbd5f8171200576d56f6d4d487c1fd7d7cb58be36c123c3f10eff49346fde54bb149e96fc4ed109d756c6288770db9800a
sha512sums = 8f6cdf859cf1c712749de734bb9ad5769ff03e2c426cdc3adad8db91adc447e8ca050d7752b30108363330e4b6ad881330c4dbcfdf357e87c6848dae409ef1f4
- sha512sums = 7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a
+ sha512sums = 6b57a66b870b2f525e2dedd8f224b89474fd4ec6ea18484b0a67a1a2b9a4fc95d025cac181504406ea42a35d6c1b184c0d4e38c92815022935fc55746c69c7c1
sha512sums = 2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7
sha512sums = 8742e2eed421e2f29850e18616f435536c12036ff793f5682a3a8c980cf5dbfc88d17fd9539c87de15d9e4663dc3190f964f18a4722940465437927b6052abbf
sha512sums = 2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf
diff --git a/60-linux.hook b/60-linux.hook
index b33873c854fb..584ce35372b0 100644
--- a/60-linux.hook
+++ b/60-linux.hook
@@ -4,7 +4,6 @@ Operation = Install
Operation = Upgrade
Operation = Remove
Target = usr/lib/modules/%KERNVER%/*
-Target = usr/lib/modules/%EXTRAMODULES%/*
[Action]
Description = Updating %PKGBASE% module dependencies...
diff --git a/PKGBUILD b/PKGBUILD
index e414f21f1dea..c1658f2a568d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,7 @@ _rtpatchver=rt${_rtver}
pkgver=${_major}.${_minor}.${_rtpatchver}
_pkgver=${_major}.${_minor}
_srcname=linux-${_pkgver}
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://github.com/sirlucjan/bfq-mq-lucjan"
license=('GPL2')
@@ -96,7 +96,7 @@ _kernelname=${pkgbase#linux}
: ${_kernelname:=-rt-bfq}
prepare() {
- cd ${_srcname}
+ cd $_srcname
### Add rt patch
msg2 "Add rt patch"
@@ -124,8 +124,8 @@ prepare() {
make olddefconfig
### Prepared version
- make -s kernelrelease > ../version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+ make -s kernelrelease > version
+ msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
### Optionally use running kernel's config
# code originally by nous; http://aur.archlinux.org/packages.php?ID=40191
@@ -142,7 +142,6 @@ prepare() {
fi
fi
-
### Optionally set tickrate to 1000
if [ -n "$_1k_HZ_ticks" ]; then
msg2 "Setting tick rate to 1k..."
@@ -200,7 +199,7 @@ prepare() {
}
build() {
- cd ${_srcname}
+ cd $_srcname
make bzImage modules htmldocs
}
@@ -214,11 +213,10 @@ _package() {
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
install=linux.install
+ cd $_srcname
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- cd $_srcname
-
msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
@@ -227,27 +225,18 @@ _package() {
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
-
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # a place for external modules,
- # with version file for building modules and running depmod from hook
- local extramodules="extramodules$_kernelname"
- local extradir="$pkgdir/usr/lib/modules/$extramodules"
- install -Dt "$extradir" -m644 ../version
- ln -sr "$extradir" "$modulesdir/extramodules"
-
# remove build and source links
rm "$modulesdir"/{source,build}
msg2 "Installing hooks..."
-
# sed expression for following substitutions
local subst="
s|%PKGBASE%|$pkgbase|g
s|%KERNVER%|$kernver|g
- s|%EXTRAMODULES%|$extramodules|g
"
# hack to allow specifying an initially nonexisting install file
@@ -272,12 +261,12 @@ _package-headers() {
pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
depends=('linux-rt-bfq')
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
cd $_srcname
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing build files..."
- install -Dt "$builddir" -m644 Makefile .config Module.symvers System.map vmlinux
+ install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
+ localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
@@ -288,7 +277,7 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
- # ???
+ # this is gone in v5.3
mkdir "$builddir/.tmp_versions"
msg2 "Installing headers..."
@@ -344,7 +333,7 @@ _package-headers() {
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
- ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
@@ -354,9 +343,8 @@ _package-docs() {
pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
depends=('linux-rt-bfq')
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
cd $_srcname
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing documentation..."
mkdir -p "$builddir"
@@ -373,7 +361,7 @@ _package-docs() {
mv "$src" "$dst"
rmdir -p --ignore-fail-on-non-empty "${src%/*}"
done < <(find "$builddir/Documentation/output" -type f -print0)
-
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
@@ -400,7 +388,7 @@ sha512sums=('76bf28dc803b6d90c4618c26ea7b95e6c72fb5931d70441447e4e5c271c08064322
'f161775e50b28e9978393196a5bae0f7681312e62121f8dadbd8bcadea158f64f61af747b3a246ec3bea714133d77692ef5b69f8c3151110847ea259e95f5e36'
'47fff20828fdef97241eb55fb91c05dbd5f8171200576d56f6d4d487c1fd7d7cb58be36c123c3f10eff49346fde54bb149e96fc4ed109d756c6288770db9800a'
'8f6cdf859cf1c712749de734bb9ad5769ff03e2c426cdc3adad8db91adc447e8ca050d7752b30108363330e4b6ad881330c4dbcfdf357e87c6848dae409ef1f4'
- '7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a'
+ '6b57a66b870b2f525e2dedd8f224b89474fd4ec6ea18484b0a67a1a2b9a4fc95d025cac181504406ea42a35d6c1b184c0d4e38c92815022935fc55746c69c7c1'
'2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7'
'8742e2eed421e2f29850e18616f435536c12036ff793f5682a3a8c980cf5dbfc88d17fd9539c87de15d9e4663dc3190f964f18a4722940465437927b6052abbf'
'2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf')