summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2015-11-02 18:26:15 +0100
committersirlucjan2015-11-02 18:26:15 +0100
commit6f76bfc1d4ba26962b06f526090ecf9a7cdf52a0 (patch)
tree0b7b147270901a2c23e7adef383ccad97a58e47c
parent66df070eea08b04c6a3b6dc488bc795f61866b54 (diff)
downloadaur-6f76bfc1d4ba26962b06f526090ecf9a7cdf52a0.tar.gz
Remove unneeded patch
-rw-r--r--.SRCINFO4
-rw-r--r--0000-fix_potential_deadlock_in_reqsk_queue_unlink.patch37
-rw-r--r--PKGBUILD12
3 files changed, 4 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9673afe2185..2c45aaf846de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-rt-bfq
pkgver = 4.1.10_rt11
- pkgrel = 1
+ pkgrel = 2
url = http://algo.ing.unimo.it
arch = i686
arch = x86_64
@@ -24,7 +24,6 @@ pkgbase = linux-rt-bfq
source = config
source = config.x86_64
source = fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT.patch
- source = 0000-fix_potential_deadlock_in_reqsk_queue_unlink.patch
sha512sums = 168ef84a4e67619f9f53f3574e438542a5747f9b43443363cb83597fcdac9f40d201625c66e375a23226745eaada9176eb006ca023613cec089349e91751f3c0
sha512sums = SKIP
sha512sums = 3b5cb5c8f494958c39a06a1b416e3e5a075a3c76c44f8bf1ae5a14deec9861407100c2ef59b0720e8fc0729b5c8422b4d819ff59f1f7ec4eed20c5ba8a95d6d5
@@ -40,7 +39,6 @@ pkgbase = linux-rt-bfq
sha512sums = 9b00cba261fef37390dc33ba6743e6176d053020207872d7ce18fd1264037a241cc578a19ed5e45e1447e26f24601707bdab5118e5e02abfb58cfabcfe69da74
sha512sums = 2679ad01ea2348844079e71b9e4d51d60a2cfe590958342261a5a1316fa929db68f9d4fb34bba7ed6a27101b6c1d12614e79f7d6dd8e7e52633aef0647c8dd48
sha512sums = 326dc571c072d4c47381852f16c00c8a7b27d11a5e6ff0f60f5e3a21d4a833c1e467dda1c2a5c04a6611af48bb6ef017f9183ea4ee578aab1a07e91e44d4e528
- sha512sums = bf8045913bc87df289cb6089b9428b2eb685ef3a745c7531b628111ba58ec33fb6e707a74ecdd53b6d59169c4354e02efff585ef16a1645ce5b04e54257f8f50
pkgname = linux-rt-bfq
pkgdesc = Linux Kernel and modules with the RT patch and the BFQ scheduler.
diff --git a/0000-fix_potential_deadlock_in_reqsk_queue_unlink.patch b/0000-fix_potential_deadlock_in_reqsk_queue_unlink.patch
deleted file mode 100644
index e5c38d40b07c..000000000000
--- a/0000-fix_potential_deadlock_in_reqsk_queue_unlink.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 83fccfc3940c4a2db90fd7e7079f5b465cd8c6af Mon Sep 17 00:00:00 2001
-From: Eric Dumazet <edumazet@google.com>
-Date: Thu, 13 Aug 2015 15:44:51 -0700
-Subject: inet: fix potential deadlock in reqsk_queue_unlink()
-
-When replacing del_timer() with del_timer_sync(), I introduced
-a deadlock condition :
-
-reqsk_queue_unlink() is called from inet_csk_reqsk_queue_drop()
-
-inet_csk_reqsk_queue_drop() can be called from many contexts,
-one being the timer handler itself (reqsk_timer_handler()).
-
-In this case, del_timer_sync() loops forever.
-
-Simple fix is to test if timer is pending.
-
-Fixes: 2235f2ac75fd ("inet: fix races with reqsk timers")
-Signed-off-by: Eric Dumazet <edumazet@google.com>
-Signed-off-by: David S. Miller <davem@davemloft.net>
-
-diff --git a/net/ipv4/inet_connection_sock.c b/net/ipv4/inet_connection_sock.c
-index 05e3145..1349571 100644
---- a/net/ipv4/inet_connection_sock.c
-+++ b/net/ipv4/inet_connection_sock.c
-@@ -593,7 +593,7 @@ static bool reqsk_queue_unlink(struct request_sock_queue *queue,
- }
-
- spin_unlock(&queue->syn_wait_lock);
-- if (del_timer_sync(&req->rsk_timer))
-+ if (timer_pending(&req->rsk_timer) && del_timer_sync(&req->rsk_timer))
- reqsk_put(req);
- return found;
- }
---
-cgit v0.10.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 3d3bb2d2d4da..518f0b5b8a87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,7 +55,7 @@ _srcname=linux-4.1
_pkgver=4.1.10
_rtpatchver=rt11
pkgver=${_pkgver}_${_rtpatchver}
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://algo.ing.unimo.it"
license=('GPL2')
@@ -79,8 +79,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux-rt-bfq.preset'
'change-default-console-loglevel.patch'
'config' 'config.x86_64'
- 'fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT.patch'
- '0000-fix_potential_deadlock_in_reqsk_queue_unlink.patch')
+ 'fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT.patch')
prepare() {
cd ${_srcname}
@@ -97,10 +96,6 @@ prepare() {
# Stops X from hanging on certain NVIDIA cards
msg "Fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT.patch"
patch -p1 -i "${srcdir}/fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT.patch"
-
- ### Fix https://bbs.archlinux.org/viewtopic.php?pid=1568197#p1568197
- msg "Fix potential deadlock in reqsk_queue_unlink"
- patch -Np1 -i "$srcdir/0000-fix_potential_deadlock_in_reqsk_queue_unlink.patch"
### set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
@@ -463,8 +458,7 @@ sha512sums=('168ef84a4e67619f9f53f3574e438542a5747f9b43443363cb83597fcdac9f40d20
'd9d28e02e964704ea96645a5107f8b65cae5f4fb4f537e224e5e3d087fd296cb770c29ac76e0ce95d173bc420ea87fb8f187d616672a60a0cae618b0ef15b8c8'
'9b00cba261fef37390dc33ba6743e6176d053020207872d7ce18fd1264037a241cc578a19ed5e45e1447e26f24601707bdab5118e5e02abfb58cfabcfe69da74'
'2679ad01ea2348844079e71b9e4d51d60a2cfe590958342261a5a1316fa929db68f9d4fb34bba7ed6a27101b6c1d12614e79f7d6dd8e7e52633aef0647c8dd48'
- '326dc571c072d4c47381852f16c00c8a7b27d11a5e6ff0f60f5e3a21d4a833c1e467dda1c2a5c04a6611af48bb6ef017f9183ea4ee578aab1a07e91e44d4e528'
- 'bf8045913bc87df289cb6089b9428b2eb685ef3a745c7531b628111ba58ec33fb6e707a74ecdd53b6d59169c4354e02efff585ef16a1645ce5b04e54257f8f50')
+ '326dc571c072d4c47381852f16c00c8a7b27d11a5e6ff0f60f5e3a21d4a833c1e467dda1c2a5c04a6611af48bb6ef017f9183ea4ee578aab1a07e91e44d4e528')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds