summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-04-13 15:56:24 +0200
committerPiotr Gorski2022-04-13 15:56:24 +0200
commit9a11f30a1f8e1f5648931d9fe0b1a286878489a9 (patch)
tree39349b556f16297a7cd403dce66627cd0f4d4168
parent6f1bc081e55369e7130f39244654b9447526b41c (diff)
downloadaur-9a11f30a1f8e1f5648931d9fe0b1a286878489a9.tar.gz
Smoothing
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD38
2 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 681f173e553a..00bdd1ab3241 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-rt-bfq-dev
pkgdesc = Linux RT-BFQ-dev
pkgver = 5.17.1.rt17
- pkgrel = 8
+ pkgrel = 9
url = https://github.com/sirlucjan/bfq-mq-lucjan
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index a43ca7c109fa..f2dbe3feb73f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,6 +43,12 @@ _localmodcfg=
# a new kernel is released, but again, convenient for package bumps.
_use_current=
+### Download bfq patchset
+# ATTENTION - one of two predefined values should be selected!
+# 'stable' - stable releases (recommended)
+# 'unstable' - dev releases
+_bfq_ver='stable'
+
### Do not edit below this line unless you know what you're doing
pkgbase=linux-rt-bfq-dev
@@ -54,7 +60,7 @@ _rtpatchver=rt${_rtver}
pkgver=${_major}.${_minor}.${_rtpatchver}
_pkgver=${_major}.${_minor}
_srcname=linux-${_pkgver}
-pkgrel=8
+pkgrel=9
pkgdesc='Linux RT-BFQ-dev'
arch=('x86_64')
url="https://github.com/sirlucjan/bfq-mq-lucjan"
@@ -65,18 +71,21 @@ makedepends=('bc' 'libelf' 'python-sphinx' 'python-sphinx_rtd_theme'
'texlive-latexextra' 'xmlto')
#_lucjanpath="https://raw.githubusercontent.com/sirlucjan/kernel-patches/master/${_major}"
_lucjanpath="https://gitlab.com/sirlucjan/kernel-patches/raw/master/${_major}"
-# Some patches for BFQ conflict with patches for BFQ-dev.
-# To use linux-bfq-dev smoothly apply bfq-reverts before bfq-dev patch.
-# Otherwise the kernel will not compile.
-#_bfq_rev_path="bfq-reverts-all"
-#_bfq_rev_patch="0001-bfq-reverts.patch"
-#_bfq_path="bfq-dev-lucjan"
-#_bfq_ver="v14"
-#_bfq_rel="r2K210223"
-#_bfq_patch="${_major}-${_bfq_path}-${_bfq_ver}-${_bfq_rel}.patch"
-_bfq_path="bfq-lucjan"
-_bfq_rel="r2K220408v1"
-_bfq_patch="${_major}-${_bfq_path}-${_bfq_rel}.patch"
+
+if [ "$_bfq_ver" = "stable" ]; then
+
+ _bfq_name='bfq-lucjan'
+ _bfq_ver='r2K220408v1'
+ _bfq_patch="${_major}-${_bfq_name}-${_bfq_ver}.patch"
+
+elif [ "$_bfq_ver" = "unstable" ]; then
+
+ _bfq_name='bfq-dev-lucjan'
+ _bfq_ver='r2K220408v3'
+ _bfq_patch="${_major}-${_bfq_name}-${_bfq_ver}.patch"
+
+fi
+
_compiler_path="cpu-patches-sep"
_compiler_patch="0001-cpu-${_major}-merge-graysky-s-patchset.patch"
@@ -84,8 +93,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.sign"
"http://www.kernel.org/pub/linux/kernel/projects/rt/${_major}/patch-${_pkgver}-${_rtpatchver}.patch.xz"
"http://www.kernel.org/pub/linux/kernel/projects/rt/${_major}/patch-${_pkgver}-${_rtpatchver}.patch.sign"
- #"${_lucjanpath}/${_bfq_rev_path}/${_bfq_rev_patch}"
- "${_lucjanpath}/${_bfq_path}/${_bfq_patch}"
+ "${_lucjanpath}/${_bfq_name}/${_bfq_patch}"
"${_lucjanpath}/${_compiler_path}/${_compiler_patch}"
"${_lucjanpath}/arch-patches-v10-sep/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch"
"${_lucjanpath}/arch-patches-v10-sep/0002-random-treat-bootloader-trust-toggle-the-same-way-as.patch"