summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-08-25 09:06:49 +0200
committerNicolas Iooss2018-08-25 09:06:49 +0200
commit43055732767dcbf4ccd4cf0aa07236dc1b849570 (patch)
tree455ca710b1583aaa26354d7fd2c9db1ecace8a69
parent822b52580a741cbda9246a86c433301d1f02b23e (diff)
downloadaur-43055732767dcbf4ccd4cf0aa07236dc1b849570.tar.gz
linux-selinux 4.18.4.arch1-1 update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
2 files changed, 29 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a38cc776085b..98e6b68cf0b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-selinux
- pkgver = 4.18.1.arch1
+ pkgver = 4.18.4.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v4.18.1-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v4.18.4-arch1
arch = x86_64
groups = selinux
license = GPL2
@@ -11,8 +11,10 @@ pkgbase = linux-selinux
makedepends = bc
makedepends = libelf
makedepends = git
+ makedepends = python-sphinx
+ makedepends = graphviz
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.18.1-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.18.4-arch1
source = config
source = 60-linux.hook
source = 90-linux.hook
diff --git a/PKGBUILD b/PKGBUILD
index a4e0501d0d19..99a9c9987dc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=linux-selinux
-_srcver=4.18.1-arch1
+_srcver=4.18.4-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git)
+makedepends=(xmlto kmod inetutils bc libelf git python-sphinx graphviz)
options=('!strip')
_srcname=archlinux-linux
groups=(selinux)
@@ -73,7 +73,7 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules
+ make bzImage modules htmldocs
}
_package() {
@@ -94,7 +94,7 @@ _package() {
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
- make INSTALL_MOD_PATH="$pkgdir/usr" DEPMOD=/doesnt/exist modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# a place for external modules,
# with version file for building modules and running depmod from hook
@@ -106,11 +106,7 @@ _package() {
# remove build and source links
rm "$modulesdir"/{source,build}
- msg2 "Running depmod..."
- depmod -b "$pkgdir/usr" -E Module.symvers -e "$kernver"
-
msg2 "Installing hooks..."
-
# sed expression for following substitutions
local subst="
s|%PKGBASE%|$pkgbase|g
@@ -207,6 +203,10 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -222,6 +222,22 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
+
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/share/doc"
+ ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
+
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}