summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-12-01 10:42:41 +0100
committerNicolas Iooss2018-12-01 10:42:41 +0100
commit69402ce99f1916632a1402e03939a01c28498562 (patch)
treef271e5c8e2ef572ae2f0896f14fbc7a3e2fa49b6
parentbd8535b7ba2d50de0dc1c30ae2b22d3b6f6e1cf3 (diff)
downloadaur-69402ce99f1916632a1402e03939a01c28498562.tar.gz
linux-selinux 4.19.4.arch1-1 update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--config5
3 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47886cff17b5..5e56aa368e60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-selinux
- pkgver = 4.19.2.arch1
+ pkgver = 4.19.4.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v4.19.2-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v4.19.4-arch1
arch = x86_64
groups = selinux
license = GPL2
@@ -14,7 +14,7 @@ pkgbase = linux-selinux
makedepends = python-sphinx
makedepends = graphviz
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.19.2-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.19.4-arch1
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -23,7 +23,7 @@ pkgbase = linux-selinux
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha256sums = SKIP
- sha256sums = ea284e0b349ce4742ad4419ce4a196e150487db8a0bb989e5078f1b3a5ea7cde
+ sha256sums = 46ad4e1653df351769908b75db7e297a422a332d9fba8045ab9d0843807a01a2
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
sha256sums = 75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
diff --git a/PKGBUILD b/PKGBUILD
index 874e1bd51e22..8ff3a1509d94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=linux-selinux
-_srcver=4.19.2-arch1
+_srcver=4.19.4-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -34,7 +34,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'ea284e0b349ce4742ad4419ce4a196e150487db8a0bb989e5078f1b3a5ea7cde'
+ '46ad4e1653df351769908b75db7e297a422a332d9fba8045ab9d0843807a01a2'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
@@ -88,13 +88,18 @@ _package() {
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
+
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
diff --git a/config b/config
index 862736eff2b3..cf81c2193879 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.2-arch1 Kernel Configuration
+# Linux/x86 4.19.3-arch1 Kernel Configuration
#
#
@@ -1603,6 +1603,7 @@ CONFIG_L2TP_V3=y
CONFIG_L2TP_IP=m
CONFIG_L2TP_ETH=m
CONFIG_STP=m
+CONFIG_GARP=m
CONFIG_MRP=m
CONFIG_BRIDGE=m
CONFIG_BRIDGE_IGMP_SNOOPING=y
@@ -1619,7 +1620,7 @@ CONFIG_NET_DSA_TAG_LAN9303=y
CONFIG_NET_DSA_TAG_MTK=y
CONFIG_NET_DSA_TAG_QCA=y
CONFIG_VLAN_8021Q=m
-# CONFIG_VLAN_8021Q_GVRP is not set
+CONFIG_VLAN_8021Q_GVRP=y
CONFIG_VLAN_8021Q_MVRP=y
# CONFIG_DECNET is not set
CONFIG_LLC=m