summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-12-16 17:47:28 +0100
committerNicolas Iooss2018-12-16 17:47:28 +0100
commitccbf6fc95f1f5c8040c411747f1ae7f76f571056 (patch)
tree29f0b8161566a61023906d9fa281a29e34ebc2ac
parent69402ce99f1916632a1402e03939a01c28498562 (diff)
downloadaur-ccbf6fc95f1f5c8040c411747f1ae7f76f571056.tar.gz
linux-selinux 4.19.8.arch1-1 update
-rw-r--r--.SRCINFO10
-rw-r--r--90-linux.hook2
-rw-r--r--PKGBUILD19
-rw-r--r--config2
4 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e56aa368e60..3b4f434d2cf6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-selinux
- pkgver = 4.19.4.arch1
+ pkgver = 4.19.8.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v4.19.4-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v4.19.8-arch1
arch = x86_64
groups = selinux
license = GPL2
@@ -14,7 +14,7 @@ pkgbase = linux-selinux
makedepends = python-sphinx
makedepends = graphviz
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.19.4-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.19.8-arch1
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -23,9 +23,9 @@ pkgbase = linux-selinux
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha256sums = SKIP
- sha256sums = 46ad4e1653df351769908b75db7e297a422a332d9fba8045ab9d0843807a01a2
+ sha256sums = e8f4f68a8a21f82879e4069fda76a796e860d60a71c9db4e45fb93d58734a03f
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
- sha256sums = 75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919
+ sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
pkgname = linux-selinux
diff --git a/90-linux.hook b/90-linux.hook
index be0d886539f4..fca45abe1a62 100644
--- a/90-linux.hook
+++ b/90-linux.hook
@@ -2,7 +2,7 @@
Type = File
Operation = Install
Operation = Upgrade
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
Target = usr/lib/initcpio/*
[Action]
diff --git a/PKGBUILD b/PKGBUILD
index 8ff3a1509d94..8c0648876c9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=linux-selinux
-_srcver=4.19.4-arch1
+_srcver=4.19.8-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -34,9 +34,9 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '46ad4e1653df351769908b75db7e297a422a332d9fba8045ab9d0843807a01a2'
+ 'e8f4f68a8a21f82879e4069fda76a796e860d60a71c9db4e45fb93d58734a03f'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
+ 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
_kernelname=${pkgbase#linux}
@@ -84,22 +84,19 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- local image="$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 "$(make -s image_name)" "$image"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- ln -sr "$image" "$modulesdir/vmlinuz"
-
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
diff --git a/config b/config
index cf81c2193879..efeb283b22a4 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.3-arch1 Kernel Configuration
+# Linux/x86 4.19.7-arch1 Kernel Configuration
#
#