summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshmilee2020-04-29 20:47:21 +0800
committershmilee2020-04-29 20:47:21 +0800
commitc7fe5d363aa03af762a1839ddf10f8f5db240aff (patch)
tree460b943ba6ca907440522dfb60fb9fb511c8bed0
parent7b84e9f99935e8393a062ebeb6e655877c7e18cd (diff)
downloadaur-c7fe5d363aa03af762a1839ddf10f8f5db240aff.tar.gz
rebuild by gcc 9.3.0-1;add sphinx-workaround.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--sphinx-workaround.patch15
3 files changed, 25 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdd0dbd07854..d4884a705d8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by makepkg 5.2.1
-# Mon Mar 16 12:47:08 UTC 2020
+# Wed Apr 29 12:14:51 UTC 2020
pkgbase = linux-shmilee
pkgver = 5.4.25
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -21,6 +21,7 @@ pkgbase = linux-shmilee
source = https://raw.githubusercontent.com/dolohow/uksm/150e27c4e7f66e4519c89573305eca8c42091f4d/v5.x/uksm-5.4.patch
source = linux-cjktty-5.3.patch::https://github.com/torvalds/linux/compare/v5.3...Gentoo-zh:5.3-utf8.patch
source = legacy-wireless-ioctls-4.9+.patch
+ source = sphinx-workaround.patch
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -34,6 +35,7 @@ pkgbase = linux-shmilee
sha256sums = 81d34bf02e771a126af5cb382d44a86dcc759c88b7c89fc7e5b7737731b9130e
sha256sums = 08b2eb809d889f18e8a0da1179c0ecc63ba37313a46c908e5f4c794c528fa63f
sha256sums = edfb9939840b8710d6ee0385a8e968609eef348295465bb087744c18ed3496e0
+ sha256sums = b7c814c8183e4645947a6dcc3cbf80431de8a8fd4e895b780f9a5fd92f82cb8e
sha256sums = 7ce388e429d8df479a721285e445e116c5ee41e3126a702862e59056460b655e
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
sha256sums = 75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919
diff --git a/PKGBUILD b/PKGBUILD
index 176ea605df25..5160739ad0e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,7 +41,7 @@ pkgbase=linux-shmilee
pkgname=("${pkgbase}" "${pkgbase}-headers" "${pkgbase}-docs")
_srcname=linux-${_LLL_VER}
pkgver=${_LLL_VER}.${_LLL_SUBVER}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -56,6 +56,7 @@ source=(
${_UKSM_PATCH}
${_CJKTTY_PATCH}
'legacy-wireless-ioctls-4.9+.patch'
+ 'sphinx-workaround.patch'
'config' # the main kernel config file
'60-linux.hook' # pacman hook for depmod
'90-linux.hook' # pacman hook for initramfs regeneration
@@ -73,6 +74,7 @@ sha256sums=('bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491'
'81d34bf02e771a126af5cb382d44a86dcc759c88b7c89fc7e5b7737731b9130e'
'08b2eb809d889f18e8a0da1179c0ecc63ba37313a46c908e5f4c794c528fa63f'
'edfb9939840b8710d6ee0385a8e968609eef348295465bb087744c18ed3496e0'
+ 'b7c814c8183e4645947a6dcc3cbf80431de8a8fd4e895b780f9a5fd92f82cb8e'
'7ce388e429d8df479a721285e445e116c5ee41e3126a702862e59056460b655e'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
@@ -107,6 +109,9 @@ prepare() {
msg "Patching source to reinstate the legacy wireless ioctls"
patch -Np2 -i ../legacy-wireless-ioctls-4.9+.patch
+ msg "Patching sphinx extensions for htmldocs"
+ patch -Np1 -i ../sphinx-workaround.patch
+
cp -Tf ../config .config
if [ "${_kernelname}" != "" ]; then
diff --git a/sphinx-workaround.patch b/sphinx-workaround.patch
new file mode 100644
index 000000000000..59aafa909b7b
--- /dev/null
+++ b/sphinx-workaround.patch
@@ -0,0 +1,15 @@
+diff --git i/Documentation/conf.py w/Documentation/conf.py
+index a8fe845832bc..2dae2e830c26 100644
+--- i/Documentation/conf.py
++++ w/Documentation/conf.py
+@@ -36,8 +36,8 @@ needs_sphinx = '1.3'
+ # Add any Sphinx extension module names here, as strings. They can be
+ # extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
+ # ones.
+-extensions = ['kerneldoc', 'rstFlatTable', 'kernel_include', 'cdomain',
+- 'kfigure', 'sphinx.ext.ifconfig', 'automarkup']
++extensions = ['kerneldoc', 'rstFlatTable', 'kernel_include',
++ 'kfigure', 'sphinx.ext.ifconfig']
+
+ # The name of the math extension changed on Sphinx 1.4
+ if (major == 1 and minor > 3) or (major > 1):