summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2024-01-10 18:55:10 +0100
committerChristopher Arndt2024-01-10 18:55:10 +0100
commit25ff38f6a33cc2b15bc80f10101e09f3aa8013f6 (patch)
tree197d6bb8e2284effd73847ad926b11c4d094603d
parent2a7d86d40dba557d1a9b5f568292cfe957133dbb (diff)
downloadaur-linux-show-player.tar.gz
New upstream version 0.6
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD56
2 files changed, 49 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9ddd49552f4..81bb5034455f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,37 @@
pkgbase = linux-show-player
pkgdesc = Cue player designed for stage productions
- pkgver = 0.5.3
+ pkgver = 0.6
pkgrel = 1
url = https://www.linux-show-player.org/
arch = any
+ groups = pro-audio
license = GPL3
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry
+ makedepends = python-wheel
+ depends = gobject-introspection-runtime
+ depends = gst-plugins-good
+ depends = python-pyalsa
+ depends = python-appdirs
+ depends = python-falcon
+ depends = python-humanize
+ depends = python-pyliblo
depends = python-pyqt5
depends = python-gobject
- depends = gst-plugins-good
depends = python-mido
+ depends = python-requests
depends = python-rtmidi
depends = python-sortedcontainers
depends = qt5-svg
optdepends = gst-libav: for larger format support
+ optdepends = gst-plugins-bad: for larger format support
+ optdepends = gst-plugins-ugly: for larger format support
optdepends = ola: for Art-Net timecode support
- optdepends = python-protobuf: for Art-Net timecode support
- optdepends = portmidi: for portmidi support
optdepends = python-jack-client: for JACK output support
+ optdepends = python-protobuf: for Art-Net timecode support
options = !emptydirs
- source = linux-show-player-0.5.3.tar.gz::https://github.com/FrancescoCeruti/linux-show-player/archive/v0.5.3.tar.gz
- sha256sums = e5b70def979984053bae1023210f4c568f989f7714d712506911de6ea3837d0b
+ source = linux-show-player-0.6.tar.gz::https://github.com/FrancescoCeruti/linux-show-player/archive/v0.6.tar.gz
+ sha256sums = bc98f0afc73519e32614d987072f22e0df09677979202b2625e45f6c63d39d9b
pkgname = linux-show-player
diff --git a/PKGBUILD b/PKGBUILD
index f90294d5d201..1092d6f360ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,41 @@
# Maintainer: Marco Asa <marcoasa90[at]gmail[dot]com>
-# Contributor: Christopher Arndt <chris at chrisarndt.de>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=linux-show-player
-pkgver=0.5.3
+pkgver=0.6
pkgrel=1
-pkgdesc="Cue player designed for stage productions"
-url="https://www.linux-show-player.org/"
-arch=('any')
-license=('GPL3')
-depends=('python-pyqt5' 'python-gobject' 'gst-plugins-good' 'python-mido'
- 'python-rtmidi' 'python-sortedcontainers' 'qt5-svg')
-makedepends=('python-setuptools')
-optdepends=('gst-libav: for larger format support'
- 'ola: for Art-Net timecode support'
- 'python-protobuf: for Art-Net timecode support'
- 'portmidi: for portmidi support'
- 'python-jack-client: for JACK output support')
+pkgdesc='Cue player designed for stage productions'
+url='https://www.linux-show-player.org/'
+arch=(any)
+license=(GPL3)
+depends=(gobject-introspection-runtime gst-plugins-good
+ python-pyalsa python-appdirs python-falcon python-humanize
+ python-pyliblo python-pyqt5 python-gobject python-mido
+ python-requests python-rtmidi python-sortedcontainers qt5-svg)
+makedepends=(python-build python-installer python-poetry python-wheel)
+groups=(pro-audio)
+optdepends=(
+ 'gst-libav: for larger format support'
+ 'gst-plugins-bad: for larger format support'
+ 'gst-plugins-ugly: for larger format support'
+ 'ola: for Art-Net timecode support'
+ 'python-jack-client: for JACK output support'
+ 'python-protobuf: for Art-Net timecode support'
+)
options=('!emptydirs')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/FrancescoCeruti/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('e5b70def979984053bae1023210f4c568f989f7714d712506911de6ea3837d0b')
-
+source=("$pkgname-$pkgver.tar.gz::https://github.com/FrancescoCeruti/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('bc98f0afc73519e32614d987072f22e0df09677979202b2625e45f6c63d39d9b')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- python setup.py build
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- python setup.py install --root="${pkgdir}/" --prefix=/usr --optimize=1 --skip-build
- install -Dm644 dist/linuxshowplayer.desktop -t "${pkgdir}/usr/share/applications"
- install -Dm644 dist/linuxshowplayer.png -t "${pkgdir}/usr/share/pixmaps"
- install -Dm644 dist/linuxshowplayer.xml -t "${pkgdir}/usr/share/mime/packages"
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 dist/linuxshowplayer.desktop -t "$pkgdir"/usr/share/applications
+ install -Dm644 dist/linuxshowplayer.png -t "$pkgdir"/usr/share/pixmaps
+ install -Dm644 dist/linuxshowplayer.xml -t "$pkgdir"/usr/share/mime/packages
+ install -Dm644 dist/linuxshowplayer.metainfo.xml -t "$pkgdir"/usr/share/metainfo
}