summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEgor Tensin2022-04-11 04:22:05 +0200
committerEgor Tensin2022-04-11 04:22:05 +0200
commit20e56172f3d14afbc50842b1f9f7d0f6c2c95530 (patch)
treea99be930b198cfc878be3ff57c5561665981af7c
parentba75cc6cb68ba60bd1e9b10e675fda7f60e64f38 (diff)
downloadaur-20e56172f3d14afbc50842b1f9f7d0f6c2c95530.tar.gz
aur: 2.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac0d095d560f..8b7615cee1da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-status
- pkgdesc = Simple Linux status web page
- pkgver = 1.2
- pkgrel = 2
+ pkgdesc = Simple Linux server monitoring
+ pkgver = 2.0
+ pkgrel = 1
url = https://github.com/egor-tensin/linux-status
install = linux-status.install
arch = any
@@ -9,7 +9,7 @@ pkgbase = linux-status
depends = procps-ng
depends = python
depends = systemd
- source = linux-status-1.2.tar.gz::https://github.com/egor-tensin/linux-status/archive/v1.2.tar.gz
+ source = linux-status-2.0.tar.gz::https://github.com/egor-tensin/linux-status/archive/v2.0.tar.gz
md5sums = SKIP
pkgname = linux-status
diff --git a/PKGBUILD b/PKGBUILD
index c7901ef44224..75b874bf4854 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Egor Tensin <Egor.Tensin@gmail.com>
pkgname=linux-status
-pkgver=1.2
-pkgrel=2
-pkgdesc='Simple Linux status web page'
+pkgver=2.0
+pkgrel=1
+pkgdesc='Simple Linux server monitoring'
arch=(any)
url='https://github.com/egor-tensin/linux-status'
license=(MIT)
@@ -21,14 +21,12 @@ package() {
install -D -m 0644 -t "$pkgdir/usr/share/linux-status" LICENSE.txt
install -D -m 0644 -t "$pkgdir/usr/share/doc/linux-status" README.md
- find img -type f -exec install -D -m 0644 -t "$pkgdir/srv/linux-status/img" {} ';'
+ install -D -m 0644 -t "$pkgdir/usr/share/doc/linux-status/doc" doc/example.png
- install -D -m 0755 -t "$pkgdir/srv/linux-status" app.py
- install -D -m 0755 -t "$pkgdir/srv/linux-status" server.py
+ install -D -m 0755 -t "$pkgdir/srv/linux-status" src/app.py
+ install -D -m 0755 -t "$pkgdir/srv/linux-status" src/server.py
- install -D -m 0644 -t "$pkgdir/srv/linux-status" index.html
- find css -type f -exec install -D -m 0644 -t "$pkgdir/srv/linux-status/css" {} ';'
- find js -type f -exec install -D -m 0644 -t "$pkgdir/srv/linux-status/js" {} ';'
+ cp -dr --preserve=mode,timestamp html "$pkgdir/srv/linux-status"
install -D -m 0644 -t "$pkgdir/usr/lib/systemd/system" dist/systemd/linux-status.service
}