summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEgor Tensin2021-03-31 20:43:30 +0300
committerEgor Tensin2021-04-07 03:32:17 +0300
commit5cef42066d6c6ec38e180a95cc98379f4bfea331 (patch)
treead2625e9a02c89cada9e93daee8e4b94152b446c
parent78530c21f42a6fe0675a16c7117159375538abd2 (diff)
downloadaur-5cef42066d6c6ec38e180a95cc98379f4bfea331.tar.gz
aur: Makefile best practices
-rw-r--r--Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 3ba30d08257b..0269644cd2d6 100644
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,28 @@
-MAKEFLAGS += --warn-undefined-variables
+MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
+unexport MAKEFLAGS
.DEFAULT_GOAL := all
.DELETE_ON_ERROR:
.SUFFIXES:
SHELL := bash
-.SHELLFLAGS := -e -o pipefail -c
+.SHELLFLAGS := -eu -o pipefail -c
+
+.PHONY: DO
+DO:
escape = $(subst ','\'',$(1))
+define noexpand
+ifeq ($$(origin $(1)),environment)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),environment override)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),command line)
+ override $(1) := $$(value $(1))
+endif
+endef
+
PKG_NAME := linux-status
this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))