summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Chen2022-07-07 10:46:14 +0800
committerJack Chen2022-07-07 10:46:14 +0800
commit5e896ce5afc6c8d78b27764aa57d9201ebb2b81f (patch)
treea7ab93aee9ee11ec53251713735c393eaa171a9a
parent743f68fcb8fcd4e1d039d84355cd1c0df9282d6a (diff)
downloadaur-5e896ce5afc6c8d78b27764aa57d9201ebb2b81f.tar.gz
PKGBUILD: minor update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef200e3b6044..7243ad258510 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
-pkgbase = linux-sunxi64
+pkgbase = linux-sunxi64-bin
pkgver = 5.15.48
pkgrel = 1
url = https://github.com/armbian/build
arch = aarch64
license = GPL2
+ provides = linux-sunxi64
noextract = linux.preset
noextract = linux-dtb-current-sunxi64_22.05.3_arm64.deb
noextract = linux-image-current-sunxi64_22.05.3_arm64.deb
@@ -18,7 +19,7 @@ pkgbase = linux-sunxi64
sha512sums = SKIP
sha512sums = SKIP
-pkgname = linux-sunxi64
+pkgname = linux-sunxi64-bin
pkgdesc = The Linux Kernel and modules - AArch64 multi-platform sunxi64
depends = coreutils
depends = linux-firmware
@@ -29,6 +30,6 @@ pkgname = linux-sunxi64
conflicts = linux
backup = etc/mkinitcpio.d/linux-sunxi64.preset
-pkgname = linux-sunxi64-headers
+pkgname = linux-sunxi64-bin-headers
pkgdesc = Header files and scripts for building modules for linux kernel - AArch64 multi-platform sunxi64
conflicts = linux-headers
diff --git a/PKGBUILD b/PKGBUILD
index 8e94d6563dc2..2ee8301e8916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Jack Chen <redchenjs@live.com>
_target=sunxi64
-pkgbase="linux-$_target"
+_pkgbase="linux-$_target"
+pkgbase="$_pkgbase-bin"
pkgname=("$pkgbase" "$pkgbase-headers")
pkgver=5.15.48
_armbver=22.05.3
@@ -12,6 +13,8 @@ _desc="AArch64 multi-platform $_target"
url="https://github.com/armbian/build"
license=('GPL2')
options=('!strip')
+provides=("$_pkgbase")
+conflics=("$_pkgbase")
source=(
"linux.preset"
"https://apt.armbian.com/pool/main/l/linux-$_kernver/linux-dtb-current-${_target}_${_armbver}_arm64.deb"
@@ -36,7 +39,7 @@ _package() {
pkgdesc="The Linux Kernel and modules - $_desc"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
- backup=("etc/mkinitcpio.d/$pkgbase.preset")
+ backup=("etc/mkinitcpio.d/$_pkgbase.preset")
provides=('WIREGUARD-MODULE')
conflicts=('linux')
@@ -50,27 +53,26 @@ _package() {
install -dm755 "$pkgdir/boot"
cp -r "boot/dtb-$_kernver" "$pkgdir/boot/dtbs"
- ln -s "vmlinuz-$pkgbase" "$pkgdir/boot/Image"
- ln -s "initramfs-$pkgbase.img" "$pkgdir/boot/Initrd"
+ ln -s "vmlinuz-$_pkgbase" "$pkgdir/boot/Image"
install -dm755 "$pkgdir/usr"
cp -r lib "$pkgdir/usr/lib"
# sed expression for following substitutions
local _subst="
- s|%PKGBASE%|$pkgbase|g
+ s|%PKGBASE%|$_pkgbase|g
s|%KERNVER%|$_kernver|g
"
# install mkinitcpio preset file
sed "$_subst" linux.preset |
- install -Dm644 /dev/stdin "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
+ install -Dm644 /dev/stdin "$pkgdir/etc/mkinitcpio.d/$_pkgbase.preset"
# install boot image
install -Dm644 "boot/vmlinuz-$_kernver" "$pkgdir/usr/lib/modules/$_kernver/vmlinuz"
# used by mkinitcpio to name the kernel
- echo "$pkgbase" | install -Dm644 /dev/stdin "$pkgdir/usr/lib/modules/$_kernver/pkgbase"
+ echo "$_pkgbase" | install -Dm644 /dev/stdin "$pkgdir/usr/lib/modules/$_kernver/pkgbase"
}
_package-headers() {