summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Pabalinas2018-04-13 13:04:06 -1000
committerJoey Pabalinas2018-04-13 13:04:06 -1000
commit829715c0dd72cad8a0da496e0188e59749121abc (patch)
tree4616f1e6ac4426ef4c13c0d3d3aeece5a279bcbf
parent718d2cbfb54c0c61e123d3a9f8c4eef854e0b491 (diff)
downloadaur-829715c0dd72cad8a0da496e0188e59749121abc.tar.gz
upgpkg: linux-surfacepro3-git 4.16.r12001.g1bad9ce155a7c010a9-1
upstream release
-rw-r--r--PKGBUILD36
-rw-r--r--config.sp35
2 files changed, 21 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8d9b533d245..f5e0a9c488a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=linux-surfacepro3-git
_srcname=linux
-pkgver=4.16.r10220.g3c0d551e02b2590fa7
+pkgver=4.16.r12001.g1bad9ce155a7c010a9
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -30,7 +30,7 @@ sha256sums=('SKIP'
_sp3config="y"
# _makenconfig="y"
_interactive="y"
-_kvmkillable_patch="y"
+_kvmkillable_patch="n"
_touchscreen_patch="n"
_kernelname="${pkgbase#linux}"
@@ -282,29 +282,29 @@ _package-headers() {
done
# Fix file conflict with -doc package
- rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild"/Kconfig.*-*
+ rm "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild"/Kconfig.*-*
# Add objtool for CONFIG_STACK_VALIDATION
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/tools"
cp -a tools/objtool "${pkgdir}/usr/lib/modules/${_kernver}/build/tools"
- # remove unneeded architectures
- rm -rf "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch/{alpha,arc,arm,arm26,arm64,avr32,blackfin,c6x,cris,frv,h8300,hexagon,ia64,m32r,m68k,m68knommu,metag,mips,microblaze,mn10300,openrisc,parisc,powerpc,ppc,s390,score,sh,sh64,sparc,sparc64,tile,unicore32,um,v850,xtensa}
-
- find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;
chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
+ find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;
- # # strip scripts directory
- # find "${pkgdir}/usr/lib/modules/${_kernver}/build/scripts" -type f -perm -u+w 2>/dev/null | while read binary ; do
- # case "$(file -bi "${binary}")" in
- # *application/x-sharedlib*) # Libraries (.so)
- # /usr/bin/strip ${STRIP_SHARED} "${binary}";;
- # *application/x-archive*) # Libraries (.a)
- # /usr/bin/strip ${STRIP_STATIC} "${binary}";;
- # *application/x-executable*) # Binaries
- # /usr/bin/strip ${STRIP_BINARIES} "${binary}";;
- # esac
- # done
+ # strip scripts directory
+ find "${pkgdir}/usr/lib/modules/${_kernver}/build/scripts" -type f -perm -u+w 2>/dev/null | while read binary ; do
+ case "$(file -bi "${binary}")" in
+ *application/x-sharedlib*) # Libraries (.so)
+ /usr/bin/strip ${STRIP_SHARED} "${binary}";;
+ *application/x-archive*) # Libraries (.a)
+ /usr/bin/strip ${STRIP_STATIC} "${binary}";;
+ *application/x-executable*) # Binaries
+ /usr/bin/strip ${STRIP_BINARIES} "${binary}";;
+ esac
+ done
+
+ # remove unneeded architectures
+ rm -rf "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch/{alpha,arc,arm,arm26,arm64,avr32,blackfin,c6x,cris,frv,h8300,hexagon,ia64,m32r,m68k,m68knommu,metag,mips,microblaze,mn10300,openrisc,parisc,powerpc,ppc,s390,score,sh,sh64,sparc,sparc64,tile,unicore32,um,v850,xtensa}
}
_package-docs() {
diff --git a/config.sp3 b/config.sp3
index caca4289c90a..738230b24cbd 100644
--- a/config.sp3
+++ b/config.sp3
@@ -6646,6 +6646,7 @@ CONFIG_ND_BLK=m
CONFIG_ND_CLAIM=y
CONFIG_ND_BTT=m
CONFIG_BTT=y
+CONFIG_DAX_DRIVER=y
CONFIG_DAX=y
# CONFIG_DEV_DAX is not set
CONFIG_NVMEM=y
@@ -7105,13 +7106,13 @@ CONFIG_ARCH_HAS_KCOV=y
#
CONFIG_LOCKUP_DETECTOR=y
CONFIG_SOFTLOCKUP_DETECTOR=y
+# CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC is not set
+CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC_VALUE=0
CONFIG_HARDLOCKUP_DETECTOR_PERF=y
CONFIG_HARDLOCKUP_CHECK_TIMESTAMP=y
CONFIG_HARDLOCKUP_DETECTOR=y
# CONFIG_BOOTPARAM_HARDLOCKUP_PANIC is not set
CONFIG_BOOTPARAM_HARDLOCKUP_PANIC_VALUE=0
-# CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC is not set
-CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC_VALUE=0
CONFIG_DETECT_HUNG_TASK=y
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set