summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralyptik2016-11-04 12:13:34 -1000
committeralyptik2016-11-04 12:13:34 -1000
commita05f1813b0140d944116ca5dd12e1b7502f12c5f (patch)
tree1dd4db93ee649274a49485015ebdd55d0441930e
parent1429e9990a19718c22f6eaea0890692d1ddac102 (diff)
downloadaur-a05f1813b0140d944116ca5dd12e1b7502f12c5f.tar.gz
Updated patches and cleaned up PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD34
-rw-r--r--config.sp32
3 files changed, 14 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9215af482da2..4b339d602af4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-surfacepro3-rt
pkgver = 4.8.6
- pkgrel = 1.8
+ pkgrel = 1.9
url = https://github.com/alyptik/linux-surfacepro3-rt
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 451c3efc372f..b429db1b9f5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=linux-surfacepro3-rt
_srcname=linux-4.8.6
pkgver=4.8.6
-pkgrel=1.8
+pkgrel=1.9
arch=('i686' 'x86_64')
url="https://github.com/alyptik/linux-surfacepro3-rt"
license=('GPL2')
@@ -76,31 +76,21 @@ _kernelname=${pkgbase#linux}
prepare() {
cd "${srcdir}/${_srcname}"
- ## BFS/BFQ patches and unsupported BCache module; none of these worked during current testing
- if [ "$bfq" != 'n' ]; then patch -p1 -i "${srcdir}/bfq.patch"; fi
- if [ "$bfs" != 'n' ]; then
- for i in bfq.patch bfs.patch bfs-fixes1.patch bfs-fixes2.patch; do patch -p1 -i "${srcdir}/${i}"; done
- fi
- if [ "$bcache" != 'n' ]; then
+ ## Options which are currently buggy/broken: BFS/BFQ patches and unsupported BCache module
+ if [ "$bfq" = 'y' ]; then patch -p1 -i "${srcdir}/bfq.patch"; fi
+ if [ "$bfs" = 'y' ]; then for i in bfq bfs bfs-fixes1 bfs-fixes2; do patch -p1 -i "${srcdir}/${i}.patch"; done; fi
+ if [ "$bcache" = 'y' ]; then
sed -i '\%^diff --git a/drivers/md/bcache/Kconfig b/drivers/md/bcache/Kconfig$%,+11 d' "${srcdir}/patch-${pkgver}-rt2.patch"
cp "${srcdir}/linux-${pkgver}/include/linux/rwsem.h" "${srcdir}/linux-${pkgver}/drivers/md/bcache/"
sed -i '/#include "bcache.h"/i #include "rwsem.h"\n' "${srcdir}/linux-${pkgver}/drivers/md/bcache/request.c"
fi
## Add personal patches
- if [ "$personal" != 'n' ]; then
- for i in block.patch init.patch kconfig.patch xattr.patch xfs.patch; do patch -p1 -i "${srcdir}/${i}"; done
- fi
+ if [ "$personal" = 'y' ]; then for i in block init kconfig xattr xfs; do patch -p1 -i "${srcdir}/${i}.patch"; done; fi
# Add RT patches
patch -p1 -i "${srcdir}/patch-${pkgver}-rt5.patch"
- # add upstream patch
- #patch -p1 -i "${srcdir}/patch-${pkgver}"
-
- # add latest fixes from stable queue, if needed
- # http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
-
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -111,18 +101,18 @@ prepare() {
# This patch adds multitouch support for the surface pro 3
# keyboard cover.
- if [ "$multitouch" != 'n' ]; then
- patch -p1 -i "${srcdir}/multitouch.patch"
- fi
+ if [ "$multitouch" = 'y' ]; then patch -p1 -i "${srcdir}/multitouch.patch"; fi
# These patches work around buggy hardware implementations
# in the surface pro 3 touchscreen module.
patch -p1 -i "${srcdir}/touchscreen_multitouch_fixes1.patch"
patch -p1 -i "${srcdir}/touchscreen_multitouch_fixes2.patch"
- if [ "${CARCH}" = "x86_64" ]; then
- ## Set sp3config='y' to use the personal config as a base
- [ "$sp3config" != 'n' ] && cat "${srcdir}/config.sp3" >./.config || cat "${srcdir}/config.x86_64" >./.config
+ ## If sp3config='y' use personal config as a base
+ if [ "$sp3config" = 'y' ]; then
+ cat "${srcdir}/config.sp3" >./.config
+ elif [ "${CARCH}" = "x86_64" ]; then
+ cat "${srcdir}/config.x86_64" >./.config
else
cat "${srcdir}/config" > ./.config
fi
diff --git a/config.sp3 b/config.sp3
index 889d80304b14..7c4b31b42eaa 100644
--- a/config.sp3
+++ b/config.sp3
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.8.6-1.8 Kernel Configuration
+# Linux/x86 4.8.6-1.9 Kernel Configuration
#
CONFIG_64BIT=y
CONFIG_X86_64=y