summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:48:36 -0700
committerAnatol Pomozov2015-06-17 08:48:36 -0700
commit5dfbd5f8294c52d35dad5283515572f7c2dc30a3 (patch)
tree3b513f7bba70d475c283f2f2f856f8f3903b06a1
downloadaur-5dfbd5f8294c52d35dad5283515572f7c2dc30a3.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
3 files changed, 45 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..8c66fe4c4aa5
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = linux-tegra
+ pkgdesc = A computer program that allows device makers and hardware developers to interact at a low level (read/write/erase/repartition/reformat) with the storage (e.g. eMMC) connected to the NVIDIA Tegra chip on a low level from a connected PC
+ pkgver = 19.3.0
+ pkgrel = 1
+ url = https://developer.nvidia.com/linux-tegra
+ arch = x86_64
+ license = NVIDIA
+ depends = lib32-glibc
+ depends = lib32-gcc-libs
+ source = https://developer.nvidia.com/sites/default/files/akamai/mobile/files/L4T/Tegra124_Linux_R19.3.0_armhf.tbz2
+
+pkgname = linux-tegra
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14cece4e947e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = linux-tegra
+ pkgdesc = A computer program that allows device makers and hardware developers to interact at a low level (read/write/erase/repartition/reformat) with the storage (e.g. eMMC) connected to the NVIDIA Tegra chip on a low level from a connected PC
+ pkgver = 19.3.0
+ pkgrel = 1
+ url = https://developer.nvidia.com/linux-tegra
+ arch = x86_64
+ license = NVIDIA
+ depends = lib32-glibc
+ depends = lib32-gcc-libs
+ source = https://developer.nvidia.com/sites/default/files/akamai/mobile/files/L4T/Tegra124_Linux_R19.3.0_armhf.tbz2
+ sha1sums = a1b9834b5d241debcfa330cf3eababe35faa8dbf
+
+pkgname = linux-tegra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08b52a19a1ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=linux-tegra
+pkgver=19.3.0
+pkgrel=1
+pkgdesc='A computer program that allows device makers and hardware developers to interact at a low level (read/write/erase/repartition/reformat) with the storage (e.g. eMMC) connected to the NVIDIA Tegra chip on a low level from a connected PC'
+arch=(x86_64)
+license=(NVIDIA)
+depends=(lib32-glibc lib32-gcc-libs) # mkbootimg is 32-bit binary
+url='https://developer.nvidia.com/linux-tegra'
+source=(https://developer.nvidia.com/sites/default/files/akamai/mobile/files/L4T/Tegra124_Linux_R${pkgver}_armhf.tbz2)
+sha1sums=('a1b9834b5d241debcfa330cf3eababe35faa8dbf')
+
+package() {
+ install -dm755 "$pkgdir"/usr/{bin,share}
+ cp -r Linux_for_Tegra "$pkgdir"/usr/share/$pkgname
+ ln -s /usr/share/$pkgname/bootloader/{mkbootimg,nvflash} "$pkgdir"/usr/bin/
+}