summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax2019-02-21 08:31:50 +1100
committerMax2019-02-21 08:31:50 +1100
commit590261a49f478fb5e30c959ff1b80735e22f18d3 (patch)
tree88405359a57164712fc0ec5401953d1aed2d77f5
parent3925e1ece2cbf43241e882b7a96d47569effe1bf (diff)
downloadaur-590261a49f478fb5e30c959ff1b80735e22f18d3.tar.gz
move to tarball install, dont overwrite config
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb20a6b38953..4818d62fb431 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = linux-thermaltake-rgb
pkgdesc = Python usb daemon and controller for thermaltake rgb watercooling devices
- pkgver = 0.1.0
- pkgrel = 2
+ pkgver = 0.1.1
+ pkgrel = 1
url = https://github.com/chestm007/linux_thermaltake_riing
arch = any
license = GPL2
makedepends = python-setuptools
makedepends = python-nose
+ makedepends = tar
depends = python
depends = python-yaml
depends = python-gobject
- depends = python-dbus
depends = python-psutil
depends = python-pyusb
- source = git+https://github.com/chestm007/linux_thermaltake_riing/#tag=0.1.0
+ backup = etc/linux_thermaltake_rgb/config.yml
+ source = https://github.com/chestm007/linux_thermaltake_riing/archive/0.1.1.tar.gz
md5sums = SKIP
pkgname = linux-thermaltake-rgb
diff --git a/PKGBUILD b/PKGBUILD
index 9ed947e4b911..d231cf840e2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,26 @@
pkgname=linux-thermaltake-rgb
pkgdesc="Python usb daemon and controller for thermaltake rgb watercooling devices"
-pkgver=0.1.0
-pkgrel=2
+pkgver=0.1.1
+pkgrel=1
arch=('any')
license=('GPL2')
-depends=('python' 'python-yaml' 'python-gobject' 'python-dbus' 'python-psutil' 'python-pyusb')
-makedepends=('python-setuptools' 'python-nose')
+depends=('python' 'python-yaml' 'python-gobject' 'python-psutil' 'python-pyusb')
+makedepends=('python-setuptools' 'python-nose' 'tar')
url="https://github.com/chestm007/linux_thermaltake_riing"
-source=("git+https://github.com/chestm007/linux_thermaltake_riing/#tag=$pkgver")
+source=("https://github.com/chestm007/linux_thermaltake_riing/archive/${pkgver}.tar.gz")
md5sums=('SKIP')
-
-#pkgver() {
-# cd linux_thermaltake_riing
-# git describe --tags | cut -d '-' -f 1
-#}
+backup=('etc/linux_thermaltake_rgb/config.yml')
build() {
- cd "$srcdir/linux_thermaltake_riing"
+ cd "$srcdir/linux_thermaltake_riing-${pkgver}"
sed -i "s/PROJECTVERSION/$pkgver/g" setup.py
python setup.py build
}
package() {
- cd "$srcdir/linux_thermaltake_riing"
+ cd "$srcdir/linux_thermaltake_riing-${pkgver}"
sed -i "s/PROJECTVERSION/$pkgver/g" setup.py
python setup.py install --prefix=/usr --root="$pkgdir"