summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2021-03-09 11:50:51 +0200
committerChristoph Fink2021-03-09 11:50:51 +0200
commitd4d417f107b78ab9c8930e4d85eafc117580ca1d (patch)
tree0ddb09fc7cff329aac21af9d1fb2bc107962c6cd
parent43cada5aad4783309e2a59f4bc776011c44994d7 (diff)
downloadaur-d4d417f107b78ab9c8930e4d85eafc117580ca1d.tar.gz
upgpkg: linux-timemachine-git v1.2.r0.g19d6e9a-1
upstream release
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD31
2 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bdb1f12995d..c3df7aa629d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-timemachine-git
pkgdesc = Rsync-based OSX-like time machine for atomic and resumable local and remote backups
- pkgver = 1.1
+ pkgver = v1.2.r0.g19d6e9a
pkgrel = 1
url = https://github.com/cytopia/linux-timemachine
arch = any
@@ -8,7 +8,7 @@ pkgbase = linux-timemachine-git
makedepends = git
depends = rsync
optdepends = openssh: backup to remote (SCP) locations
- source = linux-timemachine-git-1.1::git+https://github.com/cytopia/linux-timemachine.git
+ source = linux-timemachine-git::git+https://github.com/cytopia/linux-timemachine.git
sha256sums = SKIP
pkgname = linux-timemachine-git
diff --git a/PKGBUILD b/PKGBUILD
index 4679b98857f9..1c34dc4960e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,26 @@ pkgname="linux-timemachine-git"
pkgdesc="Rsync-based OSX-like time machine for atomic and resumable local and remote backups"
url="https://github.com/cytopia/linux-timemachine"
-pkgver=1.1
+pkgver=v1.2.r0.g19d6e9a
pkgrel=1
arch=("any")
license=("MIT")
-makedepends=(
- "git"
-)
-depends=(
- "rsync"
-)
-optdepends=(
- "openssh: backup to remote (SCP) locations"
-)
-
-source=(
- "${pkgname}-${pkgver}::git+https://github.com/cytopia/linux-timemachine.git"
-)
-sha256sums=(
- "SKIP"
-)
+makedepends=("git")
+depends=("rsync")
+optdepends=("openssh: backup to remote (SCP) locations")
+
+source=("${pkgname}::git+https://github.com/cytopia/linux-timemachine.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/"
+ cd "${srcdir}/${pkgname}"
install \
-Dm755 \