summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2021-07-21 18:37:57 +0800
committeryjun2021-07-21 18:37:57 +0800
commited8385cb408710ad50bd8c09d8b20841b421e993 (patch)
tree3fe214a02ee57756de6743404bb1bcacc76d66a6
parent0ddedc083396583613e6926c2404afef8c57ebe8 (diff)
downloadaur-ed8385cb408710ad50bd8c09d8b20841b421e993.tar.gz
dts: enable bluetooth and wifi
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD2
-rw-r--r--sun50i-h6-tqc-a01.dts23
4 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95a2bcfb4fc7..727277f3e023 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-tqc-a01
pkgver = 5.11.4
- pkgrel = 2
+ pkgrel = 3
url = http://www.kernel.org/
arch = aarch64
license = GPL2
diff --git a/.gitignore b/.gitignore
index 82a61bd8f003..3a909b06d6e4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
src/
pkg/
-linux-*.tar.xz
-patch-*.xz
+*.zst
+*.xz
+*.dtb
diff --git a/PKGBUILD b/PKGBUILD
index c55033e47dce..16891f7edd6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _srcname=linux-5.11
_kernelname=${pkgbase#linux}
_desc="AArch64 kernel for TQC A01"
pkgver=5.11.4
-pkgrel=2
+pkgrel=3
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
diff --git a/sun50i-h6-tqc-a01.dts b/sun50i-h6-tqc-a01.dts
index df6bf2fae4f4..3fa50719f4bc 100644
--- a/sun50i-h6-tqc-a01.dts
+++ b/sun50i-h6-tqc-a01.dts
@@ -45,15 +45,10 @@
compatible = "gpio-leds";
power {
- label = "orangepi:red:power";
+ label = "orangepi:blue:power";
gpios = <&r_pio 0 4 GPIO_ACTIVE_HIGH>; /* PL4 */
default-state = "on";
};
-
- status {
- label = "orangepi:green:status";
- gpios = <&r_pio 0 7 GPIO_ACTIVE_HIGH>; /* PL7 */
- };
};
reg_vcc5v: vcc5v {
@@ -65,6 +60,15 @@
regulator-always-on;
};
+ reg_gmac_2v5: gmac-2v5 {
+ compatible = "regulator-fixed";
+ regulator-name = "gmac-2v5";
+ regulator-min-microvolt = <2500000>;
+ regulator-max-microvolt = <2500000>;
+ enable-active-high;
+ gpio = <&pio 3 6 GPIO_ACTIVE_HIGH>; /* PD6 */
+ };
+
reg_vcc33_wifi: vcc33-wifi {
/* Always on 3.3V regulator for WiFi and BT */
compatible = "regulator-fixed";
@@ -89,7 +93,7 @@
compatible = "mmc-pwrseq-simple";
clocks = <&rtc 1>;
clock-names = "ext_clock";
- reset-gpios = <&r_pio 1 3 GPIO_ACTIVE_LOW>; /* PM3 */
+ reset-gpios = <&pio 0 8 GPIO_ACTIVE_LOW>; /* PL8 */
post-power-on-delay-ms = <200>;
};
};
@@ -123,6 +127,9 @@
pinctrl-0 = <&ext_rmii_pins>;
phy-mode = "rmii";
phy-handle = <&ext_rmii_phy>;
+ phy-supply = <&reg_aldo2>;
+ allwinner,rx-delay-ps = <1500>;
+ allwinner,tx-delay-ps = <700>;
status = "okay";
};
@@ -228,6 +235,8 @@
};
reg_aldo2: aldo2 {
+ regulator-always-on;
+ regulator-enable-ramp-delay = <0x186a0>;
regulator-min-microvolt = <3300000>;
regulator-max-microvolt = <3300000>;
regulator-name = "vcc33-audio-tv-ephy-mac";