summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2021-08-09 10:11:13 +0800
committeryjun2021-08-09 10:11:13 +0800
commitf4b00f90ce36a6b7db1fef7f14dd37e48be0e21a (patch)
treeddf2f3cb6ed53fabcf1292009540a81681605b6a
parentad36016f63723da21fa94b13f7cd1a9c5b30dd8a (diff)
downloadaur-f4b00f90ce36a6b7db1fef7f14dd37e48be0e21a.tar.gz
dtws: add extra CPU supply regulator
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--config2
-rw-r--r--sun50i-h6-tqc-a01.dts14
4 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5840562a14b9..a807d222429c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -33,7 +33,7 @@ pkgbase = linux-tqc-a01
source = 90-linux.hook
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-5.13.8.xz
md5sums = 76c60fb304510a7bbd9c838790bc5fe4
- md5sums = 3a6a8b9477658e6dccdeb2ef5f0eef1c
+ md5sums = 46d921dba031a9f397955a787c71911e
md5sums = 17aa0c69176c68cd98b4522740a1b747
md5sums = 2285d81ec6fb859d34b7abfd46a59550
md5sums = f9b6f367eef351eaa89b23a9b1ffc5a2
@@ -45,7 +45,7 @@ pkgbase = linux-tqc-a01
md5sums = 335382823f6dc2aae2f6038b7aee339e
md5sums = cb38b30491472097c3b9b475de39127f
md5sums = bc65c0b9e4d6fb2fe3a81b8358886885
- md5sums = a459d4bd827bc7048a45296251b20ae5
+ md5sums = 7149bc2e1daaeffe151dc06d50a1c2f7
md5sums = 66e0ae63183426b28c0ec0c7e10b5e16
md5sums = ce6c81ad1ad1f8b333fd6077d47abdaf
md5sums = 3dc88030a8f2f5a5f97266d99b149f77
diff --git a/PKGBUILD b/PKGBUILD
index b390b07d5a17..2a920c58db95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,7 @@ source=("http://cdn.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
source+=("https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz")
md5sums=('76c60fb304510a7bbd9c838790bc5fe4'
- '3a6a8b9477658e6dccdeb2ef5f0eef1c'
+ '46d921dba031a9f397955a787c71911e'
'17aa0c69176c68cd98b4522740a1b747'
'2285d81ec6fb859d34b7abfd46a59550'
'f9b6f367eef351eaa89b23a9b1ffc5a2'
@@ -50,7 +50,7 @@ md5sums=('76c60fb304510a7bbd9c838790bc5fe4'
'335382823f6dc2aae2f6038b7aee339e'
'cb38b30491472097c3b9b475de39127f'
'bc65c0b9e4d6fb2fe3a81b8358886885'
- 'a459d4bd827bc7048a45296251b20ae5'
+ '7149bc2e1daaeffe151dc06d50a1c2f7'
'66e0ae63183426b28c0ec0c7e10b5e16'
'ce6c81ad1ad1f8b333fd6077d47abdaf'
'3dc88030a8f2f5a5f97266d99b149f77'
diff --git a/config b/config
index 7bbbe8a5e0d4..e7b4024b4b3f 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm64 5.13.6-1 Kernel Configuration
+# Linux/arm64 5.13.8-1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 10.2.0"
CONFIG_CC_IS_GCC=y
diff --git a/sun50i-h6-tqc-a01.dts b/sun50i-h6-tqc-a01.dts
index 923280e61958..e3e01fad4797 100644
--- a/sun50i-h6-tqc-a01.dts
+++ b/sun50i-h6-tqc-a01.dts
@@ -101,6 +101,18 @@
cpu-supply = <&reg_dcdca>;
};
+&cpu1 {
+ cpu-supply = <&reg_dcdca>;
+};
+
+&cpu2 {
+ cpu-supply = <&reg_dcdca>;
+};
+
+&cpu3 {
+ cpu-supply = <&reg_dcdca>;
+};
+
&de {
status = "okay";
};
@@ -270,7 +282,7 @@
regulator-always-on;
regulator-min-microvolt = <3300000>;
regulator-max-microvolt = <3300000>;
- regulator-name = "vcc33-io-pd-emmc-sd-usb-uart";
+ regulator-name = "vcc33-io-pd-emmc-sd-usb-uart-2";
};
cldo2 {