summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2023-08-18 00:04:43 +0800
committeryjun2023-08-18 00:04:43 +0800
commitfc6f8150cf641f540ad3e4e16853993df0d126ac (patch)
tree07e428a381093c9eaf77a9aa1b87de58ddda0098
parente566107fba4995d422f4937c69aba7c372f5bac3 (diff)
downloadaur-fc6f8150cf641f540ad3e4e16853993df0d126ac.tar.gz
fix build error
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
-rw-r--r--drv-mfd-Add-support-for-AC200.patch7
3 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54174f49ee98..6dbbc0883997 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-tqc-a01
pkgver = 6.4.10
- pkgrel = 1
+ pkgrel = 2
url = http://www.kernel.org/
arch = aarch64
license = GPL2
@@ -48,7 +48,7 @@ pkgbase = linux-tqc-a01
md5sums = 2d7918618ec227b65d35078b3c7862ce
md5sums = 5cf059c6de6dbee8d20041dcb735f5b1
md5sums = f0826f12d7b1f597fba32913e8580543
- md5sums = 714a3df875f3a05aee07c7c464ad3fe0
+ md5sums = 75a3f190e0ea37c17007c8cd39e3e227
md5sums = f585248da27f4a1a2ae00fcef89ad92e
md5sums = ab514581687e4bb1f107a3692bba4bf3
md5sums = b45a181d414c98d99fe3231dc56ee38d
@@ -76,7 +76,6 @@ pkgname = linux-tqc-a01
provides = linux=6.4.10
provides = WIREGUARD-MODULE
conflicts = linux
- replaces = linux-armv8
backup = etc/mkinitcpio.d/linux-tqc-a01.preset
pkgname = linux-tqc-a01-headers
diff --git a/PKGBUILD b/PKGBUILD
index d3791c74a13a..3afbc75c8e2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _srcname=linux-6.4
_kernelname=${pkgbase#linux}
_desc="AArch64 kernel for TQC A01"
pkgver=6.4.10
-pkgrel=1
+pkgrel=2
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -72,7 +72,7 @@ md5sums=('bb65b2232cf596e7044c56a7c4205f51'
'2d7918618ec227b65d35078b3c7862ce'
'5cf059c6de6dbee8d20041dcb735f5b1'
'f0826f12d7b1f597fba32913e8580543'
- '714a3df875f3a05aee07c7c464ad3fe0'
+ '75a3f190e0ea37c17007c8cd39e3e227'
'f585248da27f4a1a2ae00fcef89ad92e'
'ab514581687e4bb1f107a3692bba4bf3'
'b45a181d414c98d99fe3231dc56ee38d'
@@ -153,7 +153,7 @@ build() {
#make menuconfig # CLI menu for configuration
#make nconfig # new CLI menu for configuration
#make xconfig # X-based configuration
-# make oldconfig # using old config from previous kernel version
+ make oldconfig # using old config from previous kernel version
# ... or manually edit .config
# Copy back our configuration (use with new kernel version)
@@ -181,7 +181,6 @@ _package() {
optdepends=('crda: to set the correct wireless channels of your country'
'firmware-tqc-a01: firmware for TQC A01 WiFi/Bluetooth')
provides=("linux=${pkgver}" "WIREGUARD-MODULE")
- replaces=('linux-armv8')
conflicts=('linux')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
install=${pkgname}.install
@@ -203,8 +202,7 @@ _package() {
# sed expression for following substitutions
local _subst="
s|%PKGBASE%|${pkgbase}|g
- s|%KERNVER%|${_kernver}|g
- s|%EXTRAMODULES%|${_extramodules}|g
+ s|%KERNVER%|${kernver}|g
"
# install mkinitcpio preset file
diff --git a/drv-mfd-Add-support-for-AC200.patch b/drv-mfd-Add-support-for-AC200.patch
index 0a79ef9e9176..5dc8e6b02a3a 100644
--- a/drv-mfd-Add-support-for-AC200.patch
+++ b/drv-mfd-Add-support-for-AC200.patch
@@ -111,7 +111,7 @@ index 000000000..570573790
+ .name = "ac200_irq_chip",
+ .status_base = AC200_SYS_IRQ_STATUS,
+ .mask_base = AC200_SYS_IRQ_ENABLE,
-+ .mask_invert = true,
++ .ack_invert = true,
+ .irqs = ac200_regmap_irqs,
+ .num_irqs = ARRAY_SIZE(ac200_regmap_irqs),
+ .num_regs = 1,
@@ -130,8 +130,7 @@ index 000000000..570573790
+ },
+};
+
-+static int ac200_i2c_probe(struct i2c_client *i2c,
-+ const struct i2c_device_id *id)
++static int ac200_i2c_probe(struct i2c_client *i2c)
+{
+ struct device *dev = &i2c->dev;
+ struct ac200_dev *ac200;
@@ -183,7 +182,7 @@ index 000000000..570573790
+ return 0;
+}
+
-+static int ac200_i2c_remove(struct i2c_client *i2c)
++static void ac200_i2c_remove(struct i2c_client *i2c)
+{
+ struct ac200_dev *ac200 = i2c_get_clientdata(i2c);
+