summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-04-20 20:21:26 +0200
committerPiotr Gorski2023-04-20 20:21:26 +0200
commit18962f07d2fe31846dd38a5a668cc3bbef2b5ddd (patch)
tree8b6fa7a28b18f4cdcf30fb976bc6cf962fdb0b7f
parentcd24d926a0daa68e594213a31cb8b4916ba58e10 (diff)
downloadaur-18962f07d2fe31846dd38a5a668cc3bbef2b5ddd.tar.gz
Bump to 6.2.12
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--linux-cachyos-prjc.install16
3 files changed, 26 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f0c24416a8e..d2bed004442d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-tt
pkgdesc = Linux TT scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 6.2.11
+ pkgver = 6.2.12
pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
@@ -21,15 +21,15 @@ pkgbase = linux-tt
makedepends = make
makedepends = patch
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.2.11.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.2.12.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.2/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.2/sched/0001-tt-cachy.patch
- sha256sums = 0d236784e60b87c7953535aeb148dd9e773b26495dfa9c6d69615f54fe00dd47
+ sha256sums = c7e146b52737adfa4c724bfa41bf4721c5ee3cf220c074fbc60eb3ea62b0ccc8
sha256sums = 816508270cc1062a9089548a7320922c028431450db4231fc5786d81beedd9ed
sha256sums = 41c34759ed248175e905c57a25e2b0ed09b11d054fe1a8783d37459f34984106
- sha256sums = cef5b2e45c376a0d7a78ba48f9c3c86b883cb50226faf9313958f4c30ef5604b
+ sha256sums = df9ad8d111f94c6705de28c692de217e39d76b509309f38a3e4a510a5d36d187
sha256sums = c5c48b3e6b08c54b7d057f32da5d11478cf25ba87c903727a77a7b5a8d3f78a8
pkgname = linux-tt
diff --git a/PKGBUILD b/PKGBUILD
index 8b15089a7064..faddf60fdb52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -196,7 +196,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.2
-_minor=11
+_minor=12
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -233,7 +233,7 @@ source=(
# ZFS support
if [ -n "$_build_zfs" ]; then
makedepends+=(git)
- source+=("git+https://github.com/cachyos/zfs.git#commit=00e580bca282bf30913fcf5832fc58191cf0ff32")
+ source+=("git+https://github.com/cachyos/zfs.git#commit=e25f9131d679692704c11dc0c1df6d4585b70c35")
fi
## Latency NICE Support
@@ -247,7 +247,8 @@ case "$_cpusched" in
cachyos) # CachyOS Scheduler (EEVDF)
source+=("${_patchsource}/sched/0001-EEVDF.patch");;
pds|bmq) # BMQ/PDS scheduler
- source+=("${_patchsource}/sched/0001-prjc-cachy.patch");;
+ source+=("${_patchsource}/sched/0001-prjc-cachy.patch"
+ linux-cachyos-prjc.install);;
tt) ## TT Scheduler
source+=("${_patchsource}/sched/0001-tt-cachy.patch");;
bore) ## BORE Scheduler with latency_nice
@@ -846,8 +847,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('0d236784e60b87c7953535aeb148dd9e773b26495dfa9c6d69615f54fe00dd47'
+sha256sums=('c7e146b52737adfa4c724bfa41bf4721c5ee3cf220c074fbc60eb3ea62b0ccc8'
'816508270cc1062a9089548a7320922c028431450db4231fc5786d81beedd9ed'
'41c34759ed248175e905c57a25e2b0ed09b11d054fe1a8783d37459f34984106'
- 'cef5b2e45c376a0d7a78ba48f9c3c86b883cb50226faf9313958f4c30ef5604b'
+ 'df9ad8d111f94c6705de28c692de217e39d76b509309f38a3e4a510a5d36d187'
'c5c48b3e6b08c54b7d057f32da5d11478cf25ba87c903727a77a7b5a8d3f78a8')
diff --git a/linux-cachyos-prjc.install b/linux-cachyos-prjc.install
new file mode 100644
index 000000000000..cd90471eaddf
--- /dev/null
+++ b/linux-cachyos-prjc.install
@@ -0,0 +1,16 @@
+post_install() {
+ cat << EOF
+You install the linux-cachyos kernel variant with the PDS/BMQ scheduler.
+Please note that this scheduler can cause various performance and stability
+issues (especially on AMD Ryzen CPUs) and we don't provide official
+support for fixing them. If you encounter any problems while using the kernel,
+please make sure that that it is not a BMQ or PDS specific problem before reporting it
+to us, otherwise inform the Project C developer:
+
+https://gitlab.com/alfredchen/linux-prjc/-/issues
+EOF
+}
+
+post_upgrade() {
+ post_install
+}