summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-08-10 11:15:31 +0200
committerPiotr Gorski2023-08-10 11:15:31 +0200
commit5c9a78f9fd88401abd331b0456bdee0301604c7f (patch)
tree9a9f23f4e229b4a32f5e6f8d7e0714e7a8c40fd6
parent85a1b8166d4c33c295cc17c7040cd7e20ac5da75 (diff)
downloadaur-5c9a78f9fd88401abd331b0456bdee0301604c7f.tar.gz
Disable CONFIG_CPU_SRSO for thin and full LTO
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db9331f653c4..9c9d41bfb9fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -286,6 +286,13 @@ prepare() {
"${srcdir}"/auto-cpu-optimization.sh
fi
+ ### Disabling CONFIG_CPU_SRSO
+ # More infos here: https://github.com/CachyOS/linux-cachyos/issues/150
+ if [ "$_use_llvm_lto" != "none" ]; then
+ echo "Disabling CONFIG_CPU_SRSO..."
+ scripts/config -d CPU_SRSO
+ fi
+
### Selecting CachyOS config
if [ -n "$_cachy_config" ]; then
echo "Enabling CachyOS config..."