summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-02-01 15:14:17 +0100
committerPiotr Gorski2023-02-01 15:14:17 +0100
commitad0b529b074f739f580a1e213ae32af77c1233e6 (patch)
tree3becffc16592c63d016c348102ef3773a1eedc4b
parentacd6aae8f208661697452dfb684f1f505f232acf (diff)
downloadaur-ad0b529b074f739f580a1e213ae32af77c1233e6.tar.gz
Bump to 6.1.9-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD142
2 files changed, 49 insertions, 103 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d0ef2d98514..9da1a2c76835 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-tt
pkgdesc = Linux TT scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 6.1.8
- pkgrel = 1
+ pkgver = 6.1.9
+ pkgrel = 2
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -21,15 +21,15 @@ pkgbase = linux-tt
makedepends = make
makedepends = patch
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.1.8.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.1.9.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.1/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.1/sched/0001-tt-cachy.patch
- sha256sums = b60bb53ab8ba370a270454b11e93d41af29126fc72bd6ede517673e2e57b816d
+ sha256sums = d60cf185693c386e7acd9f3eb3a94ae30ffbfee0a9447a20e83711e0bdf5922b
sha256sums = fab53ac59d4da6fb0433f6fd15877871f4124a89021237f90835d1ff3755ba9c
sha256sums = 41c34759ed248175e905c57a25e2b0ed09b11d054fe1a8783d37459f34984106
- sha256sums = 775fd31535e3f025bd7597105fbc34def0265671f2c6000f253d4eb2f3883988
+ sha256sums = 3c31aea899ab3ba5d4119fc08935b31f66b2d4da65b6adfbfd3b410114c25753
sha256sums = d23955f69440adab0e1edd4e372bcf424c4772556a6bca7565ddd087eaf31fec
pkgname = linux-tt
diff --git a/PKGBUILD b/PKGBUILD
index 9a5b39211ae4..c2a6bb052448 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,6 @@ _cachy_config=${_cachy_config-'yes'}
# ATTENTION - one of seven predefined values should be selected!
# 'bmq' - select 'BitMap Queue CPU scheduler'
# 'pds' - select 'Priority and Deadline based Skip list multiple queue CPU scheduler'
-# 'cacule' - select 'CacULE scheduler'
-# 'cacule-rdb' - select 'CacULE-RDB scheduler'
# 'bore' - select 'Burst-Oriented Response Enhancer'
# 'cfs' - select 'Completely Fair Scheduler'
# 'tt' - select 'Task Type Scheduler by Hamad Marri'
@@ -200,7 +198,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.1
-_minor=8
+_minor=9
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -210,7 +208,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux TT scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=1
+pkgrel=2
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -240,7 +238,7 @@ source=(
"${_patchsource}/all/0001-cachyos-base-all.patch")
## ZFS Support
if [ -n "$_build_zfs" ]; then
- source+=("git+https://github.com/cachyos/zfs.git#commit=04b02785b67f9b976c43643dd52ce6cdbc22e11e")
+ source+=("git+https://github.com/cachyos/zfs.git#commit=92e0d9d183ce6752cd52f7277c8321d81df9ffee")
fi
## Latency NICE Support
if [ -n "$_latency_nice" ]; then
@@ -248,39 +246,20 @@ if [ -n "$_latency_nice" ]; then
source+=("${_patchsource}/misc/0001-Add-latency-priority-for-CFS-class.patch")
fi
fi
-## BMQ Scheduler
-if [ "$_cpusched" = "bmq" ]; then
- source+=("${_patchsource}/sched/0001-prjc-cachy.patch")
-fi
-## PDS Scheduler
-if [ "$_cpusched" = "pds" ]; then
- source+=("${_patchsource}/sched/0001-prjc-cachy.patch")
-fi
-## BORE Scheduler with latency_nice
-if [ "$_cpusched" = "bore" ]; then
- source+=("${_patchsource}/sched/0001-bore-cachy.patch")
-## BORE SYSCTL TUNING
- if [ -n "$_tune_bore" ]; then
- source+=("${_patchsource}/misc/0001-bore-tuning-sysctl.patch")
- fi
-fi
-## CacULE Scheduler
-if [ "$_cpusched" = "cacule" ]; then
- source+=("${_patchsource}/sched/0001-cacULE-cachy.patch")
-fi
-## CacULE-RDB Scheduler
-if [ "$_cpusched" = "cacule-rdb" ]; then
- source+=("${_patchsource}/sched/0001-cacULE-cachy.patch")
-fi
-## TT Scheduler
-if [ "$_cpusched" = "tt" ]; then
- source+=("${_patchsource}/sched/0001-tt-cachy.patch")
-fi
-## Hardened Patches with BORE Scheduler
-if [ "$_cpusched" = "hardened" ]; then
- source+=("${_patchsource}/sched/0001-bore-cachy.patch"
- "${_patchsource}/misc/0001-hardened.patch")
-fi
+
+case "$_cpusched" in
+ pds|bmq) # BMQ/PDS scheduler
+ source+=("${_patchsource}/sched/0001-prjc-cachy.patch");;
+ tt) ## TT Scheduler
+ source+=("${_patchsource}/sched/0001-tt-cachy.patch");;
+ bore) ## BORE Scheduler with latency_nice
+ [ -n "$_tune_bore" ] && source+=("${_patchsource}/misc/0001-bore-tuning-sysctl.patch")
+ source+=("${_patchsource}/sched/0001-bore-cachy.patch");;
+ hardened) ## Hardened Patches with BORE Scheduler
+ source+=("${_patchsource}/sched/0001-bore-cachy.patch"
+ "${_patchsource}/misc/0001-hardened.patch");;
+esac
+
## Kernel CFI Patch
if [ -n "$_use_kcfi" ]; then
BUILD_FLAGS=(
@@ -312,6 +291,8 @@ export KBUILD_BUILD_HOST=cachyos
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
+_die() { error "$@" ; exit; }
+
prepare() {
cd ${srcdir}/$_srcname
@@ -359,50 +340,23 @@ prepare() {
else
error "The value is empty. Choose the correct one again."
fi
- error "Selecting CachyOS config failed!"
- exit
+ _die "Selecting CachyOS config failed!"
fi
### Selecting the CPU scheduler
- if [ "$_cpusched" = "bmq" ]; then
- echo "Selecting BMQ CPU scheduler..."
- scripts/config -e SCHED_ALT \
- -e SCHED_BMQ \
- -d SCHED_PDS
- elif [ "$_cpusched" = "pds" ]; then
- echo "Selecting PDS CPU scheduler..."
- scripts/config -e SCHED_ALT \
- -d SCHED_BMQ \
- -e SCHED_PDS
- elif [ "$_cpusched" = "cacule" ]; then
- echo "Selecting CacULE scheduler..."
- scripts/config -e CACULE_SCHED \
- -d CACULE_RDB
- elif [ "$_cpusched" = "cacule-rdb" ]; then
- echo "Selecting CacULE-RDB scheduler..."
- scripts/config -e CACULE_SCHED \
- -e CACULE_RDB \
- --set-val RDB_INTERVAL 19
- elif [ "$_cpusched" = "bore" ]; then
- echo "Selecting BORE Scheduler..."
- scripts/config -e SCHED_BORE
- elif [ "$_cpusched" = "tt" ]; then
- echo "Selecting TT Scheduler..."
- scripts/config -e TT_SCHED \
- -e TT_ACCOUNTING_STATS
- elif [ "$_cpusched" = "cfs" ]; then
- echo "Selecting Completely Fair Scheduler..."
- elif [ "$_cpusched" = "hardened" ]; then
- echo "Selecting hardened patches with the BORE Scheduler..."
- else
- if [ -n "$_cpusched" ]; then
- error "The value $_cpusched is invalid. Choose the correct one again."
- else
- error "The value is empty. Choose the correct one again."
- fi
- error "Selecting the CPU scheduler failed!"
- exit
- fi
+ [ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
+
+ case "$_cpusched" in
+ pds) scripts/config -e SCHED_ALT -d SCHED_BMQ -e SCHED_PDS;;
+ bmq) scripts/config -e SCHED_ALT -e SCHED_BMQ -d SCHED_PDS;;
+ tt) scripts/config -e TT_SCHED -e TT_ACCOUNTING_STATS;;
+ bore|hardened) scripts/config -e SCHED_BORE;;
+ cfs) ;;
+ *) _die "The value $_cpusched is invalid. Choose the correct one again.";;
+ esac
+
+ local sched_name="$(echo $_cpusched|tr '[:lower:]' '[:upper:]')"
+ echo "Selecting ${sched_name} CPU scheduler..."
### Enable KCFI
if [ -n "$_use_kcfi" ]; then
@@ -448,19 +402,15 @@ prepare() {
fi
### Select tick rate
- if [[ -z $_HZ_ticks ]]; then
- error "The value is empty. Choose the correct one again."
- exit
- fi
+ [ -z $_HZ_ticks ] && _die "The value is empty. Choose the correct one again."
case "$_HZ_ticks" in
100|250|500|600|750|1000)
- scripts/config -d HZ_300 -e "HZ_${_HZ_ticks}" --set-val HZ $_HZ_ticks;;
+ scripts/config -d HZ_300 -e "HZ_${_HZ_ticks}" --set-val HZ "${_HZ_ticks}";;
300)
scripts/config -e HZ_300 --set-val HZ 300;;
*)
- error "The value $_HZ_ticks is invalid. Choose the correct one again."
- exit;;
+ _die "The value $_HZ_ticks is invalid. Choose the correct one again."
esac
echo "Setting tick rate to ${_HZ_ticks}Hz..."
@@ -541,8 +491,7 @@ prepare() {
else
error "The value is empty. Choose the correct one again."
fi
- error "Selecting the tick rate failed!"
- exit
+ _die "Selecting the tick rate failed!"
fi
### Select preempt type
@@ -579,8 +528,7 @@ prepare() {
else
error "The value is empty. Choose the correct one again."
fi
- error "Selecting PREEMPT failed!"
- exit
+ _die "Selecting PREEMPT failed!"
fi
### Enable O3
@@ -642,8 +590,7 @@ prepare() {
else
error "The value is empty. Choose the correct one again."
fi
- error "Enabling per-VMA locking failed!"
- exit
+ _die "Enabling per-VMA locking failed!"
fi
### Select THP
@@ -661,8 +608,7 @@ prepare() {
else
error "The value is empty. Choose the correct one again."
fi
- error "Setting THP has failed!"
- exit
+ _die "Setting THP has failed!"
fi
### Enable DAMON
@@ -780,8 +726,7 @@ prepare() {
else
error "The value is empty. Choose the correct one again."
fi
- error "Selecting the ZSTD modules and kernel compression level failed!"
- exit
+ _die "Selecting the ZSTD modules and kernel compression level failed!"
fi
### Disable DEBUG
@@ -1006,6 +951,7 @@ _package-headers() {
_package-zfs(){
pkgdesc="zfs module for the $pkgdesc kernel"
depends=('pahole' linux-$pkgsuffix=$_kernver)
+ provides=('ZFS-MODULE')
cd ${srcdir}/"zfs"
install -dm755 "$pkgdir/usr/lib/modules/${_kernver}-${pkgsuffix}"
@@ -1025,8 +971,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('b60bb53ab8ba370a270454b11e93d41af29126fc72bd6ede517673e2e57b816d'
+sha256sums=('d60cf185693c386e7acd9f3eb3a94ae30ffbfee0a9447a20e83711e0bdf5922b'
'fab53ac59d4da6fb0433f6fd15877871f4124a89021237f90835d1ff3755ba9c'
'41c34759ed248175e905c57a25e2b0ed09b11d054fe1a8783d37459f34984106'
- '775fd31535e3f025bd7597105fbc34def0265671f2c6000f253d4eb2f3883988'
+ '3c31aea899ab3ba5d4119fc08935b31f66b2d4da65b6adfbfd3b410114c25753'
'd23955f69440adab0e1edd4e372bcf424c4772556a6bca7565ddd087eaf31fec')