summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-04-13 19:24:59 +0200
committerPiotr Gorski2023-04-13 19:24:59 +0200
commitcd24d926a0daa68e594213a31cb8b4916ba58e10 (patch)
tree0c9f27213e206732b291ed0cca4ee55ae16ff783
parent678eda4a7816ac7a3598d72b7abda8a6ecfad5cc (diff)
downloadaur-cd24d926a0daa68e594213a31cb8b4916ba58e10.tar.gz
Bump to 6.2.11
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD37
-rw-r--r--config4
3 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29eacc5845b9..0f0c24416a8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-tt
pkgdesc = Linux TT scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 6.2.10
+ pkgver = 6.2.11
pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
@@ -21,15 +21,15 @@ pkgbase = linux-tt
makedepends = make
makedepends = patch
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.2.10.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.2.11.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.2/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.2/sched/0001-tt-cachy.patch
- sha256sums = 57c562c3cd2753f232549cab05c8ad770ed848ae86401619c7581bdffaeea4fe
- sha256sums = c37cd629b9044fe1e1ebf86dd1bc5f99aa472d8c4ccad314c36c247a2b97daac
+ sha256sums = 0d236784e60b87c7953535aeb148dd9e773b26495dfa9c6d69615f54fe00dd47
+ sha256sums = 816508270cc1062a9089548a7320922c028431450db4231fc5786d81beedd9ed
sha256sums = 41c34759ed248175e905c57a25e2b0ed09b11d054fe1a8783d37459f34984106
- sha256sums = 367a6d70bd990a142ef9541d75166b1fca06953dbfff0c9846ce3ebd77abe7d2
+ sha256sums = cef5b2e45c376a0d7a78ba48f9c3c86b883cb50226faf9313958f4c30ef5604b
sha256sums = c5c48b3e6b08c54b7d057f32da5d11478cf25ba87c903727a77a7b5a8d3f78a8
pkgname = linux-tt
diff --git a/PKGBUILD b/PKGBUILD
index 96800fecd983..8b15089a7064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,7 @@ _cachy_config=${_cachy_config-y}
# 'cfs' - select 'Completely Fair Scheduler'
# 'tt' - select 'Task Type Scheduler by Hamad Marri'
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
+# 'cachyos' - select EEVDF Scheduler with some CachyOS Optimizations. EEVDF does bring latency-nice as default
_cpusched=${_cpusched-tt}
## Apply some suggested sysctl values from the bore developer
@@ -97,7 +98,8 @@ _lru_config=${_lru_config-standard}
# 'standard' - enable per-VMA locking
# 'stats' - enable per-VMA locking with stats
# 'none' - disable per-VMA locking
-_vma_config=${_vma_config-none}
+# Broken since 6.2.11 due the maple tree RCU patches. Will be as default enabled in 6.3
+# _vma_config=${_vma_config-none}
### Transparent Hugepages
# ATTENTION - one of two predefined values should be selected!
@@ -182,6 +184,7 @@ _bcachefs=${_bcachefs-}
# You need to set the values per task
# Ananicy-cpp has a implementation for this
# You need to configure ananicy-cpp for this or use existing settings
+# Its default enabled at the "cachyos" scheduler option
_latency_nice=${_latency_nice-}
if [[ "$_use_llvm_lto" = "thin" || "$_use_llvm_lto" = "full" ]] && [ -n "$_use_lto_suffix" ]; then
@@ -193,7 +196,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.2
-_minor=10
+_minor=11
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -241,6 +244,8 @@ if [ -n "$_latency_nice" ]; then
fi
case "$_cpusched" in
+ cachyos) # CachyOS Scheduler (EEVDF)
+ source+=("${_patchsource}/sched/0001-EEVDF.patch");;
pds|bmq) # BMQ/PDS scheduler
source+=("${_patchsource}/sched/0001-prjc-cachy.patch");;
tt) ## TT Scheduler
@@ -325,7 +330,7 @@ prepare() {
pds) scripts/config -e SCHED_ALT -d SCHED_BMQ -e SCHED_PDS -e PSI_DEFAULT_DISABLED;;
bmq) scripts/config -e SCHED_ALT -e SCHED_BMQ -d SCHED_PDS -e PSI_DEFAULT_DISABLED;;
tt) scripts/config -e TT_SCHED -e TT_ACCOUNTING_STATS;;
- bore|hardened) scripts/config -e SCHED_BORE;;
+ bore|hardened|cachyos) scripts/config -e SCHED_BORE;;
cfs) ;;
*) _die "The value $_cpusched is invalid. Choose the correct one again.";;
esac
@@ -477,16 +482,16 @@ prepare() {
echo "Selecting '$_lru_config' LRU_GEN config..."
### Select VMA config
- [ -z "$_vma_config" ] && _die "The value is empty. Choose the correct one again."
-
- case "$_vma_config" in
- standard) scripts/config -e PER_VMA_LOCK -d PER_VMA_LOCK_STATS;;
- stats) scripts/config -e PER_VMA_LOCK -e PER_VMA_LOCK_STATS;;
- none) scripts/config -d PER_VMA_LOCK;;
- *) _die "The value '$_vma_config' is invalid. Choose the correct one again.";;
- esac
-
- echo "Selecting '$_vma_config' PER_VMA_LOCK config..."
+# [ -z "$_vma_config" ] && _die "The value is empty. Choose the correct one again."
+#
+# case "$_vma_config" in
+# standard) scripts/config -e PER_VMA_LOCK -d PER_VMA_LOCK_STATS;;
+# stats) scripts/config -e PER_VMA_LOCK -e PER_VMA_LOCK_STATS;;
+# none) scripts/config -d PER_VMA_LOCK;;
+# *) _die "The value '$_vma_config' is invalid. Choose the correct one again.";;
+# esac
+#
+# echo "Selecting '$_vma_config' PER_VMA_LOCK config..."
### Select THP
[ -z "$_hugepage" ] && _die "The value is empty. Choose the correct one again."
@@ -841,8 +846,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('57c562c3cd2753f232549cab05c8ad770ed848ae86401619c7581bdffaeea4fe'
- 'c37cd629b9044fe1e1ebf86dd1bc5f99aa472d8c4ccad314c36c247a2b97daac'
+sha256sums=('0d236784e60b87c7953535aeb148dd9e773b26495dfa9c6d69615f54fe00dd47'
+ '816508270cc1062a9089548a7320922c028431450db4231fc5786d81beedd9ed'
'41c34759ed248175e905c57a25e2b0ed09b11d054fe1a8783d37459f34984106'
- '367a6d70bd990a142ef9541d75166b1fca06953dbfff0c9846ce3ebd77abe7d2'
+ 'cef5b2e45c376a0d7a78ba48f9c3c86b883cb50226faf9313958f4c30ef5604b'
'c5c48b3e6b08c54b7d057f32da5d11478cf25ba87c903727a77a7b5a8d3f78a8')
diff --git a/config b/config
index a69e88ce213d..982138524ae6 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.2.8 Kernel Configuration
+# Linux/x86 6.2.11 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.2.1 20230311"
CONFIG_CC_IS_GCC=y
@@ -18,7 +18,7 @@ CONFIG_CC_HAS_ASM_GOTO_OUTPUT=y
CONFIG_CC_HAS_ASM_GOTO_TIED_OUTPUT=y
CONFIG_CC_HAS_ASM_INLINE=y
CONFIG_CC_HAS_NO_PROFILE_FN_ATTR=y
-CONFIG_PAHOLE_VERSION=124
+CONFIG_PAHOLE_VERSION=125
CONFIG_IRQ_WORK=y
CONFIG_BUILDTIME_TABLE_SORT=y
CONFIG_THREAD_INFO_IN_TASK=y