summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-08-12 19:29:37 +0200
committerPiotr Gorski2023-08-12 19:29:37 +0200
commitde5912d8507f8eda306ea33d34a1d3e44e917c65 (patch)
tree9206f34cac9071b7aec72c72554f19f92bcf8969
parentd9fdc0f011fba79a385fccf76e4b3899153df8de (diff)
downloadaur-de5912d8507f8eda306ea33d34a1d3e44e917c65.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--config2
3 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 312e80e9c0f5..72bd34cf2f49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-tt
pkgdesc = Linux TT scheduler Kernel by CachyOS with other patches and improvements
pkgver = 6.4.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -28,7 +28,7 @@ pkgbase = linux-tt
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.4/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.4/sched/0001-tt-cachy.patch
b2sums = 700017448073f63880739efed3f60baba18116500737419e305b2b5e0d2532e2d40a41368c773772cba437236bc1edda85c8f16ca23a945c754e283a30184a6d
- b2sums = cd383af01fcba36732f3be5bce46b8a809bf29390025418bb37bd188f7a97845185f6e84b313244147ad9c006c2edaf4b108866224b77221d28086cf3f9009cf
+ b2sums = f86d5bc428a0a3213b186fc16e05779256f243b097b37e69af10b4cce29a9fbcd5b4458b057a86a9aaf12659da7c44df711844cb3beda3f995aa2c2fe7435f17
b2sums = 11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0
b2sums = 3ec64cda731868642c3e502e09991d2b30779e1fb6194e00b2a3fbfc9516c8cf3f86c1c3475c5fa11a2e71e208748d4c693b688c7fd20690486ad28a61111f0e
b2sums = bf474ebc49632279d6af0f054c2a350660aabf1584a59842f6f39cbd0d79cb2763d3328565142637a7792ed2fdcf2eab68f2f68c33296c06445abde4ed1b73c5
diff --git a/PKGBUILD b/PKGBUILD
index a1f3bf958455..4cf494d0da70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -178,7 +178,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux TT scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=1
+pkgrel=2
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -286,12 +286,24 @@ prepare() {
"${srcdir}"/auto-cpu-optimization.sh
fi
+ ### Prevent ZFS and bcachefs building at the same time
+ # More infos here: https://github.com/CachyOS/linux-cachyos/issues/152
+ if [[ -n "$_bcachefs" && -n "$_build_zfs" ]]; then
+ _die "ZFS and bcachefs support cannot be built at the same time. "
+ fi
+
### Selecting CachyOS config
if [ -n "$_cachy_config" ]; then
echo "Enabling CachyOS config..."
scripts/config -e CACHY
fi
+ ### Workaround for bcachefs
+ # More infos here: https://github.com/CachyOS/linux-cachyos/issues/152
+ if [ -n "$_bcachefs" ]; then
+ scripts/config -d DRM_ACCEL_IVPU
+ fi
+
### Selecting the CPU scheduler
[ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
@@ -790,7 +802,7 @@ for _p in "${pkgname[@]}"; do
done
b2sums=('700017448073f63880739efed3f60baba18116500737419e305b2b5e0d2532e2d40a41368c773772cba437236bc1edda85c8f16ca23a945c754e283a30184a6d'
- 'cd383af01fcba36732f3be5bce46b8a809bf29390025418bb37bd188f7a97845185f6e84b313244147ad9c006c2edaf4b108866224b77221d28086cf3f9009cf'
+ 'f86d5bc428a0a3213b186fc16e05779256f243b097b37e69af10b4cce29a9fbcd5b4458b057a86a9aaf12659da7c44df711844cb3beda3f995aa2c2fe7435f17'
'11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0'
'3ec64cda731868642c3e502e09991d2b30779e1fb6194e00b2a3fbfc9516c8cf3f86c1c3475c5fa11a2e71e208748d4c693b688c7fd20690486ad28a61111f0e'
'bf474ebc49632279d6af0f054c2a350660aabf1584a59842f6f39cbd0d79cb2763d3328565142637a7792ed2fdcf2eab68f2f68c33296c06445abde4ed1b73c5')
diff --git a/config b/config
index 214625c440ed..b3c0834fd49c 100644
--- a/config
+++ b/config
@@ -2394,7 +2394,7 @@ CONFIG_ISCSI_IBFT=m
CONFIG_FW_CFG_SYSFS=m
# CONFIG_FW_CFG_SYSFS_CMDLINE is not set
CONFIG_SYSFB=y
-CONFIG_SYSFB_SIMPLEFB=y
+# CONFIG_SYSFB_SIMPLEFB is not set
CONFIG_FW_CS_DSP=m
CONFIG_GOOGLE_FIRMWARE=y
# CONFIG_GOOGLE_SMI is not set