summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2019-05-05 02:40:04 +0200
committerPiotr Gorski2019-05-05 02:40:04 +0200
commitbc08a095c9693b4ff274f00f07b89010ec3683e9 (patch)
treee64955c075f52b6f680379433c2a2085ff9bc418
parent145d1a86692b2780b655d5a07979d6ac26965742 (diff)
downloadaur-bc08a095c9693b4ff274f00f07b89010ec3683e9.tar.gz
Add udp patches
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a71a4b84ad4..75e57382d1b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-uksm
pkgver = 5.0.12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dolohow/uksm
arch = x86_64
license = GPL2
@@ -14,6 +14,8 @@ pkgbase = linux-uksm
source = https://raw.githubusercontent.com/graysky2/kernel_gcc_patch/master/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch
source = https://raw.githubusercontent.com/sirlucjan/uksm/master/v5.x/uksm-5.0.10.patch
source = https://gitlab.com/sirlucjan/kernel-patches/raw/master/5.0/arch-patches/0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+ source = https://gitlab.com/sirlucjan/kernel-patches/raw/master/5.0/arch-patches-v2/0001-udp-fix-GRO-reception-in-case-of-length-mismatch.patch
+ source = https://gitlab.com/sirlucjan/kernel-patches/raw/master/5.0/arch-patches-v2/0002-udp-fix-GRO-packet-of-death.patch
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -25,6 +27,8 @@ pkgbase = linux-uksm
sha512sums = e62aa377a0acc4f63f394e27a0fb7316583ff1a6a6afdfcc97593ddffd7d2bc224cfd70b552cb3fb9513cf6b8db4c2fd913d21ec2380db8cd642e37d4d67370c
sha512sums = adf7f7195b0811c13b950b147f24b51874f072c02005ab312f9937dedd9d2356e92dd7537d5603cfaea2e3d1eb0d6872e81af57496d9b42b7f2ec271ec181a77
sha512sums = 1e8a1deb7a0100627b928b588a9419b58aa42ac1b33d974b83c24dcd4e5f59ace694959e30df2692a96de329d8bab61cd42bb59578f7814845391203416d7364
+ sha512sums = d3da993cbb4988c638548a2a614c43b73de46ba05ee0282355922ce1d34a38dea1aef3c3314a3bb6921a0e61a2623a741d0728f4593c0e8134b009fa68ea8bd0
+ sha512sums = 033ccdff31322b2b5ccedc129ced9d8ab1dad41491a97ea2b2f1f39dd61444fe5bfb794cafcf97ff3617007c057dc4359f039a68231becbdc620a1ab8c26178f
sha512sums = dd1cb821dafe6f292f5486eb36f4a19469d7704d050ac109a2214bc8592fa68845e16fc0800e3ee4ed52eaddba67ae8f4b2639568fa4e3f3ada7baceab047696
sha512sums = 7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a
sha512sums = 2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7
diff --git a/PKGBUILD b/PKGBUILD
index 77f8f5fcf6d5..3f69e90b0a0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,7 @@ _major=5.0
_minor=12
pkgver=${_major}.${_minor}
_srcname=linux-${pkgver}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/dolohow/uksm"
license=('GPL2')
@@ -77,6 +77,8 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
#"${_lucjanpath}/uksm-dev/${_uksm_patch}"
"${_uksm_path}/${_uksm_patch}"
"${_lucjanpath}/arch-patches/0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch"
+ "${_lucjanpath}/arch-patches-v2/0001-udp-fix-GRO-reception-in-case-of-length-mismatch.patch"
+ "${_lucjanpath}/arch-patches-v2/0002-udp-fix-GRO-packet-of-death.patch"
# the main kernel config files
'config'
# pacman hook for depmod
@@ -375,6 +377,8 @@ sha512sums=('cf3b2607d9f4fac1e5724c71fdb7cbbcd86711ddad45a045f805ac9250c759ec558
'e62aa377a0acc4f63f394e27a0fb7316583ff1a6a6afdfcc97593ddffd7d2bc224cfd70b552cb3fb9513cf6b8db4c2fd913d21ec2380db8cd642e37d4d67370c'
'adf7f7195b0811c13b950b147f24b51874f072c02005ab312f9937dedd9d2356e92dd7537d5603cfaea2e3d1eb0d6872e81af57496d9b42b7f2ec271ec181a77'
'1e8a1deb7a0100627b928b588a9419b58aa42ac1b33d974b83c24dcd4e5f59ace694959e30df2692a96de329d8bab61cd42bb59578f7814845391203416d7364'
+ 'd3da993cbb4988c638548a2a614c43b73de46ba05ee0282355922ce1d34a38dea1aef3c3314a3bb6921a0e61a2623a741d0728f4593c0e8134b009fa68ea8bd0'
+ '033ccdff31322b2b5ccedc129ced9d8ab1dad41491a97ea2b2f1f39dd61444fe5bfb794cafcf97ff3617007c057dc4359f039a68231becbdc620a1ab8c26178f'
'dd1cb821dafe6f292f5486eb36f4a19469d7704d050ac109a2214bc8592fa68845e16fc0800e3ee4ed52eaddba67ae8f4b2639568fa4e3f3ada7baceab047696'
'7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a'
'2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7'