summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-01-26 14:05:00 +0100
committerPiotr Gorski2023-01-26 14:05:00 +0100
commit49372ce775c5e1c0cb06d65d776526ad8cd287fa (patch)
tree643f0b92b9f13f45730ce9572efdea9710a228c5
parent140edcd3daf0100efd2a49353c0d7e04f9c97d29 (diff)
downloadaur-49372ce775c5e1c0cb06d65d776526ad8cd287fa.tar.gz
Add lto support
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--config2
3 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c3a9cd43bd1..33c064eb2746 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-usermode
pkgdesc = User mode Linux kernel and modules
pkgver = 6.1.8
- pkgrel = 1
+ pkgrel = 2
url = http://user-mode-linux.sourceforge.net/
arch = x86_64
license = GPL2
@@ -10,13 +10,15 @@ pkgbase = linux-usermode
depends = coreutils
source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.1.8.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.1.8.tar.sign
+ source = https://gitlab.com/sirlucjan/kernel-patches/raw/master/6.1/um-patches/0001-um-Support-LTO.patch
source = config
source = 70-uml.hook
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = b60bb53ab8ba370a270454b11e93d41af29126fc72bd6ede517673e2e57b816d
sha256sums = SKIP
- sha256sums = 16d94dbe31b1b2ed2ec5b901f44c03a9fa69d8c2e9dfe3646408591e16d27d26
+ sha256sums = 4f20c25d0b185a2a10836a765451af316e05fb9e66b8a6773d4299448b5aeb8a
+ sha256sums = f56024e6ee3ac6a9808b766c2604a51564dff9e3d2223fbd05f1b883d9ff31e9
sha256sums = 05ea4e00d1e99bf8140a21c94e3c42acf17b9debad9c6f5decbe1dd1fe04332c
pkgname = linux-usermode
diff --git a/PKGBUILD b/PKGBUILD
index a3d3e7bb05b2..7384bcc40f54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,26 @@ _major=6.1
_minor=8
pkgver=${_major}.${_minor}
_srcname=linux-${pkgver}
-pkgrel=1
+pkgrel=2
pkgdesc="User mode Linux kernel and modules"
arch=('x86_64')
license=('GPL2')
url="http://user-mode-linux.sourceforge.net/"
depends=('coreutils')
makedepends=('bc' 'inetutils')
+#_lucjanpath="https://raw.githubusercontent.com/sirlucjan/kernel-patches/master/${_major}"
+_lucjanpath="https://gitlab.com/sirlucjan/kernel-patches/raw/master/${_major}"
+
source=("https://www.kernel.org/pub/linux/kernel/v6.x/linux-${pkgver}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v6.x/linux-${pkgver}.tar.sign"
+ "${_lucjanpath}/um-patches/0001-um-Support-LTO.patch"
'config'
'70-uml.hook')
sha256sums=('b60bb53ab8ba370a270454b11e93d41af29126fc72bd6ede517673e2e57b816d'
'SKIP'
- '16d94dbe31b1b2ed2ec5b901f44c03a9fa69d8c2e9dfe3646408591e16d27d26'
+ '4f20c25d0b185a2a10836a765451af316e05fb9e66b8a6773d4299448b5aeb8a'
+ 'f56024e6ee3ac6a9808b766c2604a51564dff9e3d2223fbd05f1b883d9ff31e9'
'05ea4e00d1e99bf8140a21c94e3c42acf17b9debad9c6f5decbe1dd1fe04332c')
validpgpkeys=(
diff --git a/config b/config
index 0a6e88bbf950..6e4837a09b1e 100644
--- a/config
+++ b/config
@@ -295,6 +295,8 @@ CONFIG_HAVE_ARCH_SECCOMP_FILTER=y
CONFIG_SECCOMP=y
CONFIG_SECCOMP_FILTER=y
# CONFIG_SECCOMP_CACHE_DEBUG is not set
+CONFIG_ARCH_SUPPORTS_LTO_CLANG=y
+CONFIG_ARCH_SUPPORTS_LTO_CLANG_THIN=y
CONFIG_LTO_NONE=y
CONFIG_HAVE_VIRT_CPU_ACCOUNTING_GEN=y
CONFIG_MODULES_USE_ELF_RELA=y