summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2019-09-06 20:32:16 +0200
committerPiotr Gorski2019-09-06 20:32:16 +0200
commit8d4002ceb59b5c481211bdb89ad42e240a588715 (patch)
tree97307b15d9b651d3cf91c318c8979853821c14a6
parent472fff45efe217dec5ac6b5b60aa5df637519cef (diff)
downloadaur-8d4002ceb59b5c481211bdb89ad42e240a588715.tar.gz
Bump to 5.2.13-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO17
-rw-r--r--001-hide_the_int3_emulate_call_jmp_functions_from_uml.patch36
-rw-r--r--70-uml.hook11
-rw-r--r--PKGBUILD108
-rw-r--r--config188
-rw-r--r--modules.install11
6 files changed, 235 insertions, 136 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5daa0eef02c0..51fb96680dbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-usermode
pkgdesc = User mode Linux kernel and modules
- pkgver = 5.1.5
+ pkgver = 5.2.13
pkgrel = 1
url = http://user-mode-linux.sourceforge.net/
arch = x86_64
@@ -8,21 +8,18 @@ pkgbase = linux-usermode
makedepends = bc
makedepends = inetutils
depends = coreutils
- source = http://www.kernel.org/pub/linux/kernel/v5.x/linux-5.1.tar.xz
- source = http://www.kernel.org/pub/linux/kernel/v5.x/linux-5.1.tar.sign
- source = http://www.kernel.org/pub/linux/kernel/v5.x/patch-5.1.5.xz
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.2.13.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.2.13.tar.sign
source = config
- source = 001-hide_the_int3_emulate_call_jmp_functions_from_uml.patch
+ source = 70-uml.hook
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = d06a7be6e73f97d1350677ad3bae0ce7daecb79c2c2902aaabe806f7fa94f041
+ sha256sums = 17b60f55241dee4b9a2919a653de144ef1002e2de49ccf5d15225b1f07bc178a
sha256sums = SKIP
- sha256sums = def1a382c555454daf28fb768ed2c3e6f339c4bfcd36faa99982e4d31c04efa6
- sha256sums = c2741019f57c2c918ad80cbf0fad0d03ef585fadf045078b3117cd73d83e5f2b
- sha256sums = f292341bdbc90f27ea6775bf3c709d92fbf8842c7cf7603c71807f06ad1e69a9
+ sha256sums = a5ad6d1bad174fa407e891c2128746125b2bc0c921be5459ce90fe1949ef617c
+ sha256sums = 452b8d4d71e1565ca91b1bebb280693549222ef51c47ba8964e411b2d461699c
pkgname = linux-usermode
pkgname = linux-usermode-modules
- install = modules.install
diff --git a/001-hide_the_int3_emulate_call_jmp_functions_from_uml.patch b/001-hide_the_int3_emulate_call_jmp_functions_from_uml.patch
deleted file mode 100644
index d9374cb165cd..000000000000
--- a/001-hide_the_int3_emulate_call_jmp_functions_from_uml.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From: "Steven Rostedt (VMware)" <rostedt@goodmis.org>
-
-User Mode Linux does not have access to the ip or sp fields of the pt_regs,
-and accessing them causes UML to fail to build. Hide the int3_emulate_jmp()
-and int3_emulate_call() instructions from UML, as it doesn't need them
-anyway.
-
-Reported-by: kbuild test robot <lkp@intel.com>
-Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
----
- arch/x86/include/asm/text-patching.h | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/arch/x86/include/asm/text-patching.h b/arch/x86/include/asm/text-patching.h
-index 05861cc08787..0bbb07eaed6b 100644
---- a/arch/x86/include/asm/text-patching.h
-+++ b/arch/x86/include/asm/text-patching.h
-@@ -39,6 +39,7 @@ extern int poke_int3_handler(struct pt_regs *regs);
- extern void *text_poke_bp(void *addr, const void *opcode, size_t len, void *handler);
- extern int after_bootmem;
-
-+#ifndef CONFIG_UML_X86
- static inline void int3_emulate_jmp(struct pt_regs *regs, unsigned long ip)
- {
- regs->ip = ip;
-@@ -65,6 +66,7 @@ static inline void int3_emulate_call(struct pt_regs *regs, unsigned long func)
- int3_emulate_push(regs, regs->ip - INT3_INSN_SIZE + CALL_INSN_SIZE);
- int3_emulate_jmp(regs, func);
- }
--#endif
-+#endif /* CONFIG_X86_64 */
-+#endif /* !CONFIG_UML_X86 */
-
- #endif /* _ASM_X86_TEXT_PATCHING_H */
---
-2.20.1
diff --git a/70-uml.hook b/70-uml.hook
new file mode 100644
index 000000000000..584ce35372b0
--- /dev/null
+++ b/70-uml.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/modules/%KERNVER%/*
+
+[Action]
+Description = Updating %PKGBASE% module dependencies...
+When = PostTransaction
+Exec = /usr/bin/depmod %KERNVER%
diff --git a/PKGBUILD b/PKGBUILD
index 20680a9837bb..dccffab7261c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: Haruue Icymoon <haruue@caoyue.com.cn>
-# Contributor: Lucjan Lucjanov <lucjan.lucjanov@gmail.com>
+# Maintainer: Piotr Gorski <lucjan.lucjanov@gmail.com>
+# Contributor: Haruue Icymoon <haruue@caoyue.com.cn>
-pkgname=linux-usermode
-true && pkgname=(linux-usermode linux-usermode-modules)
pkgbase=linux-usermode
+pkgname=('linux-usermode' 'linux-usermode-modules')
_kernelname=-usermodelinux
-_srcname=linux-5.1
-pkgver=5.1.5
+_major=5.2
+_minor=13
+pkgver=${_major}.${_minor}
+_srcname=linux-${pkgver}
pkgrel=1
pkgdesc="User mode Linux kernel and modules"
arch=('x86_64')
@@ -14,74 +15,79 @@ license=('GPL2')
url="http://user-mode-linux.sourceforge.net/"
depends=('coreutils')
makedepends=('bc' 'inetutils')
-source=(
- http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.{xz,sign}
-# http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
- http://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz
- config
- 001-hide_the_int3_emulate_call_jmp_functions_from_uml.patch)
+source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.xz"
+ "https://www.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.sign"
+ 'config'
+ '70-uml.hook')
-sha256sums=('d06a7be6e73f97d1350677ad3bae0ce7daecb79c2c2902aaabe806f7fa94f041'
+sha256sums=('17b60f55241dee4b9a2919a653de144ef1002e2de49ccf5d15225b1f07bc178a'
'SKIP'
- 'def1a382c555454daf28fb768ed2c3e6f339c4bfcd36faa99982e4d31c04efa6'
- 'c2741019f57c2c918ad80cbf0fad0d03ef585fadf045078b3117cd73d83e5f2b'
- 'f292341bdbc90f27ea6775bf3c709d92fbf8842c7cf7603c71807f06ad1e69a9')
+ 'a5ad6d1bad174fa407e891c2128746125b2bc0c921be5459ce90fe1949ef617c'
+ '452b8d4d71e1565ca91b1bebb280693549222ef51c47ba8964e411b2d461699c')
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
-)
+ 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ )
prepare() {
- cd "${srcdir}/${_srcname}"
-
- # add upstream patch
- patch -p1 -i "${srcdir}/patch-${pkgver}"
-
- # https://lkml.org/lkml/2019/5/14/966
- patch -Np1 -i "${srcdir}"/001-hide_the_int3_emulate_call_jmp_functions_from_uml.patch
-
- cat ../config - >.config <<END
-CONFIG_LOCALVERSION="${_kernelname}"
-CONFIG_LOCALVERSION_AUTO=n
-END
+ cd ${_srcname}
+
+ msg2 "Setting version..."
+ sed -e "/^EXTRAVERSION =/s/=.*/=/" -i Makefile
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "$_kernelname" > localversion.20-pkgname
+
+ msg2 "Setting config..."
+ cp ../config .config
+ yes "" | make ARCH=um config >/dev/null
- # set extraversion to pkgrel
- sed -i "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" Makefile
+ make ARCH=um kernelrelease > ../version
+ msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
- # rewrite configuration
- yes "" | make ARCH=um config >/dev/null
+ msg2 "Save configuration for later reuse"
+ cat .config > "${startdir}/config.last"
}
build() {
- cd "${srcdir}/${_srcname}"
+ cd ${_srcname}
unset LDFLAGS CFLAGS
-
make ARCH=um vmlinux modules
}
-package_linux-usermode() {
- cd "${srcdir}/${_srcname}"
+_package() {
+
+ cd ${_srcname}
mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/share/kernel-usermode"
install -m 644 System.map ${pkgdir}/usr/share/kernel-usermode/System.map
install -m 755 vmlinux ${pkgdir}/usr/bin/
}
-package_linux-usermode-modules() {
- install=modules.install
-
- cd "${srcdir}/${_srcname}"
-
- # get kernel version, but discard the first result
- make ARCH=um kernelrelease > /dev/null
- _kernver="$(make ARCH=um kernelrelease)"
+_package-modules() {
+
+ local kernver="$(<version)"
+ cd ${_srcname}
# make ARCH=um INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
make ARCH=um INSTALL_MOD_PATH="${pkgdir}/usr" _modinst_
- rm -f $pkgdir/usr/lib/modules/${_kernver}/{source,build}
- sed \
- -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
- -i "${startdir}/modules.install"
+ rm -f $pkgdir/usr/lib/modules/${kernver}/{source,build}
+ # sed expression for following substitutions
+ local _subst="
+ s|%PKGBASE%|${pkgbase}|g
+ s|%KERNVER%|${kernver}|g
+ "
+ # install pacman hook
+ sed "${_subst}" ../70-uml.hook |
+ install -Dm644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/70-uml.hook"
}
+pkgname=("${pkgbase}" "${pkgbase}-modules")
+for _p in ${pkgname[@]}; do
+ eval "package_${_p}() {
+ $(declare -f "_package${_p#${pkgbase}}")
+ _package${_p#${pkgbase}}
+ }"
+done
+
# vim:set ts=8 sts=2 sw=2 et:
diff --git a/config b/config
index e681a7eeb889..08408b29d36e 100644
--- a/config
+++ b/config
@@ -1,13 +1,13 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/um 5.1.5-1 Kernel Configuration
+# Linux/um 5.2.0 Kernel Configuration
#
#
-# Compiler: gcc (GCC) 8.3.0
+# Compiler: gcc (GCC) 9.1.0
#
CONFIG_CC_IS_GCC=y
-CONFIG_GCC_VERSION=80300
+CONFIG_GCC_VERSION=90100
CONFIG_CLANG_VERSION=0
CONFIG_CC_HAS_ASM_GOTO=y
CONFIG_CC_HAS_WARN_MAYBE_UNINITIALIZED=y
@@ -19,7 +19,7 @@ CONFIG_IRQ_WORK=y
#
CONFIG_BROKEN_ON_SMP=y
CONFIG_INIT_ENV_ARG_LIMIT=128
-CONFIG_LOCALVERSION="-usermodelinux"
+CONFIG_LOCALVERSION=""
# CONFIG_LOCALVERSION_AUTO is not set
CONFIG_BUILD_SALT=""
CONFIG_DEFAULT_HOSTNAME="(none)"
@@ -37,6 +37,8 @@ CONFIG_HAVE_ARCH_AUDITSYSCALL=y
# IRQ subsystem
#
CONFIG_GENERIC_IRQ_SHOW=y
+# end of IRQ subsystem
+
CONFIG_GENERIC_CLOCKEVENTS=y
#
@@ -48,6 +50,8 @@ CONFIG_NO_HZ_COMMON=y
CONFIG_NO_HZ_IDLE=y
CONFIG_NO_HZ=y
CONFIG_HIGH_RES_TIMERS=y
+# end of Timers subsystem
+
CONFIG_PREEMPT_NONE=y
#
@@ -58,6 +62,7 @@ CONFIG_BSD_PROCESS_ACCT=y
# CONFIG_BSD_PROCESS_ACCT_V3 is not set
# CONFIG_TASKSTATS is not set
# CONFIG_PSI is not set
+# end of CPU/Task time and stats accounting
#
# RCU Subsystem
@@ -66,9 +71,11 @@ CONFIG_TINY_RCU=y
# CONFIG_RCU_EXPERT is not set
CONFIG_SRCU=y
CONFIG_TINY_SRCU=y
-CONFIG_BUILD_BIN2C=y
+# end of RCU Subsystem
+
CONFIG_IKCONFIG=y
CONFIG_IKCONFIG_PROC=y
+# CONFIG_IKHEADERS is not set
CONFIG_LOG_BUF_SHIFT=14
CONFIG_PRINTK_SAFE_LOG_BUF_SHIFT=13
CONFIG_CGROUPS=y
@@ -100,7 +107,6 @@ CONFIG_SYSFS_DEPRECATED=y
# CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE is not set
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_SYSCTL=y
-CONFIG_ANON_INODES=y
CONFIG_HAVE_UID16=y
CONFIG_BPF=y
# CONFIG_EXPERT is not set
@@ -135,13 +141,17 @@ CONFIG_KALLSYMS_BASE_RELATIVE=y
#
# Kernel Performance Events And Counters
#
+# end of Kernel Performance Events And Counters
+
CONFIG_VM_EVENT_COUNTERS=y
CONFIG_COMPAT_BRK=y
CONFIG_SLAB=y
# CONFIG_SLUB is not set
CONFIG_SLAB_MERGE_DEFAULT=y
# CONFIG_SLAB_FREELIST_RANDOM is not set
+# CONFIG_SHUFFLE_PAGE_ALLOCATOR is not set
# CONFIG_PROFILING is not set
+# end of General setup
#
# UML-specific options
@@ -174,11 +184,12 @@ CONFIG_CPU_SUP_INTEL=y
CONFIG_CPU_SUP_AMD=y
CONFIG_CPU_SUP_HYGON=y
CONFIG_CPU_SUP_CENTAUR=y
+# end of Host processor type and features
+
CONFIG_UML_X86=y
CONFIG_64BIT=y
CONFIG_X86_64=y
CONFIG_ARCH_DEFCONFIG="arch/um/configs/x86_64_defconfig"
-CONFIG_RWSEM_XCHGADD_ALGORITHM=y
CONFIG_3_LEVEL_PGTABLES=y
CONFIG_GENERIC_HWEIGHT=y
# CONFIG_STATIC_LINK is not set
@@ -186,11 +197,12 @@ CONFIG_LD_SCRIPT_DYN=y
CONFIG_HOSTFS=y
CONFIG_MCONSOLE=y
CONFIG_MAGIC_SYSRQ=y
-CONFIG_KERNEL_STACK_ORDER=1
+CONFIG_KERNEL_STACK_ORDER=2
# CONFIG_MMAPPER is not set
CONFIG_NO_DMA=y
CONFIG_PGTABLE_LEVELS=3
CONFIG_SECCOMP=y
+# end of UML-specific options
#
# UML Character Devices
@@ -209,6 +221,7 @@ CONFIG_UML_SOUND=m
CONFIG_SOUND=m
CONFIG_SOUND_OSS_CORE=y
CONFIG_HOSTAUDIO=m
+# end of UML Character Devices
#
# UML Network Devices
@@ -223,6 +236,7 @@ CONFIG_UML_NET_DAEMON=y
CONFIG_UML_NET_MCAST=y
# CONFIG_UML_NET_PCAP is not set
CONFIG_UML_NET_SLIRP=y
+# end of UML Network Devices
#
# General architecture-dependent options
@@ -241,9 +255,20 @@ CONFIG_ARCH_NO_PREEMPT=y
#
# GCOV-based kernel profiling
#
+# end of GCOV-based kernel profiling
+
CONFIG_PLUGIN_HOSTCC="g++"
CONFIG_HAVE_GCC_PLUGINS=y
-# CONFIG_GCC_PLUGINS is not set
+CONFIG_GCC_PLUGINS=y
+
+#
+# GCC plugins
+#
+# CONFIG_GCC_PLUGIN_LATENT_ENTROPY is not set
+# CONFIG_GCC_PLUGIN_RANDSTRUCT is not set
+# end of GCC plugins
+# end of General architecture-dependent options
+
CONFIG_RT_MUTEXES=y
CONFIG_BASE_SMALL=0
CONFIG_MODULES=y
@@ -272,6 +297,7 @@ CONFIG_BLOCK=y
# CONFIG_PARTITION_ADVANCED is not set
CONFIG_MSDOS_PARTITION=y
CONFIG_EFI_PARTITION=y
+# end of Partition Types
#
# IO Schedulers
@@ -279,6 +305,8 @@ CONFIG_EFI_PARTITION=y
CONFIG_MQ_IOSCHED_DEADLINE=y
CONFIG_MQ_IOSCHED_KYBER=y
# CONFIG_IOSCHED_BFQ is not set
+# end of IO Schedulers
+
CONFIG_INLINE_SPIN_UNLOCK_IRQ=y
CONFIG_INLINE_READ_UNLOCK=y
CONFIG_INLINE_READ_UNLOCK_IRQ=y
@@ -295,6 +323,7 @@ CONFIG_CORE_DUMP_DEFAULT_ELF_HEADERS=y
CONFIG_BINFMT_SCRIPT=y
CONFIG_BINFMT_MISC=m
CONFIG_COREDUMP=y
+# end of Executable file formats
#
# Memory Management options
@@ -314,10 +343,12 @@ CONFIG_NEED_PER_CPU_KM=y
# CONFIG_ZBUD is not set
# CONFIG_ZSMALLOC is not set
# CONFIG_IDLE_PAGE_TRACKING is not set
+CONFIG_ARCH_HAS_HMM_MIRROR=y
# CONFIG_PERCPU_STATS is not set
# CONFIG_GUP_BENCHMARK is not set
+# end of Memory Management options
+
CONFIG_NET=y
-CONFIG_SKB_EXTENSIONS=y
#
# Networking options
@@ -328,12 +359,7 @@ CONFIG_UNIX=y
CONFIG_UNIX_SCM=y
# CONFIG_UNIX_DIAG is not set
# CONFIG_TLS is not set
-CONFIG_XFRM=y
# CONFIG_XFRM_USER is not set
-# CONFIG_XFRM_INTERFACE is not set
-# CONFIG_XFRM_SUB_POLICY is not set
-# CONFIG_XFRM_MIGRATE is not set
-# CONFIG_XFRM_STATISTICS is not set
# CONFIG_NET_KEY is not set
CONFIG_INET=y
# CONFIG_IP_MULTICAST is not set
@@ -350,9 +376,6 @@ CONFIG_NET_IP_TUNNEL=y
# CONFIG_INET_ESP is not set
# CONFIG_INET_IPCOMP is not set
CONFIG_INET_TUNNEL=y
-CONFIG_INET_XFRM_MODE_TRANSPORT=y
-CONFIG_INET_XFRM_MODE_TUNNEL=y
-CONFIG_INET_XFRM_MODE_BEET=y
CONFIG_INET_DIAG=y
CONFIG_INET_TCP_DIAG=y
# CONFIG_INET_UDP_DIAG is not set
@@ -369,10 +392,6 @@ CONFIG_IPV6=y
# CONFIG_INET6_ESP is not set
# CONFIG_INET6_IPCOMP is not set
# CONFIG_IPV6_MIP6 is not set
-CONFIG_INET6_XFRM_MODE_TRANSPORT=y
-CONFIG_INET6_XFRM_MODE_TUNNEL=y
-CONFIG_INET6_XFRM_MODE_BEET=y
-# CONFIG_INET6_XFRM_MODE_ROUTEOPTIMIZATION is not set
# CONFIG_IPV6_VTI is not set
CONFIG_IPV6_SIT=y
# CONFIG_IPV6_SIT_6RD is not set
@@ -425,6 +444,9 @@ CONFIG_BQL=y
# Network testing
#
# CONFIG_NET_PKTGEN is not set
+# end of Network testing
+# end of Networking options
+
# CONFIG_HAMRADIO is not set
# CONFIG_CAN is not set
# CONFIG_BT is not set
@@ -448,7 +470,6 @@ CONFIG_MAC80211_STA_HASH_MAX_SIZE=0
# CONFIG_LWTUNNEL is not set
CONFIG_DST_CACHE=y
CONFIG_GRO_CELLS=y
-# CONFIG_NET_DEVLINK is not set
# CONFIG_FAILOVER is not set
#
@@ -471,16 +492,21 @@ CONFIG_PREVENT_FIRMWARE_BUILD=y
CONFIG_FW_LOADER=y
CONFIG_EXTRA_FIRMWARE=""
# CONFIG_FW_LOADER_USER_HELPER is not set
+# end of Firmware loader
+
CONFIG_ALLOW_DEV_COREDUMP=y
# CONFIG_DEBUG_DRIVER is not set
# CONFIG_DEBUG_DEVRES is not set
# CONFIG_DEBUG_TEST_DRIVER_REMOVE is not set
# CONFIG_TEST_ASYNC_DRIVER_PROBE is not set
CONFIG_GENERIC_CPU_DEVICES=y
+# end of Generic Driver Options
#
# Bus devices
#
+# end of Bus devices
+
# CONFIG_CONNECTOR is not set
# CONFIG_GNSS is not set
# CONFIG_MTD is not set
@@ -502,6 +528,7 @@ CONFIG_BLK_DEV_NBD=m
#
# NVME Support
#
+# end of NVME Support
#
# Misc devices
@@ -514,10 +541,12 @@ CONFIG_BLK_DEV_NBD=m
# EEPROM support
#
# CONFIG_EEPROM_93CX6 is not set
+# end of EEPROM support
#
# Texas Instruments shared transport line discipline
#
+# end of Texas Instruments shared transport line discipline
#
# Altera FPGA firmware download module (requires I2C)
@@ -559,7 +588,10 @@ CONFIG_BLK_DEV_NBD=m
#
# VOP Driver
#
+# end of Intel MIC & related support
+
# CONFIG_ECHO is not set
+# end of Misc devices
#
# SCSI device support
@@ -567,6 +599,8 @@ CONFIG_BLK_DEV_NBD=m
CONFIG_SCSI_MOD=y
# CONFIG_RAID_ATTRS is not set
# CONFIG_SCSI is not set
+# end of SCSI device support
+
# CONFIG_MD is not set
# CONFIG_TARGET_CORE is not set
CONFIG_NETDEVICES=y
@@ -594,6 +628,8 @@ CONFIG_TUN=m
#
# Distributed Switch Architecture drivers
#
+# end of Distributed Switch Architecture drivers
+
CONFIG_ETHERNET=y
CONFIG_NET_VENDOR_ALACRITECH=y
CONFIG_NET_VENDOR_AMAZON=y
@@ -678,6 +714,7 @@ CONFIG_LEGACY_PTYS=y
CONFIG_LEGACY_PTY_COUNT=32
# CONFIG_N_GSM is not set
# CONFIG_TRACE_SINK is not set
+# CONFIG_NULL_TTY is not set
CONFIG_LDISC_AUTOLOAD=y
CONFIG_DEVMEM=y
# CONFIG_DEVKMEM is not set
@@ -685,11 +722,14 @@ CONFIG_DEVMEM=y
# CONFIG_HW_RANDOM is not set
CONFIG_UML_RANDOM=y
# CONFIG_RAW_DRIVER is not set
+# end of Character devices
#
# I2C support
#
# CONFIG_I2C is not set
+# end of I2C support
+
# CONFIG_I3C is not set
# CONFIG_SPMI is not set
# CONFIG_HSI is not set
@@ -703,6 +743,8 @@ CONFIG_UML_RANDOM=y
#
# Enable PHYLIB and NETWORK_PHY_TIMESTAMPING to see the additional clocks.
#
+# end of PTP clock support
+
# CONFIG_PINCTRL is not set
# CONFIG_GPIOLIB is not set
# CONFIG_POWER_AVS is not set
@@ -715,6 +757,8 @@ CONFIG_UML_RANDOM=y
#
# Graphics support
#
+# end of Graphics support
+
CONFIG_SOUND_OSS_CORE_PRECLAIM=y
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
# CONFIG_UWB is not set
@@ -726,6 +770,8 @@ CONFIG_USB_OHCI_LITTLE_ENDIAN=y
# DMABUF options
#
# CONFIG_SYNC_FILE is not set
+# end of DMABUF options
+
# CONFIG_AUXDISPLAY is not set
# CONFIG_UIO is not set
# CONFIG_VIRT_DRIVERS is not set
@@ -734,26 +780,34 @@ CONFIG_VIRTIO_MENU=y
#
# Microsoft Hyper-V guest support
#
+# end of Microsoft Hyper-V guest support
+
# CONFIG_STAGING is not set
# CONFIG_HWSPINLOCK is not set
#
# Clock Source drivers
#
+# end of Clock Source drivers
+
# CONFIG_MAILBOX is not set
CONFIG_IOMMU_SUPPORT=y
#
# Generic IOMMU Pagetable Support
#
+# end of Generic IOMMU Pagetable Support
#
# Remoteproc drivers
#
+# end of Remoteproc drivers
#
# Rpmsg drivers
#
+# end of Rpmsg drivers
+
# CONFIG_SOUNDWIRE is not set
#
@@ -763,27 +817,48 @@ CONFIG_IOMMU_SUPPORT=y
#
# Amlogic SoC drivers
#
+# end of Amlogic SoC drivers
+
+#
+# Aspeed SoC drivers
+#
+# end of Aspeed SoC drivers
#
# Broadcom SoC drivers
#
+# end of Broadcom SoC drivers
#
# NXP/Freescale QorIQ SoC drivers
#
+# end of NXP/Freescale QorIQ SoC drivers
#
# i.MX SoC drivers
#
+# end of i.MX SoC drivers
+
+#
+# IXP4xx SoC drivers
+#
+# CONFIG_IXP4XX_QMGR is not set
+# CONFIG_IXP4XX_NPE is not set
+# end of IXP4xx SoC drivers
#
# Qualcomm SoC drivers
#
+# end of Qualcomm SoC drivers
+
# CONFIG_SOC_TI is not set
#
# Xilinx SoC drivers
#
+# end of Xilinx SoC drivers
+# end of SOC (System On Chip) specific Drivers
+
# CONFIG_PM_DEVFREQ is not set
# CONFIG_EXTCON is not set
# CONFIG_MEMORY is not set
@@ -794,6 +869,8 @@ CONFIG_IOMMU_SUPPORT=y
# IRQ chip support
#
CONFIG_ARM_GIC_MAX_NR=1
+# end of IRQ chip support
+
# CONFIG_RESET_CONTROLLER is not set
# CONFIG_FMC is not set
@@ -801,6 +878,8 @@ CONFIG_ARM_GIC_MAX_NR=1
# PHY Subsystem
#
# CONFIG_GENERIC_PHY is not set
+# end of PHY Subsystem
+
# CONFIG_POWERCAP is not set
# CONFIG_RAS is not set
@@ -808,6 +887,8 @@ CONFIG_ARM_GIC_MAX_NR=1
# Android
#
# CONFIG_ANDROID is not set
+# end of Android
+
# CONFIG_DAX is not set
# CONFIG_NVMEM is not set
@@ -815,10 +896,14 @@ CONFIG_ARM_GIC_MAX_NR=1
# HW tracing support
#
# CONFIG_STM is not set
+# end of HW tracing support
+
# CONFIG_FPGA is not set
# CONFIG_SIOX is not set
# CONFIG_SLIMBUS is not set
# CONFIG_INTERCONNECT is not set
+# CONFIG_COUNTER is not set
+# end of Device Drivers
#
# File systems
@@ -871,6 +956,7 @@ CONFIG_AUTOFS_FS=m
# Caches
#
# CONFIG_FSCACHE is not set
+# end of Caches
#
# CD-ROM/DVD Filesystems
@@ -879,6 +965,7 @@ CONFIG_ISO9660_FS=m
CONFIG_JOLIET=y
# CONFIG_ZISOFS is not set
# CONFIG_UDF_FS is not set
+# end of CD-ROM/DVD Filesystems
#
# DOS/FAT/NT Filesystems
@@ -886,6 +973,7 @@ CONFIG_JOLIET=y
# CONFIG_MSDOS_FS is not set
# CONFIG_VFAT_FS is not set
# CONFIG_NTFS_FS is not set
+# end of DOS/FAT/NT Filesystems
#
# Pseudo filesystems
@@ -902,6 +990,8 @@ CONFIG_TMPFS=y
# CONFIG_TMPFS_XATTR is not set
CONFIG_MEMFD_CREATE=y
# CONFIG_CONFIGFS_FS is not set
+# end of Pseudo filesystems
+
CONFIG_MISC_FILESYSTEMS=y
# CONFIG_ORANGEFS_FS is not set
# CONFIG_ADFS_FS is not set
@@ -981,6 +1071,8 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NLS_MAC_ROMANIAN is not set
# CONFIG_NLS_MAC_TURKISH is not set
# CONFIG_NLS_UTF8 is not set
+# CONFIG_UNICODE is not set
+# end of File systems
#
# Security options
@@ -994,6 +1086,22 @@ CONFIG_HAVE_HARDENED_USERCOPY_ALLOCATOR=y
# CONFIG_STATIC_USERMODEHELPER is not set
CONFIG_DEFAULT_SECURITY_DAC=y
CONFIG_LSM="yama,loadpin,safesetid,integrity"
+
+#
+# Kernel hardening options
+#
+
+#
+# Memory initialization
+#
+CONFIG_INIT_STACK_NONE=y
+# CONFIG_GCC_PLUGIN_STRUCTLEAK_USER is not set
+# CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF is not set
+# CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL is not set
+# end of Memory initialization
+# end of Kernel hardening options
+# end of Security options
+
CONFIG_CRYPTO=y
#
@@ -1012,9 +1120,6 @@ CONFIG_CRYPTO_RNG_DEFAULT=m
CONFIG_CRYPTO_AKCIPHER2=y
CONFIG_CRYPTO_KPP2=y
CONFIG_CRYPTO_ACOMP2=y
-# CONFIG_CRYPTO_RSA is not set
-# CONFIG_CRYPTO_DH is not set
-# CONFIG_CRYPTO_ECDH is not set
CONFIG_CRYPTO_MANAGER=m
CONFIG_CRYPTO_MANAGER2=y
# CONFIG_CRYPTO_USER is not set
@@ -1028,6 +1133,14 @@ CONFIG_CRYPTO_WORKQUEUE=y
# CONFIG_CRYPTO_TEST is not set
#
+# Public-key cryptography
+#
+# CONFIG_CRYPTO_RSA is not set
+# CONFIG_CRYPTO_DH is not set
+# CONFIG_CRYPTO_ECDH is not set
+# CONFIG_CRYPTO_ECRDSA is not set
+
+#
# Authenticated Encryption with Associated Data
#
# CONFIG_CRYPTO_CCM is not set
@@ -1140,13 +1253,16 @@ CONFIG_CRYPTO_HW=y
#
# Certificates for signature checking
#
+# end of Certificates for signature checking
#
# Library routines
#
+# CONFIG_PACKING is not set
CONFIG_BITREVERSE=y
CONFIG_GENERIC_NET_UTILS=y
CONFIG_GENERIC_FIND_FIRST_BIT=y
+# CONFIG_CORDIC is not set
# CONFIG_CRC_CCITT is not set
CONFIG_CRC16=y
# CONFIG_CRC_T10DIF is not set
@@ -1169,11 +1285,11 @@ CONFIG_ARCH_DMA_ADDR_T_64BIT=y
CONFIG_SGL_ALLOC=y
CONFIG_DQL=y
CONFIG_NLATTR=y
-# CONFIG_CORDIC is not set
# CONFIG_DDR is not set
# CONFIG_IRQ_POLL is not set
CONFIG_SBITMAP=y
# CONFIG_STRING_SELFTEST is not set
+# end of Library routines
#
# Kernel hacking
@@ -1188,6 +1304,7 @@ CONFIG_CONSOLE_LOGLEVEL_DEFAULT=7
CONFIG_CONSOLE_LOGLEVEL_QUIET=4
CONFIG_MESSAGE_LOGLEVEL_DEFAULT=4
# CONFIG_BOOT_PRINTK_DELAY is not set
+# end of printk and dmesg options
#
# Compile-time checks and compiler options
@@ -1196,6 +1313,7 @@ CONFIG_DEBUG_INFO=y
# CONFIG_DEBUG_INFO_REDUCED is not set
# CONFIG_DEBUG_INFO_SPLIT is not set
# CONFIG_DEBUG_INFO_DWARF4 is not set
+# CONFIG_DEBUG_INFO_BTF is not set
# CONFIG_GDB_SCRIPTS is not set
CONFIG_ENABLE_MUST_CHECK=y
CONFIG_FRAME_WARN=1024
@@ -1203,13 +1321,17 @@ CONFIG_FRAME_WARN=1024
# CONFIG_READABLE_ASM is not set
# CONFIG_UNUSED_SYMBOLS is not set
# CONFIG_DEBUG_FS is not set
+# CONFIG_OPTIMIZE_INLINING is not set
# CONFIG_DEBUG_SECTION_MISMATCH is not set
CONFIG_SECTION_MISMATCH_WARN_ONLY=y
CONFIG_FRAME_POINTER=y
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
+# end of Compile-time checks and compiler options
+
CONFIG_MAGIC_SYSRQ_DEFAULT_ENABLE=0x1
CONFIG_MAGIC_SYSRQ_SERIAL=y
CONFIG_DEBUG_KERNEL=y
+CONFIG_DEBUG_MISC=y
#
# Memory Debugging
@@ -1227,6 +1349,8 @@ CONFIG_HAVE_DEBUG_KMEMLEAK=y
CONFIG_DEBUG_MEMORY_INIT=y
CONFIG_CC_HAS_KASAN_GENERIC=y
CONFIG_KASAN_STACK=1
+# end of Memory Debugging
+
CONFIG_ARCH_HAS_KCOV=y
CONFIG_CC_HAS_SANCOV_TRACE_PC=y
# CONFIG_KCOV is not set
@@ -1238,6 +1362,8 @@ CONFIG_CC_HAS_SANCOV_TRACE_PC=y
# CONFIG_SOFTLOCKUP_DETECTOR is not set
# CONFIG_DETECT_HUNG_TASK is not set
# CONFIG_WQ_WATCHDOG is not set
+# end of Debug Lockups and Hangs
+
# CONFIG_PANIC_ON_OOPS is not set
CONFIG_PANIC_ON_OOPS_VALUE=0
CONFIG_PANIC_TIMEOUT=0
@@ -1260,13 +1386,15 @@ CONFIG_LOCK_DEBUGGING_SUPPORT=y
# CONFIG_DEBUG_LOCKING_API_SELFTESTS is not set
# CONFIG_LOCK_TORTURE_TEST is not set
# CONFIG_WW_MUTEX_SELFTEST is not set
+# end of Lock Debugging (spinlocks, mutexes, etc...)
+
CONFIG_STACKTRACE=y
# CONFIG_WARN_ALL_UNSEEDED_RANDOM is not set
# CONFIG_DEBUG_KOBJECT is not set
CONFIG_HAVE_DEBUG_BUGVERBOSE=y
CONFIG_DEBUG_BUGVERBOSE=y
# CONFIG_DEBUG_LIST is not set
-# CONFIG_DEBUG_PI_LIST is not set
+# CONFIG_DEBUG_PLIST is not set
# CONFIG_DEBUG_SG is not set
# CONFIG_DEBUG_NOTIFIERS is not set
# CONFIG_DEBUG_CREDENTIALS is not set
@@ -1278,6 +1406,8 @@ CONFIG_DEBUG_BUGVERBOSE=y
# CONFIG_RCU_TORTURE_TEST is not set
# CONFIG_RCU_TRACE is not set
# CONFIG_RCU_EQS_DEBUG is not set
+# end of RCU Debugging
+
# CONFIG_DEBUG_WQ_FORCE_RR_CPU is not set
# CONFIG_DEBUG_BLOCK_EXT_DEVT is not set
# CONFIG_NOTIFIER_ERROR_INJECTION is not set
@@ -1307,6 +1437,7 @@ CONFIG_RUNTIME_TESTING_MENU=y
# CONFIG_ATOMIC64_SELFTEST is not set
# CONFIG_TEST_HEXDUMP is not set
# CONFIG_TEST_STRING_HELPERS is not set
+# CONFIG_TEST_STRSCPY is not set
# CONFIG_TEST_KSTRTOX is not set
# CONFIG_TEST_PRINTF is not set
# CONFIG_TEST_BITMAP is not set
@@ -1336,3 +1467,4 @@ CONFIG_UBSAN_ALIGNMENT=y
# CONFIG_GPROF is not set
# CONFIG_GCOV is not set
CONFIG_EARLY_PRINTK=y
+# end of Kernel hacking
diff --git a/modules.install b/modules.install
deleted file mode 100644
index ed65aadf06eb..000000000000
--- a/modules.install
+++ /dev/null
@@ -1,11 +0,0 @@
-KERNEL_VERSION=5.1.5-1-usermodelinux
-
-post_install() {
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
-}
-
-post_upgrade() {
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
-}