aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Weiman2017-08-29 13:42:02 -0400
committerMark Weiman2017-08-29 13:42:02 -0400
commit10f8ccd901c31702ce41074000bb5f5bc19131b3 (patch)
tree4302a2990a1fca6d2d3e568da72f9c33f40e5239
parentd78dc42ab89b1965553a51615a8a8a50d9b6b82e (diff)
downloadaur-10f8ccd901c31702ce41074000bb5f5bc19131b3.tar.gz
Update to 4.12.8-1
-rw-r--r--PKGBUILD18
-rw-r--r--README5
-rw-r--r--bonding-ratelimit-failed-speed-duplex-update-warning.patch47
-rw-r--r--bonding-require-speed-duplex-only-for-802.3ad-alb-an.patch68
-rw-r--r--mm-Revert-x86_64-and-arm64-ELF_ET_DYN_BASE-base.patch35
5 files changed, 166 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97a45bf9e3a1..54f03ffe96e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-vfio
_srcname=linux-4.12
-pkgver=4.12.6
+pkgver=4.12.8
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -14,6 +14,9 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+ 'bonding-require-speed-duplex-only-for-802.3ad-alb-an.patch'
+ 'bonding-ratelimit-failed-speed-duplex-update-warning.patch'
+ 'mm-Revert-x86_64-and-arm64-ELF_ET_DYN_BASE-base.patch'
# the main kernel config files
'config' 'config.x86_64'
# pacman hook for initramfs regeneration
@@ -25,8 +28,11 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'i915-vga-arbiter.patch')
sha256sums=('a45c3becd4d08ce411c14628a949d08e2433d8cdeca92036c7013980e93858ab'
'SKIP'
- '60938af0f95ae794f879294f2393c48077c01bdba851e80b085fdc0418eeca44'
+ '32b860911a3bafd5cd5bc813a427c90fad6eafdf607fa64e1b763b16ab605636'
'SKIP'
+ '48e0505438bb4ccc7a0e050a896122b490e8f1b1446aa3833841a9d4d7853d68'
+ 'fc606711a922638d5cc4358f47f69f554d9e6eab1cec91f0b49f00911f399722'
+ 'b830ce777543c0edd20a77d70f204c095f2429bb37151cd4a8c9dfae2af8d51a'
'df55887a43dcbb6bd35fd2fb1ec841427b6ea827334c0880cbc256d4f042a7a1'
'bf84528c592d1841bba0662242f0339a24a1de384c31f28248631e8be9446586'
'8f407ad5ff6eff106562ba001c36a281134ac9aa468a596aea660a4fe1fd60b5'
@@ -49,6 +55,14 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+ # https://bugzilla.kernel.org/show_bug.cgi?id=196547
+ patch -Np1 -i ../bonding-ratelimit-failed-speed-duplex-update-warning.patch
+ patch -Np1 -i ../bonding-require-speed-duplex-only-for-802.3ad-alb-an.patch
+
+ # https://github.com/google/sanitizers/issues/837
+ # https://patchwork.kernel.org/patch/9886105/
+ patch -Np1 -i ../mm-Revert-x86_64-and-arm64-ELF_ET_DYN_BASE-base.patch
+
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
else
diff --git a/README b/README
deleted file mode 100644
index 4ba03927663b..000000000000
--- a/README
+++ /dev/null
@@ -1,5 +0,0 @@
-This is an Arch Linux PKGBUILD that tracks the repositoriy kernel version but
-has the necessary patches applied to allow GPU passthrough with KVM using
-vfio.
-
-See https://bbs.archlinux.org/viewtopic.php?id=162768 for more info.
diff --git a/bonding-ratelimit-failed-speed-duplex-update-warning.patch b/bonding-ratelimit-failed-speed-duplex-update-warning.patch
new file mode 100644
index 000000000000..c1a8bc5b47e6
--- /dev/null
+++ b/bonding-ratelimit-failed-speed-duplex-update-warning.patch
@@ -0,0 +1,47 @@
+From 11e9d7829dd08dbafb24517fe922f11c3a8a9dc2 Mon Sep 17 00:00:00 2001
+From: Andreas Born <futur.andy@googlemail.com>
+Date: Sat, 12 Aug 2017 00:36:55 +0200
+Subject: [PATCH] bonding: ratelimit failed speed/duplex update warning
+
+bond_miimon_commit() handles the UP transition for each slave of a bond
+in the case of MII. It is triggered 10 times per second for the default
+MII Polling interval of 100ms. For device drivers that do not implement
+__ethtool_get_link_ksettings() the call to bond_update_speed_duplex()
+fails persistently while the MII status could remain UP. That is, in
+this and other cases where the speed/duplex update keeps failing over a
+longer period of time while the MII state is UP, a warning is printed
+every MII polling interval.
+
+To address these excessive warnings net_ratelimit() should be used.
+Printing a warning once would not be sufficient since the call to
+bond_update_speed_duplex() could recover to succeed and fail again
+later. In that case there would be no new indication what went wrong.
+
+Fixes: b5bf0f5b16b9c (bonding: correctly update link status during mii-commit phase)
+Signed-off-by: Andreas Born <futur.andy@googlemail.com>
+Signed-off-by: David S. Miller <davem@davemloft.net>
+---
+ drivers/net/bonding/bond_main.c | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/drivers/net/bonding/bond_main.c b/drivers/net/bonding/bond_main.c
+index 85bb272d2a34..fc63992ab0e0 100644
+--- a/drivers/net/bonding/bond_main.c
++++ b/drivers/net/bonding/bond_main.c
+@@ -2144,9 +2144,10 @@ static void bond_miimon_commit(struct bonding *bond)
+ if (bond_update_speed_duplex(slave) &&
+ bond_needs_speed_duplex(bond)) {
+ slave->link = BOND_LINK_DOWN;
+- netdev_warn(bond->dev,
+- "failed to get link speed/duplex for %s\n",
+- slave->dev->name);
++ if (net_ratelimit())
++ netdev_warn(bond->dev,
++ "failed to get link speed/duplex for %s\n",
++ slave->dev->name);
+ continue;
+ }
+ bond_set_slave_link_state(slave, BOND_LINK_UP,
+--
+2.14.1
+
diff --git a/bonding-require-speed-duplex-only-for-802.3ad-alb-an.patch b/bonding-require-speed-duplex-only-for-802.3ad-alb-an.patch
new file mode 100644
index 000000000000..09028515b84f
--- /dev/null
+++ b/bonding-require-speed-duplex-only-for-802.3ad-alb-an.patch
@@ -0,0 +1,68 @@
+From ad729bc9acfb7c47112964b4877ef5404578ed13 Mon Sep 17 00:00:00 2001
+From: Andreas Born <futur.andy@googlemail.com>
+Date: Thu, 10 Aug 2017 06:41:44 +0200
+Subject: [PATCH] bonding: require speed/duplex only for 802.3ad, alb and tlb
+
+The patch c4adfc822bf5 ("bonding: make speed, duplex setting consistent
+with link state") puts the link state to down if
+bond_update_speed_duplex() cannot retrieve speed and duplex settings.
+Assumably the patch was written with 802.3ad mode in mind which relies
+on link speed/duplex settings. For other modes like active-backup these
+settings are not required. Thus, only for these other modes, this patch
+reintroduces support for slaves that do not support reporting speed or
+duplex such as wireless devices. This fixes the regression reported in
+bug 196547 (https://bugzilla.kernel.org/show_bug.cgi?id=196547).
+
+Fixes: c4adfc822bf5 ("bonding: make speed, duplex setting consistent
+with link state")
+Signed-off-by: Andreas Born <futur.andy@googlemail.com>
+Acked-by: Mahesh Bandewar <maheshb@google.com>
+Signed-off-by: David S. Miller <davem@davemloft.net>
+---
+ drivers/net/bonding/bond_main.c | 6 ++++--
+ include/net/bonding.h | 5 +++++
+ 2 files changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/drivers/net/bonding/bond_main.c b/drivers/net/bonding/bond_main.c
+index 9bee6c1c70cc..85bb272d2a34 100644
+--- a/drivers/net/bonding/bond_main.c
++++ b/drivers/net/bonding/bond_main.c
+@@ -1569,7 +1569,8 @@ int bond_enslave(struct net_device *bond_dev, struct net_device *slave_dev)
+ new_slave->delay = 0;
+ new_slave->link_failure_count = 0;
+
+- if (bond_update_speed_duplex(new_slave))
++ if (bond_update_speed_duplex(new_slave) &&
++ bond_needs_speed_duplex(bond))
+ new_slave->link = BOND_LINK_DOWN;
+
+ new_slave->last_rx = jiffies -
+@@ -2140,7 +2141,8 @@ static void bond_miimon_commit(struct bonding *bond)
+ continue;
+
+ case BOND_LINK_UP:
+- if (bond_update_speed_duplex(slave)) {
++ if (bond_update_speed_duplex(slave) &&
++ bond_needs_speed_duplex(bond)) {
+ slave->link = BOND_LINK_DOWN;
+ netdev_warn(bond->dev,
+ "failed to get link speed/duplex for %s\n",
+diff --git a/include/net/bonding.h b/include/net/bonding.h
+index b00508d22e0a..b2e68657a216 100644
+--- a/include/net/bonding.h
++++ b/include/net/bonding.h
+@@ -277,6 +277,11 @@ static inline bool bond_is_lb(const struct bonding *bond)
+ BOND_MODE(bond) == BOND_MODE_ALB;
+ }
+
++static inline bool bond_needs_speed_duplex(const struct bonding *bond)
++{
++ return BOND_MODE(bond) == BOND_MODE_8023AD || bond_is_lb(bond);
++}
++
+ static inline bool bond_is_nondyn_tlb(const struct bonding *bond)
+ {
+ return (BOND_MODE(bond) == BOND_MODE_TLB) &&
+--
+2.14.1
+
diff --git a/mm-Revert-x86_64-and-arm64-ELF_ET_DYN_BASE-base.patch b/mm-Revert-x86_64-and-arm64-ELF_ET_DYN_BASE-base.patch
new file mode 100644
index 000000000000..bf089e08adc6
--- /dev/null
+++ b/mm-Revert-x86_64-and-arm64-ELF_ET_DYN_BASE-base.patch
@@ -0,0 +1,35 @@
+diff --git a/arch/arm64/include/asm/elf.h b/arch/arm64/include/asm/elf.h
+index acae781f7359..3288c2b36731 100644
+--- a/arch/arm64/include/asm/elf.h
++++ b/arch/arm64/include/asm/elf.h
+@@ -114,10 +114,10 @@
+
+ /*
+ * This is the base location for PIE (ET_DYN with INTERP) loads. On
+- * 64-bit, this is raised to 4GB to leave the entire 32-bit address
++ * 64-bit, this is above 4GB to leave the entire 32-bit address
+ * space open for things that want to use the area for 32-bit pointers.
+ */
+-#define ELF_ET_DYN_BASE 0x100000000UL
++#define ELF_ET_DYN_BASE (2 * TASK_SIZE_64 / 3)
+
+ #ifndef __ASSEMBLY__
+
+diff --git a/arch/x86/include/asm/elf.h b/arch/x86/include/asm/elf.h
+index 1c18d83d3f09..9aeb91935ce0 100644
+--- a/arch/x86/include/asm/elf.h
++++ b/arch/x86/include/asm/elf.h
+@@ -247,11 +247,11 @@ extern int force_personality32;
+
+ /*
+ * This is the base location for PIE (ET_DYN with INTERP) loads. On
+- * 64-bit, this is raised to 4GB to leave the entire 32-bit address
++ * 64-bit, this is above 4GB to leave the entire 32-bit address
+ * space open for things that want to use the area for 32-bit pointers.
+ */
+ #define ELF_ET_DYN_BASE (mmap_is_ia32() ? 0x000400000UL : \
+- 0x100000000UL)
++ (TASK_SIZE / 3 * 2))
+
+ /* This yields a mask that user programs can use to figure out what
+ instruction set this CPU supports. This could be done in user space,