aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Weiman2020-05-06 16:25:21 -0400
committerMark Weiman2020-05-06 16:25:21 -0400
commitc580c0ca71ad7f64191f74606eaff7ab757f0700 (patch)
treeb74f1caf1b8ded9f11dafbfaf9fa3acb99893fba
parent315412ae0c5e84afcd1d2032d5ddc852dabdf578 (diff)
downloadaur-c580c0ca71ad7f64191f74606eaff7ab757f0700.tar.gz
Revision to 5.6.10.arch1-1
The previous commit seemed to have issues building in a clean chroot. This commit takes on the exact patch used in the linux package as well as remakes the add-acs-overrides.patch file to a form usable by `git am` as was done in previous iterations of this patch.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--add-acs-overrides.patch15
-rw-r--r--sphinx-workaround.patch10
4 files changed, 12 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8be6fa2c13f6..bee01f02ea4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,9 +25,9 @@ pkgbase = linux-vfio
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha256sums = SKIP
sha256sums = f392c9ecbb5177ea2573aaf22935322940ea2be0366f3fb9c9f861431f4aed21
- sha256sums = 1f11475db0778b7c4a4d6b07c86c2421ea01a653d6ee18d564204903d1ec0a8b
+ sha256sums = 0352f4a52166bef96ac5b4ff1d2bcb61efd9580803af57ce0f3019565daa0bc2
sha256sums = 094a29902b52cec2f0840219225a1458ca925f875524ecb7827da62a33c74ccf
- sha256sums = e2e2e64ed4b716046a999b880fe41def580eca89fb6eb412ed141d2d3c7715da
+ sha256sums = 8cb21e0b3411327b627a9dd15b8eb773295a0d2782b1a41b2a8839d1b2f5778c
pkgname = linux-vfio
pkgdesc = The Linux kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index e630eb29a5db..c4c7503f56a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,9 +32,9 @@ validpgpkeys=(
)
sha256sums=('SKIP'
'f392c9ecbb5177ea2573aaf22935322940ea2be0366f3fb9c9f861431f4aed21'
- '1f11475db0778b7c4a4d6b07c86c2421ea01a653d6ee18d564204903d1ec0a8b'
+ '0352f4a52166bef96ac5b4ff1d2bcb61efd9580803af57ce0f3019565daa0bc2'
'094a29902b52cec2f0840219225a1458ca925f875524ecb7827da62a33c74ccf'
- 'e2e2e64ed4b716046a999b880fe41def580eca89fb6eb412ed141d2d3c7715da')
+ '8cb21e0b3411327b627a9dd15b8eb773295a0d2782b1a41b2a8839d1b2f5778c')
export KBUILD_BUILD_HOST=archlinux
diff --git a/add-acs-overrides.patch b/add-acs-overrides.patch
index ce4efd0f19b0..4b3fbd58dd81 100644
--- a/add-acs-overrides.patch
+++ b/add-acs-overrides.patch
@@ -1,7 +1,7 @@
-From f56f33917f418568141184eb2503ec65309a8255 Mon Sep 17 00:00:00 2001
+From 169ce1a1bf376ba90cd0ab51ec19f9e32ead9dcb Mon Sep 17 00:00:00 2001
From: Mark Weiman <mark.weiman@markzz.com>
-Date: Thu, 13 Dec 2018 13:15:16 -0500
-Subject: [PATCH] pci: Enable overrides for missing ACS capabilities (4.18)
+Date: Wed, 6 May 2020 15:40:50 -0400
+Subject: [PATCH] pci: Enable overrides for missing ACS capabilities (5.6.9+)
This an updated version of Alex Williamson's patch from:
https://lkml.org/lkml/2013/5/30/513
@@ -50,7 +50,7 @@ your customers the hassle of this boot option.
2 files changed, 110 insertions(+)
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
-index 0c404cda531a..0d45f0014f4a 100644
+index 20aac805e197..e625ef816cf7 100644
--- a/Documentation/admin-guide/kernel-parameters.txt
+++ b/Documentation/admin-guide/kernel-parameters.txt
@@ -3472,6 +3472,14 @@
@@ -69,7 +69,7 @@ index 0c404cda531a..0d45f0014f4a 100644
Safety option to keep boot IRQs enabled. This
should never be necessary.
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
-index fbeb9f73ef28..3bf409c65609 100644
+index ca9ed5774eb1..4567b0e8f2de 100644
--- a/drivers/pci/quirks.c
+++ b/drivers/pci/quirks.c
@@ -192,6 +192,106 @@ static int __init pci_apply_final_quirks(void)
@@ -187,6 +187,7 @@ index fbeb9f73ef28..3bf409c65609 100644
+ { PCI_ANY_ID, PCI_ANY_ID, pcie_acs_overrides },
{ 0 }
};
+
+--
+2.26.2
---
-5.6.10
diff --git a/sphinx-workaround.patch b/sphinx-workaround.patch
index 44265cdb3f04..1aa3f1c8f66e 100644
--- a/sphinx-workaround.patch
+++ b/sphinx-workaround.patch
@@ -1,13 +1,3 @@
-`make htmldocs` is broken again and this is a temporary fix for that. the html
-docs may be malformed but at least it builds without error ¯\_(ツ)_/¯
-
-source: https://bugs.archlinux.org/task/66156#comment188161
-upstream issue: https://github.com/sphinx-doc/sphinx/issues/7421
-
-this should be removed once the issue is resolved. note that there will be a lot
-more errors/warnings than usual due to ripping such an integral part out of
-the docs parser.
-
diff --git i/Documentation/conf.py w/Documentation/conf.py
index 3c7bdf4cd31f..9a0ced58a3e9 100644
--- i/Documentation/conf.py